This discussion is archived
6 Replies Latest reply: Aug 27, 2012 6:01 PM by Dude! RSS

Gnome automount and media.repo under Oracle Linux 6.3

Dude! Guru
Currently Being Moderated
Hello,

I experiencing a strange behavior testing the following under Oracle Linux 6.3 (x86-64-bit) UEK2 with all latest updates. I selected the Gnome desktop packages using the "customize now" ratio button when installing the OS

* Log in to a graphical shell such as GNOME
* Insert addition media disk into the computer
* Observe the media is mounted by the session
* Wait a couple of seconds
* Observe the /etc/yum.repos.d/packagekit-media.repo now exists

The above is explained in more details at http://people.redhat.com/rhughes/media-repo.txt

I don't know what the "addition media disk" is, but inserted the Oracle Linux 6.3 x86_64 binary distribution DVD, which also has media.repo file in the root directory. And btw, I'm using VirtualBox and the DVD is an .iso disk image.

I'm experiencing the following:

Gnome automount works and automatically opens the DVD when inserted.
It does not create the /etc/yum.repos.d/packagekit-media.repo file.

It actually does create the named repo file, but only after one waits about 15 minutes. Perhaps this has anything to do with gpk-update-icon, but when run manually it hangs.

With the packagekit-media.repo file finally created. The gpk-application however complains: "The group list was invalid".

I know how to create a yum configuration file pointing to a local repository, which is also coverd in the Oracle Linux 6.3 distribution readme. I just wonder about the problem. Th automatic business with the media.repo file seems broken and useless. I did one more test using the original RHEL kernel which, as expected, did not make a difference.

Does anyone know more about it?

Thanks!
  • 1. Re: Gnome automount and media.repo under Oracle Linux 6.3
    TommyReynolds Expert
    Currently Being Moderated
    Odd, I have two different ISO versions of 6.3; there may have been a respin:
    $ sha1sum *.iso
    f43128d8f14bd22a16e78b473cc9a1decd251e70  OracleLinux-R6-U3-Server-i386-dvd.iso
    7daae91cc0437f6a98a4359ad9706d678a9f19de  OracleLinux-R6-U3-Server-x86_64-dvd.iso
    These are for the currently-available ISO's. What do your ISO's show?
  • 2. Re: Gnome automount and media.repo under Oracle Linux 6.3
    Avi Miller Guru
    Currently Being Moderated
    Dude wrote:
    I don't know what the "addition media disk" is, but inserted the Oracle Linux 6.3 x86_64 binary distribution DVD, which also has media.repo file in the root directory. And btw, I'm using VirtualBox and the DVD is an .iso disk image.
    Red Hat ships additional media disks to cover their additional paid-for options, e.g. High Availability (RHCS) and other components. Oracle Linux doesn't ship any additional media disks, so the media-repo.txt stuff isn't applicable.
  • 3. Re: Gnome automount and media.repo under Oracle Linux 6.3
    Dude! Guru
    Currently Being Moderated
    I have the same checksum for the x86_64 installation DVD. I have not tried it with the 32-bit version.
  • 4. Re: Gnome automount and media.repo under Oracle Linux 6.3
    Dude! Guru
    Currently Being Moderated
    As far as I understand, the gnome packagekit is not Red Hat specific. So why would the media-repo business be different for Red Hat media?

    I did a bit of research and found the following: Apparently the diskinfo and the mediaid of the Oracle Linux 6.3 installation DVD do not match. I don't know if this could be the reason for the strange issue with gpk-update-icon creating the /etc/yum.repos.d/packagekit-media.repo file, but it might explain why the repo file does not work.


    # cat .discinfo
    1340764523.288408
    Oracle Linux 6.3
    x86_64
    1

    # cat media.repo
    [InstallMedia]
    name=Oracle Linux 6.3
    mediaid=1340762685.87
    metadata_expire=-1
    gpgcheck=0
    cost=500
    [InstallMedia]
    name=Oracle Linux 6.3
    mediaid=1340764248.23
    metadata_expire=-1
    gpgcheck=0
    cost=500
  • 5. Re: Gnome automount and media.repo under Oracle Linux 6.3
    Avi Miller Guru
    Currently Being Moderated
    Dude wrote:
    I did a bit of research and found the following: Apparently the diskinfo and the mediaid of the Oracle Linux 6.3 installation DVD do not match. I don't know if this could be the reason for the strange issue with gpk-update-icon creating the /etc/yum.repos.d/packagekit-media.repo file, but it might explain why the repo file does not work.
    Do you have Oracle Linux support? If so, I'd love it if you would open an SR for this. :)
  • 6. Re: Gnome automount and media.repo under Oracle Linux 6.3
    Dude! Guru
    Currently Being Moderated
    I cannot create an SR, but I did some more tests creating my own DVD, playing with the info in the media.repo file. It seems matching the mediaid and .discinfo information alone doesn't fix it.

    Actually some of the stuff is explained in the link I already used: http://people.redhat.com/rhughes/media-repo.txt. The problem seems that it doesn't work as advertised.

    It takes exactly 15 min. before the system (gnome) automatically copies the media.repo file from DVD to /etc/packagekit-media.repo. If the file already exists it gets overwritten.

    I think it might be a good idea to make an entry in the media.repo file on the DVD, such as:

    baseurl=file:///media/<disklabel>
    skip_if_unavailable=True

    Then when inserting the DVD under gnome it would not be necessary to create a yum repository configuration file to use the DVD. The 15 min. delay will have to be fixed, which is only supposed to take a couple of seconds.

    Edited by: Dude on Aug 27, 2012 5:51 PM

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points