This discussion is archived
2 Replies Latest reply: Aug 31, 2012 1:23 AM by user469 RSS

7410 booting directly to grub command line after forced restart?

955603 Newbie
Currently Being Moderated
I'm running a 7410 (2x 100gb SSDs and 2x 500gb sata) with a j4400 containing 24 1tb drives. I attempted to create a pool and the bui hung so I went back to the SP and did a stop /SYS. After doing a start /SYS then starting the console, it goes through the bios startup, then initializes the external SAS card and after that immediately drops into the grub command line. There's no grub menu or anything, just the CL. Any idea how I can get back into the 7000 appliance software? As you can undoubtedly tell, I'm kind of a newbie so any help will be greatly appreciated!
  • 1. Re: 7410 booting directly to grub command line after forced restart?
    bigbadjohnnyb Newbie
    Currently Being Moderated
    I did something SORTA similar on a 7320, lost a peer node and it went crazy on me. I ended up doing a HARD reset, somehow it magically came back to life.

    I'm sure pretty late for you...
  • 2. Re: 7410 booting directly to grub command line after forced restart?
    user469 Newbie
    Currently Being Moderated
    Not much documented and you must know your ak-nas-version

    findroot (system,0,a)
    bootfs system/boot/ak-nas-2009.04.10.5.0_1-1.20
    kernel$ /platform/i86pc/kernel/$ISADIR/unix -B ak_undo=true,zfs-bootfs=system/121,console=ttya,ttya-mode="9600,8,n,1,-"
    module$ /platform/i86pc/$ISADIR/boot_archive

    7xxx kernel$ /platform/i86pc/kernel/$ISADIR/unix -B ak_undo=true,zfs-bootfs=system/77,console=ttya,ttya-mode="9600,8,n,1,-"
    7110 kernel$ /platform/i86pc/kernel/$ISADIR/unix -B ak_undo=true,zfs-bootfs=system/90,console=ttya,ttya-mode="9600,8,n,1,-"
    7410 kernel$ /platform/i86pc/kernel/$ISADIR/unix -B ak_undo=true,zfs-bootfs=system/121,console=ttya,ttya-mode="9600,8,n,1,-"

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points