1 2 Previous Next 20 Replies Latest reply: Aug 29, 2012 11:57 PM by Osama_Mustafa Go to original post RSS
      • 15. Re: Can't use xe as sid
        Osama_Mustafa
        Add this to sqlnet.ora
        SQLNET.INBOUND_CONNECT_TIMEOUT=0 and try to connect
        • 16. Re: Can't use xe as sid
          HuaMin Chen
          Thanks.

          I've created this file
          [HuaMin@localhost ~]$ cd /u01/app/oracle/product/11.2.0/xe/network/admin
          [HuaMin@localhost admin]$ cat sqlnet.ora
          SQLNET.INBOUND_CONNECT_TIMEOUT=0

          and have restarted the machine but I still get this.
          SQL> conn system as sysdba
          Enter password:
          Connected.
          SQL> conn system@xe as sysdba
          Enter password:
          ERROR:
          ORA-12170: TNS:Connect timeout occurred


          Warning: You are no longer connected to ORACLE.

          Edited by: HuaMin Chen on Aug 29, 2012 3:39 PM
          • 17. Re: Can't use xe as sid
            Paul M.
            If your database is not registered with the listener, you'll never be able to connect using a connection string. So, you have to understand why this happens.

            BTW, from your posts it's not clear what's your IP address (different values in different posts).

            Please post your listener.ora and */etc/hosts*.

            Do you have any active firewall on your machine ?
            • 18. Re: Can't use xe as sid
              HuaMin Chen
              Good day Paul,
              I did do the register in the way Osama mentioned.
              The IP changed as the IP was reallocated every day but I did put the current IP in the listener.ora file and then had restarted the machine to do the test.

              Here is /etc/hosts

              127.0.0.1 localhost.localdomain localhost
              ::1 localhost6.localdomain6 localhost6

              Here is listener.ora
              SID_LIST_LISTENER =
              (SID_LIST =
              (SID_DESC =
              (SID_NAME = PLSExtProc)
              (ORACLE_HOME = /u01/app/oracle/product/11.2.0/xe)
              (PROGRAM = extproc)
              )
              )

              LISTENER =
              (DESCRIPTION_LIST =
              (DESCRIPTION =
              (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC_FOR_XE))
              (ADDRESS = (PROTOCOL = TCP)(HOST = ?.?.254.241)(PORT = 1521))
              # (ADDRESS = (PROTOCOL = TCP)(HOST = localhost.localdomain)(PORT = 1521))
              )
              )

              DEFAULT_SERVICE_LISTENER = (XE)

              Do I need to disable the firewall?


              Many Thanks & Best Regards,
              HuaMin

              Edited by: HuaMin Chen on Aug 30, 2012 1:10 PM
              • 19. Re: Can't use xe as sid
                Osama_Mustafa
                 The IP changed as the IP was reallocated every day but I did put the current IP in the listener.ora file and then restarted the machine.
                Why ? do you have DHCP or what ? And yes sometimes firewall prevent connections , so i think its deserve to give it try .
                • 20. Re: Can't use xe as sid
                  HuaMin Chen
                  Thanks. After I've disabled the firewall and then retry it, I still get these
                  SQL> conn system/??? as sysdba
                  Connected.
                  SQL> conn system/???@xe as sysdba
                  ERROR:
                  ORA-12543: TNS:destination host unreachable


                  Warning: You are no longer connected to ORACLE.

                  Many Thanks & Best Regards,
                  HuaMin

                  Edited by: HuaMin Chen on Sep 20, 2012 10:37 AM
                  1 2 Previous Next