1 2 Previous Next 15 Replies Latest reply: Sep 7, 2012 2:55 PM by JorgeB-Oracle Go to original post RSS
      • 15. Re: Incramental inferencing question
        JorgeB-Oracle
        SR 3-6158861971

        When creating an entailment using the option of incremental inference and issuing the CREATE_ENTAILMENT the second time to do the incremental inference using the delta_in parameter, the triples are being saved in the second model in the sem_models parameter instead of the first model.

        create table c_tpl(triple sdo_rdf_triple_s) compress;
        exec sem_apis.create_sem_model('c','c_tpl','triple');

        create table c_new_tpl(triple sdo_rdf_triple_s) compress;
        exec sem_apis.create_sem_model('c_new','c_new_tpl','triple');

        create table d_tpl(triple sdo_rdf_triple_s) compress;
        exec sem_apis.create_sem_model('d','d_tpl','triple');

        create table d_new_tpl(triple sdo_rdf_triple_s) compress;
        exec sem_apis.create_sem_model('d_new','d_new_tpl','triple');

        EXECUTE sem_apis.create_entailment ('d_IDX',sem_models('d','c'), sem_rulebases('OWLPRIME'),null,null, 'INC=T');

        select count(1) from mdsys.rdfm_c;
        --returns 0
        select count(1) from mdsys.rdfm_d;
        --returns 0
        select count(1) from mdsys.rdfi_d_idx;
        --returns 0

        insert into c_new_tpl(triple) values(sdo_rdf_triple_s('c_new','<urn:C1>','rdfs:subClassOf','<urn:C6>'));
        insert into d_new_tpl(triple) values(sdo_rdf_triple_s('d_new','<urn:C1>','rdfs:subClassOf','<urn:C7>'));
        commit;

        EXECUTE sem_apis.create_entailment('d_IDX', sem_models('d','c'), sem_rulebases('OWLPRIME'), SEM_APIS.REACH_CLOSURE, null, options => 'INC=T', delta_in => sem_models('d_NEW','c_new'));

        select count(1) from mdsys.rdfm_c;
        --returns 2
        select count(1) from mdsys.rdfm_c_new;
        --returns 1
        select count(1) from mdsys.rdfm_d;
        --returns 0
        select count(1) from mdsys.rdfm_d_new;
        --returns 1
        select count(1) from mdsys.rdfi_d_idx;
        --returns 0

        "d" model is empty (see the count 0)
        Expecting the 2 new rows to be in here instead of "c" model

        Filing bug, please follow up on SR/bug
        Thanks!
        Jorge
        1 2 Previous Next