7 Replies Latest reply on Sep 7, 2012 8:52 PM by tx103108

    Linux to Windows connectivity issue

      DB: Oracle EE 11gR2 running on OEL 5.3
      GATEWAY: ODBC 11gr2 running on WindowsXP SP3
      DB Link>=SID=> TXEIS

      tnsping TXEIS never returns when called from Linux trying to connect/tnsping to gateway running on Windows. Locally on Windows I can tnsping TXEIS w/o any issues.

      On Linux (tnsnames.ora):
      TXEIS =
      (ADDRESS = (PROTOCOL = TCP)(HOST = sybasetest.region10.org)(PORT = 1522))
      (SID = TXEIS))

      On Windows (listener.ora):
      (SID_LIST =
      (SID_DESC =
      (SID_NAME = TXEIS)
      (ORACLE_HOME = C:\oraclexe\app\oracle\product\11.2.0\gtw)
      (PROGRAM = dg4odbc)

      LISTENER =
      (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1522))

      ADR_BASE_LISTENER = C:\oraclexe\app\oracle\product\11.2.0\gtw

      On Windows (initTXEIS.ora):
      #HS_FDS_TRACE_LEVEL = debug


      Please advise and thank you.
        • 1. Re: Linux to Windows connectivity issue
          The first problem is the gateway listener on your Windows machine. It only listens on the localhost address:
          (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1522))

          When you want to connect from another machine you need to specify the real hostname in the listeners address list. Once changed, please stop and start the listener on the Windows machine. Then test again with ping <hostname> and tnsping txeis both commands executed from the Linux box.
          • 2. Re: Linux to Windows connectivity issue
            I had already tried the computer name and IP address of the Windows Server and under both circumstances the the Linux Server still could not see the service in the Windows Server.

            tnsping from Linux server just hangs -- see below (IP address of Windows server masked for security). IP address is a virtual external address (it gets translated at the router to an internal address).

            oracle@empower01.region10.org:/u01/app/oracle/product/11.1/db_1/network/admin> tnsping TXEIS

            TNS Ping Utility for Linux: Version - Production on 31-AUG-2012 13:22:22

            Copyright (c) 1997, 2008, Oracle. All rights reserved.

            Used parameter files:

            Used TNSNAMES adapter to resolve the alias
            Attempting to contact (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = 123.456.768.887)(PORT = 1522)) (CONNECT_DATA = (SID = TXEIS)) (HS=OK))

            Edited by: user601798 on Aug 31, 2012 11:22 AM
            • 3. Re: Linux to Windows connectivity issue
              Did you change the HOST name in the listener.ora on Windows from -

              (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1522))

              to -

              (ADDRESS = (PROTOCOL = TCP)(HOST = <actual name or IP address>)(PORT = 1522))

              and then stop and start the listener ?
              What happens if you 'ping' the Windows name or IP address fron Linux -

              ping <Windows IP address>

              Try a 'ping' and not just a 'tnsping'. If 'ping' doesn't work then the gateway connection will not work.
              Is there a firewall between Linux and Windows ?

              • 4. Re: Linux to Windows connectivity issue
                Listener host changed to ip address where gateway listener is running (on Windows server). Listener restarted.
                'ping' connects successfully from server to Windows system as well.

                Still can not tnsping from Linux (and even tried from another Windows system) to gateway listener on Windows server.

                The windows server with the gateway is on another network but there is a virtual IP address setup that we are using from the Linux box to access this windows server with the gateway listener. That is, by virtue of the VIP, all systems are on the same network.

                Edited by: user601798 on Sep 6, 2012 3:36 PM
                • 5. Re: Linux to Windows connectivity issue
                  please provide the "ping" output that shows which address you're using to ping the Windows host, your current listener.ora configuration and try to telnet to the Oracle listener from your Linux box ("telnet <Windows IP address> <port>").
                  Also please provide from your Windows machine the netstat -a output.

                  BTW, is there a Firewall running on the Windows machine?
                  • 6. Re: Linux to Windows connectivity issue
                    I am trying now to connect from Windows in an effort to eliminate any Linux-specific issues.

                    From Windows 7:
                    I can ping to the server successfully.
                    No firewall - on same subnet.
                    I can RDP (from Windows) to that server w/o issues.

                    Below is the tnsping trace file, 'admin' level:

                    TNS Ping Utility for 32-bit Windows: Version - Production on 07-SEP-2012 12:31:19

                    Copyright (c) 1997, 2010, Oracle. All rights reserved.

                    New trace stream is C:\oraclexe\app\oracle\product\11.2.0\server\network\ADMIN\tnsping.trc
                    New trace level is 6
                    Attempted load of system pfile source C:\oraclexe\app\oracle\product\11.2.0\server\network\admin\sqlnet.ora
                    Parameter source loaded successfully

                    Successful parameter table load
                    TNSPING.TRACE_LEVEL = admin
                    NAMES.DIRECTORY_PATH = (TNSNAMES)
                    TNSPING.TRACE_DIRECTORY = C:\oraclexe\app\oracle\product\11.2.0\server\network\ADMIN
                    --- PARAMETER SOURCE INFORMATION ENDS ---
                    Log stream will be "standard output"
                    Log stream validation not requested
                    --- LOG CONFIGURATION INFORMATION ENDS ---

                    nlstdipi: entry
                    nlstdipi: exit
                    nnfun2awanm: entry
                    nnfgiinit: entry
                    nncpcin_maybe_init: default name server domain is [root]
                    nnfgiinit: Installing read path
                    nnfgsrsp: entry
                    nnfgsrsp: Obtaining path parameter from names.directory_path or native_names.directory_path
                    nnfgsrdp: entry
                    nnfgsrdp: Setting path:
                    nnfgsrdp: checking element TNSNAMES
                    nnfgsrdp: Path set
                    nnfun2a: entry
                    nlolgobj: entry
                    nnfgrne: entry
                    nnfgrne: Going though read path adapters
                    nnfgrne: Switching to TNSNAMES adapter
                    nnftboot: entry
                    nlpaxini: entry
                    nlpaxini: exit
                    nnftmlf_make_local_addrfile: entry
                    nnftmlf_make_local_addrfile: construction of local names file failed
                    nnftmlf_make_local_addrfile: exit
                    nlpaxini: entry
                    nlpaxini: exit
                    nnftmlf_make_system_addrfile: entry
                    nnftmlf_make_system_addrfile: system names file is C:\oraclexe\app\oracle\product\11.2.0\server\network\admin\tnsnames.ora
                    nnftmlf_make_system_addrfile: exit
                    nnftboot: exit
                    nnftrne: entry
                    nnftrne: Original name: TXEIS
                    nnfttran: entry
                    nnfttran: exit
                    nnftrne: Using tnsnames.ora address (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP) (HOST = (PORT = 1522)) (CONNECT_DATA = (SID = TXEIS)) (HS=OK)) for name TXEIS
                    nnftrne: exit
                    nnfgrne: exit
                    nlolgserv: entry
                    nnfggav: entry
                    nnftgav: entry
                    nnftgav: exit
                    nnfgfrm: entry
                    nnftfrm: entry
                    nnftfrm: exit
                    nnfgfrm: exit
                    nlolgserv: exit
                    nlolgobj: exit
                    nlolfmem: entry
                    nlolfmem: exit
                    nnfun2awanm: Getting the path of sqlnet.ora
                    nnfun2awanm: Getting the adapter name
                    nnfun2awanm: exit
                    nsmal: 216 bytes at 0x430b1d8
                    nscall: connecting...
                    snlinGetAddrInfo: entry
                    snlinGetAddrInfo: exit
                    snlinFreeAddrInfo: entry
                    snlinFreeAddrInfo: exit
                    nladini: entry
                    nladini: exit
                    nladget: entry
                    nladget: exit
                    nsmal: 101 bytes at 0x435a1a8
                    nttbnd2addr: entry
                    snlinGetAddrInfo: entry
                    snlinGetAddrInfo: exit
                    nttbnd2addr: using host IP address:
                    snlinFreeAddrInfo: entry
                    snlinFreeAddrInfo: exit
                    nttbnd2addr: exit
                    nsmal: 996 bytes at 0x435a218
                    nsmal: 2120 bytes at 0x435a608
                    nsmal: 84 bytes at 0x435af98
                    nsopen: opening transport...
                    nttcon: entry
                    nttcon: toc = 1
                    nttcnp: entry
                    nttcnp: exit
                    nttcni: entry
                    nttcni: Tcp conn timeout = 60000 (ms)
                    nttctl: entry
                    nttctl: Setting connection into non-blocking mode
                    nttcni: trying to connect to socket 476.
                    ntt2err: entry
                    ntt2err: exit
                    ntctst: size of NTTEST list is 1 - not calling poll
                    ntt2err: entry
                    ntt2err: soc 476 error - operation=1, ntresnt[0]=505, ntresnt[1]=60, ntresnt[2]=0
                    ntt2err: exit
                    nttcni: exit
                    nttcon: exit
                    nserror: nsres: id=0, op=65, ns=12535, ns2=12560; nt[0]=505, nt[1]=60, nt[2]=0; ora[0]=0, ora[1]=0, ora[2]=0
                    nsopen: unable to open transport
                    nsvntx_dei: entry
                    nsvntx_dei: exit
                    nsmfr: 2120 bytes at 0x435a608
                    nsmfr: 996 bytes at 0x435a218
                    nsmfr: 101 bytes at 0x435a1a8
                    nscall: connecting...
                    nladget: entry
                    nladget: exit
                    nsmfr: 216 bytes at 0x430b1d8
                    nladtrm: entry
                    nladtrm: exit
                    nlse_term_audit: entry
                    nlse_term_audit: exit
                    • 7. Re: Linux to Windows connectivity issue
                      My mistake -- an apologies.
                      There WAS a firewall up. And that was the issue.
                      Thanks for your time