2 Replies Latest reply on Sep 7, 2012 10:25 PM by Snolan-Oracle

    Issue with CAS services & initializa_servcies

    Esha Prasad
      Hi

      We have Endeca installed on a linux box. and i am tying to initialize an application as below.
      [root@NIGGMDEMO control]# ./initialize_services.sh

      We are getting this issue.

      Finished updating EAC.
      Initializing record stores...
      These record stores exist:
      Exception in thread "main" java.lang.RuntimeException: java.io.IOException:


      http://NIGGMDEMO:8500/ComponentInstanceManager/?wsdl returned response code 404
      at com.endeca.itl.service.ServiceLocator.getService(ServiceLocator.java:154)
      at com.endeca.itl.component.manager.cmd.task.ComponentManagerTask.getManager(ComponentManagerTask.java:22)
      at com.endeca.itl.component.manager.cmd.task.ListComponentInstancesTask.process(ListComponentInstancesTask.java:18)
      at com.endeca.itl.cmd.BaseCmd.run(BaseCmd.java:412)
      at com.endeca.itl.component.manager.cmd.ComponentManagerCmd.main(ComponentManagerCmd.java:52)
      Caused by: java.io.IOException: http://NIGGMDEMO:8500/ComponentInstanceManager/?wsdl returned response code 404
      at com.endeca.itl.util.UrlUtils.ping(UrlUtils.java:129)

      I tried to restart the Endeca platform , tools, & CAS servcies. CAS services status would be 'wating' and then it exits, without any message.

      Can anyone please share your inputs to resolve this issue in linux env? (in windows we are able to run though).