6 Replies Latest reply: Sep 12, 2012 11:18 AM by Roger25 RSS

    problem configuring the listener

    Roger25
      Hi,
      I have followed all the steps from the doc, of how to install with Oracle Glassfish server: http://docs.oracle.com/cd/E21611_01/doc.11/e21058/install.htm#CHDBIAIF
      I have created those 2 users, adminlistener and managerlistener, in the "file" subnode, and giving them a password.
      Then i deployed apex.war from apex-listener directory.

      I encounter a problem here:


      Access Oracle Application Express Listener Administration

      To access Oracle Application Express Listener Administration, in your Web browser go to:

      http://<host>:<port>/apex/listenerConfigure

      Where:

      *<host> is the DNS name or IP address of the Administration Server*

      *<port> is the listen port on which the Administration Server is listening for requests*

      Next, configure Oracle Application Express Listener. See "Configuring Oracle Application Express Listener".

      Ok, let's configure then.
      I have entered http://127.0.0.1:4848/apex/listenerConfigure and it opens the Glassfish Server Administration Console, asking me for a username/password. I think i should login with that previously created username with Admin role (adminlistener). When i try to log with adminlistener and the password, it says:

      Authentication Failed
      Re-enter your username and password

      The password is entered ok. What i'm doing wrong and how can i configure the listener from the glassfish console?
      Thanks

      Edited by: Roger22 on 10.09.2012 23:40
        • 1. Re: problem configuring the listener
          Prabodh
          Hi Roger,
          Pay attention to these lines
          >
          To access Oracle Application Express Listener Administration, in your Web browser go to:

          http://<host>:<port>/apex/listenerConfigure

          Where:

          <host> is the DNS name or IP address of the Administration Server

          <port> is the listen port on which the Administration Server is listening for requests

          Next, configure Oracle Application Express Listener. See "Configuring Oracle Application Express Listener".

          >

          The PORT here refers to the HTTP port of the http-listener1 under configuration > network config > network listeners > http-listener-1 > Port . The default is 8080.

          If you are using the default ports then your URL will be
          http://127.0.0.1:8080/apex/listenerConfigure
          The port 4848 is used only for the Glassfish domain admin console.

          Before you go about configuring Apexlistener please pin the location of the apex-config.xml file in the web.xml file by un-commenting the lines
           <context-param>
          <param-name>config.dir</param-name>
          <param-value>${java.io.tmpdir}/APEX</param-value>
          </context-param>
          And replacing the ${java.io.tmpdir} with a hard coded fully qualified path, e.g. the same path as that of the web.xml file.

          If you do not do pin the location of the apex-config.xml file as given above, we can expect more posts from you related to "apexlistener suddenly stopped listening" ;)

          Cheers,
          • 2. Re: problem configuring the listener
            Roger25
            "http://127.0.0.1:8080/apex/listenerConfigure"

            And do i need to start the listener for this? Even if i deployed the .war file of apex listener into the Glasasfish UI (in Applications node)? or just the glassfish domain (domain1)

            And for the location of web.xml, it's something like this?

            <param-value>D:\oracle\app\...\APEX</param-value>

            Path separator should be "\" in my case, or "/" ?
            Thanks.

            Edited by: Roger22 on 12.09.2012 10:38
            • 3. Re: problem configuring the listener
              Prabodh
              Hi,
              >
              "http://127.0.0.1:8080/apex/listenerConfigure"

              And do i need to start the listener for this? Even if i deployed the .war file of apex listener into the Glasasfish UI (in Applications node)? or just the glassfish domain (domain1)
              >
              You have to only start the domain. By default the all domains will be started when you start Glassfish.
              >
              And for the location of web.xml, it's something like this?

              <param-value>D:\oracle\app\...\APEX</param-value>

              Path separator should be "\" in my case, or "/" ?
              >
              If you see a path and the lines are not comments with &lt;!-- --> then the location is pinned.

              Use the value
              D:\oracle\app\.../APEX
              Note the slash before APEX.

              Cheers,
              • 4. Re: problem configuring the listener
                Roger25
                OK, i have started the domain, and i logged in administration console (localhost:4848).
                In the Configurations -> server-config -> Network listeners -> http-listener-1 i have specified the port as 9191. Other values are unchanged (e.g. Address, which is 0.0.0.0).
                Now when i try to connect to http://127.0.0.1:9191/apex/listenerConfigure i get:

                The APEX Listener is already configured. Please login as Administrator to access APEX Listener Administration.

                Ok, it's configured, but how can i reconfigure it, if i want? How can i edit for example the tns, or the SID, or the port of the database i'm connecting to?
                At http://localhost:9191/apex/listenerAdmin all the fields are filled, but disabled


                EDIT: And however, this
                     <context-param>
                          <param-name>config.dir</param-name>
                          <param-value>D:\oracle\app/APEX</param-value>
                     </context-param>
                shouldn't be
                     <context-param>
                          <param-name>config.dir</param-name>
                          <param-value>D:\oracle\app/APEX/apex-config.xml</param-value>
                     </context-param>
                ?

                And i don't understand why some of the path contains "\" and before APEX there is "/"? (this is not a problem, everything "works", but i'm just asking..)
                Edited by: Roger22 on 12.09.2012 18:24
                • 5. Re: problem configuring the listener
                  Prabodh
                  Hi,

                  A. To reconfigure the JDBC, username, etc you need to
                  <ul><li> stop the domain</li><li>delete the apex-config.xml (or rename it)</li><li>start the domain</li></ul> Then try apex/listnerConfigure.

                  B. I normally put the IP address of the host on which Apexlistener is running in Address. I do not leave it on 0.0.0.0. I believe it is required for accessing the listener from other machines.

                  C. You implementation is on Windows so the path is back slashes. The /APEX part is actually the servlet end point, so I believe it needs a slash as per normal web conventions.

                  I am not 100% sure about what happens if we use all forward slashes or all back slashes. I will need to try them out on instance when it is not in use. It works so I left it at that. I did not think that too odd as we have number of other servlets running too.

                  Cheers,
                  • 6. Re: problem configuring the listener
                    Roger25
                    Ok, thanks!