This discussion is archived
4 Replies Latest reply: Sep 17, 2012 3:53 AM by DavidGreenfield RSS

AWM- Cube Population

saranya.a Newbie
Currently Being Moderated
In AWM, i map the cube to a relational table and populate the cube. then is it possible to change the mapping to another relational table and populate the cube again,so that i have both the tables data in the cube.is this possible? when i map second time to the another relational table,i see that the mapping for measure gets disappeared when i change the relational table. can anyone pls help me on this??
  • 1. Re: AWM- Cube Population
    AdamMartin Pro
    Currently Being Moderated
    Why don't you map to a view?

    Create a view that contains data from both tables and map to it instead. Use joins or unions to get the data to look exactly how you want it. This will also give you the ability to change the view definition whenever you want without having to re-map the cube. I'd recommend always mapping to views anyway just for the flexibility that it gives you.
  • 2. Re: AWM- Cube Population
    saranya.a Newbie
    Currently Being Moderated
    i even tried mapping to view. First time,i populated the cube with the view having first day data. but when i try populating the cube with the view being changed to have second day data,am getting the below error.

    "INI: error creating a definition manager, Generic at TxsOqConnection::generic<BuildProcess>INI: XOQ-01724: invalid USING clause, Generic at TxsOqBuildProcessor::initializeForDimension"

    So am not able to populate the cube when the data in the view has been changed.any idea on this why am i getting this error????
  • 3. Re: AWM- Cube Population
    DavidGreenfield Expert
    Currently Being Moderated
    This error happens when you attempt to build a dimension with MVs enabled using a script that is incompatible with MVs.

    Do you have MVs enabled on your dimension? How are you running the build? (e.g. AWM or PL/SQL) If PL/SQL, what is the exact script you are running?
  • 4. Re: AWM- Cube Population
    DavidGreenfield Expert
    Currently Being Moderated
    I just remembered that I have seen this error if you use AWM version 11.1.0.7 against an 11.2 version of the server and you have MVs enabled on your dimensions.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points