1 2 Previous Next 25 Replies Latest reply on Sep 14, 2012 11:23 AM by 962177 Go to original post
      • 15. Re: OEM 12c start failed
        Daryl E.
        Seems that first https url works .. notsure why there are two. empbs ??

        2012-03-23 11:05:44,224 [main] DEBUG oms.StatusOMSCmd processStatusOMS.159 - HTTP port in emgc property file: 7203
        2012-03-23 11:05:44,225 [main] DEBUG oms.StatusOMSCmd processStatusOMS.160 - HTTPS port in emgc property file: 7302
        2012-03-23 11:05:44,225 [main] DEBUG oms.StatusOMSCmd processStatusOMS.166 - Webtier HTTP port in emgc property file: 7789
        2012-03-23 11:05:44,226 [main] DEBUG oms.StatusOMSCmd processStatusOMS.167 - Webtier HTTPS port in emgc property file: 7801
        2012-03-23 11:05:44,226 [main] DEBUG oms.StatusOMSCmd processStatusOMS.186 - Using https port.
        2012-03-23 11:05:44,227 [main] DEBUG oms.StatusOMSCmd processStatusOMS.203 - Using webtier https port.
        2012-03-23 11:05:44,646 [main] DEBUG oms.StatusOMSCmd pingOMSCheck.341 - Attempting to connect to https://oem12cnc:7302/em/faces/logon/core-uifwk-console-login
        2012-03-23 11:05:45,660 [main] DEBUG oms.StatusOMSCmd pingOMSCheck.341 - Attempting to connect to https://oem12cnc:7801/empbs/check
        2012-03-23 11:05:45,665 [main] INFO oms.StatusOMSCmd processStatusOMS.294 - Failed to connect to em login page
        2012-03-23 11:05:45,665 [main] INFO oms.StatusOMSCmd processStatusOMS.295 - Connection refused
        2012-03-23 11:05:45,666 [main] INFO oms.StatusOMSCmd processStatusOMS.296 - Connection exception when trying to hit OMS page. OMS is down
        • 16. Re: OEM 12c start failed
          Daryl E.
          This doesnt look good ...

          2012-03-23 11:29:34,809 [oracle.sysman.core.pbs.gcloader.ResourceManager] ERROR gcloader.ResourceManager logp.251 - Severe error is updating the performance data
          oracle.sysman.emSDK.svc.conn.CacheInvalidStateException: OMS is shutting down
          at oracle.sysman.emSDK.svc.conn.ConnectionService._getSystemConnectionCache(ConnectionService.java:2701)
          at oracle.sysman.emSDK.svc.conn.ConnectionService.getSystemConnection(ConnectionService.java:1791)
          at oracle.sysman.core.pbs.gcloader.ResourceManager.getConnection(ResourceManager.java:1290)
          at oracle.sysman.core.pbs.gcloader.ResourceManager.logPerformanceData(ResourceManager.java:1238)
          at oracle.sysman.core.pbs.gcloader.ResourceManager.run(ResourceManager.java:1118)
          at java.lang.Thread.run(Thread.java:662)
          • 17. Re: OEM 12c start failed
            Daryl E.
            Down 5 days now .. thanks support...

            https://oem12cnc:7801/empbs/check not starting up .. grrr...
            • 18. Re: OEM 12c start failed
              sxkumar
              Someone from Support should follow up today. Let me know if that does not happen
              • 19. Re: OEM 12c start failed
                Daryl E.
                OMG -- upload 15 more logs files (again) ...
                • 20. Re: OEM 12c start failed
                  Daryl E.
                  The answer for my situation was to remove one crash file/directory..

                  /opt/app/oracle/middleware/gc_inst/WebTierIH1/config/OPMN/opmn/states

                  opmnctl couldnt start the webtier since it thought it was running already. It was stuck trying to stop something that wasnt running.
                  Hope this helps others.

                  We did
                  opmnctl startall
                  opmctl status
                  It would say it was stopped and the PID shown was not the right pid at all.
                  Once that was working, stopall -- then back to emctl startall being sure no java processes or EMG... processes are running.
                  • 21. Re: OEM 12c start failed
                    user409186 - oracle
                    Hello experts,

                    I have installed EM 12c Bundle Patch1 and EM was working fine for 2 days. However on 3rd day I was not able to login with error 404. I tried to stop and start oms but I get the message oms is down.

                    I checked the emctl.log and found:

                    2012-04-02 11:50:28,096 [main] DEBUG oms.StatusOMSCmd processStatusOMS.159 - HTTP port in emgc property file: 7204
                    2012-04-02 11:50:28,096 [main] DEBUG oms.StatusOMSCmd processStatusOMS.160 - HTTPS port in emgc property file: 7303
                    2012-04-02 11:50:28,096 [main] DEBUG oms.StatusOMSCmd processStatusOMS.166 - Webtier HTTP port in emgc property file: 7790
                    2012-04-02 11:50:28,096 [main] DEBUG oms.StatusOMSCmd processStatusOMS.167 - Webtier HTTPS port in emgc property file: 7802
                    2012-04-02 11:50:28,097 [main] DEBUG oms.StatusOMSCmd processStatusOMS.186 - Using https port.
                    2012-04-02 11:50:28,097 [main] DEBUG oms.StatusOMSCmd processStatusOMS.203 - Using webtier https port.
                    2012-04-02 11:50:28,214 [main] DEBUG oms.StatusOMSCmd pingOMSCheck.341 - Attempting to connect to https://host1.example.com:7303/em/faces/logon/core-uifwk-console-login
                    2012-04-02 11:50:28,892 [main] DEBUG oms.StatusOMSCmd pingOMSCheck.341 - Attempting to connect to https://host1.example.com:7802/empbs/check
                    2012-04-02 11:50:28,905 [main] DEBUG oms.StatusOMSCmd processStatusOMS.240 - console page status code is 404
                    2012-04-02 11:50:30,001 [main] DEBUG oms.StatusOMSCmd processStatusOMS.242 - pbs page status code is 500
                    2012-04-02 11:50:30,001 [main] DEBUG oms.StatusOMSCmd processStatusOMS.245 - console header is null
                    2012-04-02 11:50:30,002 [main] DEBUG oms.StatusOMSCmd processStatusOMS.247 - pbs header is null
                    2012-04-02 11:50:30,002 [main] DEBUG oms.StatusOMSCmd processStatusOMS.285 - Both Console and PBS are down. Status codes are: Console - 404 and PBS - 500
                    2012-04-02 11:50:30,002 [main] INFO oms.StatusOMSCmd processStatusOMS.294 - Failed to connect to em login page
                    2012-04-02 11:50:30,002 [main] INFO oms.StatusOMSCmd processStatusOMS.295 - Encountered error while hitting page. Status codes are 404 for console and 500 for PBS
                    2012-04-02 11:50:30,002 [main] INFO oms.StatusOMSCmd processStatusOMS.296 - Connection exception when trying to hit OMS page. OMS is down
                    2012-04-02 11:50:30,003 [main] INFO wls.OMSController statusOMS.1354 - statusOMS finished with result: 8


                    I tried to stop and start opmn but even that did not help. Can somebody please explain what is the above error and solution ?

                    Thank you
                    Vikas Mallapati
                    • 22. Re: OEM 12c start failed
                      Daryl E.
                      Certainly no expert .. but try a couple things..

                      connect to your OEM repository as sys --
                      alter system switch archivelog;

                      (see if it is full)

                      Then login to OEM as sysman - see if the account its locked.

                      Check opmn

                      cd /opt/app/oracle/middleware/gc_inst/WebTierIH1/bin
                      ./opmnctl status
                      • 23. Re: OEM 12c start failed
                        932428
                        I had to do emctl stop oms and then again emctl start oms to fix this issue.

                        Thanks
                        prasad Kotipalli
                        • 24. Re: OEM 12c start failed
                          rougefyl
                          Thank you! The check OPMN indicated OHS was still up which somehow blocks the startup process. After doing what the next post said ... stopping oms clears the process ... then restarting worked!

                          This utter silliness can easily be caused by not doing a full shutdown (i.e. oms, agent, and db)

                          Edited by: rougefyl on May 2, 2012 1:32 AM
                          • 25. Re: OEM 12c start failed
                            962177
                            Hi,

                            I had similar issue after restarting my server.

                            Starting WebTier...
                            WebTier Successfully Started
                            Starting Oracle Management Server...
                            Oracle Management Server is Down

                            this is what i done to fix it (ofcourse some of the comments above might have addressed this solution, sorry for repeating)

                            Step 1:
                            cd /u01/app/oracle/middleware/gc_inst/WebTierIH1/bin
                            ./opmnctl status

                            (check the status if it is alive then stop it)

                            ./opmnctl stopall

                            Step:2

                            go this directory /u01/app/oracle/middleware/gc_inst/WebTierIH1/config/OPMN/opmn/states

                            create a backup folder move the file (starts with p...) move that file to backup folder

                            now issue the command ./opmnctl startall

                            Step:3
                            check for any emctl.log files and delete them (find / -name emctl.log -type f)

                            Step:4
                            then stop OMS and agent

                            /u01/app/oracle/Middleware/oms/bin/emctl stop oms -all
                            /u01/app/oracle/Middleware/agent/core/12.1.0.1.0/bin/emctl stop agent
                            then start OMS and agent

                            /u01/app/oracle/Middleware/oms/bin/emctl start oms -all
                            /u01/app/oracle/Middleware/agent/core/12.1.0.1.0/bin/emctl start agent
                            Best regards,
                            Karthik Reddivari
                            1 2 Previous Next