3 Replies Latest reply: Sep 19, 2012 9:38 PM by Levi Pereira RSS

    touble to start ASM


      In AIX 6.1.

      we shutdown all databases in one server, and shutdown ASM too, system adminstrator did a reboot, after that, we try to start ASM first,

      has touble like below, any suggestions? thank you

      server:/home/oracle-> crsctl start asm
      exec(): 0509-036 Cannot load program /app/oracle/product/11.1.0/bin/crsctl.bin because of the following errors:
      0509-130 Symbol resolution failed for /usr/lib/libperfstat.a[shr_64.o] because:
      0509-136 Symbol ptx_get_ifnets64 (number 97) is not exported from
      dependent module /unix.
      0509-026 System error: Error 0
      0509-192 Examine .loader section symbols with the
      'dump -Tv' command.

      server:/home/oracle-> asmcmd
      install_driver(Oracle) failed: Can't load '/app/oracle/product/11.1.0/perl/lib/site_perl/5.8.3/aix-thread-multi-64all/auto/DBD/Oracle/Oracle.so' for module DBD::Oracle: 0509-130 Symbol resolution failed for /usr/lib/libperfstat.a[shr_64.o] because:
      0509-136 Symbol ptx_get_ifnets64 (number 97) is not exported from
      dependent module /unix.
      0509-022 Cannot load module /app/oracle/product/11.1.0/perl/lib/site_perl/5.8.3/aix-thread-multi-64all/auto/DBD/Oracle/Oracle.so.
      0509-026 System error: Cannot run a file that does not have a valid format.
      0509-192 Examine .loader section symbols with the
      'dump -Tv' command. at /app/oracle/product/11.1.0/perl/lib/5.8.3/aix-thread-multi-64all/DynaLoader.pm line 229.
      at (eval 5) line 3
      Compilation failed in require at (eval 5) line 3.
      Perhaps a required shared library or dll isn't installed where expected
      at /app/oracle/product/11.1.0/lib/asmcmdbase.pm line 4592

      Edited by: 951932 on Sep 19, 2012 12:12 PM
        • 1. Re: touble to start ASM
          Is ORACLE_HOME properly set?
          Is $ORACLE_HOME/bin in your PATH?

          Show us
          env|grep ORA|sort
          env|grep PATH
          Edited by: EdStevens on Sep 19, 2012 2:52 PM
          • 2. Re: touble to start ASM
            Bruce Beck
            We had the exact same error. The issue is there a conflicting file set install. For example on our system there it was at version 6.1 TL 6 ML 5. However someone installed a ML 6 fileset. Everything worked just fine until a reboot. We update our system to TL 6 ML 6, rebooted, and the problem went away.
            • 3. Re: touble to start ASM
              Levi Pereira

              Is necessary to relink the Oracle binaries following an OS upgrade. OS upgrades include upgrading to a maintenance level of the same release or upgrading from one OS release to another.

              Oracle software comes as object files or source files which get relinked with OS libraries at the time of installation to generate the executable. When one upgrades or applies patches to the operating system, the libraries which are linked with Oracle binaries, may get updated. Ideally, updated libraries also would work fine with Oracle binaries as OS vendors maintain backward compatibility. It may still happen that new libraries may not compatible with old libraries (because of bugs in OS libraries or with the Oracle product itself). Therefore, to be safe, one should always relink post OS upgrade. This also serves as a sanity check should there be problems of what changed in the environment when linking last worked.

              So, as user Owner of ORACLE_HOME.

              Stop all Oracle Process under this ORACLE_HOME

              $ORACLE_HOME/bin/relink all

              I recommend you use this tech note on MOS: *Is It Necessary To Relink Oracle Following OS Upgrade? [ID 444595.1]*

              Levi Pereira

              Edited by: Levi Pereira on Sep 19, 2012 11:37 PM