This discussion is archived
10 Replies Latest reply: Sep 21, 2012 1:07 AM by tbrinkmann RSS

oracle asm and ocfs2 old version

tbrinkmann Explorer
Currently Being Moderated
Hi,
I try to install the latest OL 5.8 patches but hit some mission dependencies.

We use the OL5.8 as a two node oracle 11.2 cluster.

I can fix the deps by removing the installed packages. Does I need
ocfs2-2.6.18-274.0.0.0.1.el5xen-1.4.10-1
oracleasm-2.6.18-274.0.0.0.1.el5xen-2.0.

the two packages anymore ? or may I update force ?
*T                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
  • 1. Re: oracle asm and ocfs2 old version
    Dude! Guru
    Currently Being Moderated
    Force is usually a bad idea.

    Are you not using YUM to install, remove or update the software?
    Do you run the UEK kernel?
  • 2. Re: oracle asm and ocfs2 old version
    tbrinkmann Explorer
    Currently Being Moderated
    Re,
    normally I use up2date and in some cases I use directly yum.
    We run our own repository. We only download
    5.8_base and 5.8_patch. Know we try to up2date the system and the dependencies are missing.

    Does we need additional repos link 5.7 or 5.6 ?

    Thanks *T                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       
  • 3. Re: oracle asm and ocfs2 old version
    Dude! Guru
    Currently Being Moderated
    The up2date utility was used under RHEL 4 and OEL 4 and earlier. Version 5 and 6 uses the YUM utility. YUM uses package metatdata from a special repository to automatically resolve software dependencies and prevent conflicts. YUM is a front-end package manager for RPM.

    The asm and ocfs2 kernel drivers you are referring to depend on the XEN kernel. If you do not use the XEN kernel you do not need them. If this is not a Dom0 or DomU system you should not use it.
  • 4. Re: oracle asm and ocfs2 old version
    tbrinkmann Explorer
    Currently Being Moderated
    Re,
    dude does I understand you right I do not use up2date anymore ?
    Updating and installing software only with yum right ?

    So for my understanding where I can find this very heavy basic information. To do not use up2date anymore.
    In the change logs ? User Manuals or just hitting problems :-/

    Anyway why does these packages not included in the 5_8base and 5_8patch repos ?

    ocfs2-2.6.18-274.0.0.0.1.el5xen-1.4.10-1 requires kernel-xen = 2.6.18-274.0.0.0.1.el5
    oracleasm-2.6.18-274.0.0.0.1.el5xen-2.0. requires kernel-xen = 2.6.18-274.0.0.0.1.el5

    Edited by: tbrinkmann on Sep 20, 2012 2:35 AM
  • 5. Re: oracle asm and ocfs2 old version
    BillyVerreynne Oracle ACE
    Currently Being Moderated
    tbrinkmann wrote:

    We use the OL5.8 as a two node oracle 11.2 cluster.

    I can fix the deps by removing the installed packages. Does I need
    ocfs2-2.6.18-274.0.0.0.1.el5xen-1.4.10-1
    oracleasm-2.6.18-274.0.0.0.1.el5xen-2.0.
    Neither is needed for a successful 11gr2 Grid Infrastructure or RAC install.

    Why are these packages needed/installed?
  • 6. Re: oracle asm and ocfs2 old version
    tbrinkmann Explorer
    Currently Being Moderated
    Re,
    I don´t know the system was installed by Oracle 5.7 image from metalink.
    So I will delete these packages and the xen kernel because we use the UEK.

    Edited by: tbrinkmann on Sep 20, 2012 4:11 AM

    .... It is not possible to deinstall the kernel-xen because of additional gnome dependencies.

    Does anyone knoe how to deal the right way with that ?

    Edited by: tbrinkmann on Sep 20, 2012 4:13 AM
  • 7. Re: oracle asm and ocfs2 old version
    Dude! Guru
    Currently Being Moderated
    Please see the response from Sergio regarding up2date or yum at yum or up2date for oel updates ? If I remember correctly yum is covered in the standard OS documentation.
    Anyway why does these packages not included in the 5_8base and 5_8patch repos ?
    The ocfs2 and asm drivers for the RHEL XEN kernel are part of the Oracle Linux base distribution. AFAIK, software versions ending with 0.0.0.1 are Oracle's own patches. The Oracle public yum repository also contains the latest software patches.

    The up2date utility requires a ULN subscription. If you have a subscription I suggest to contact Oracle support and open a SR. To continue further I think you will need to provide information about what kernel you are using and what you are trying to update or accomplish. For instance, what are you doing that requires to remove the xen kernel drivers? It may seem irrelevant to answer your question, but it can help to find a solution.
  • 8. Re: oracle asm and ocfs2 old version
    tbrinkmann Explorer
    Currently Being Moderated
    It looks like I have a basic understanding problem regarding package management on OL(RH) :-/
    Just for a bedder understanding.

    1. We have a Support ID.
    2. I used the script based repo generation from oracle --> ./167283.sh
    ( http://www.oracle.com/technetwork/topics/linux/yum-repository-setup-085606.html )
    3. We installed our OL from edelivery image 5.*7*
    4. We subscribe the OL5.8 basic and 5.8 patch repos.
    5. Download them to our local repo Server
    6. We use and we CAN use up2date with our local repositories. ( up2date -u )
    /etc/sysconfig/rhn/sources
    7. we configure yum to work with our local repo server ( yum install, yum update )
    /etc/yum.repos/

    Regarding to you last post as TommyReynolds says its a shrug if I use up2date -u or yum OK :-)

    I will keep in mind that you say that I use yum update for the future.
    So I will run the update now.....and :-/

    There is another error

    Transaction Check Error:
    package kernel-uek-firmware-2.6.39-100.5.1.el5uek.noarch (which is newer than kernel-uek-firmware-2.6.32-300.32.2.el5uek.noarch) is already installed

    Living linux dependencies is a hard lessen to lern :-(
  • 9. Re: oracle asm and ocfs2 old version
    Dude! Guru
    Currently Being Moderated
    You still haven't explained what you are trying to accomplish. Are you trying to update a 5.7 system to 5.8 including the latest patches or are you trying to remove the XEN kernel?

    Can you provide the command you are using including the exact error as it appears on your screen?

    To be able to remove the Xen kernel you need to make sure that you have another kernel installed and do not use the Xen kernel as your current kernel. However, you generally do not need to remove the Xen kernel to install and use the UEK2 kernel, so what is the problem?

    To update the system from 5.7 to 5.8 you do not need the 5.7 or earlier software repository.
  • 10. Re: oracle asm and ocfs2 old version
    tbrinkmann Explorer
    Currently Being Moderated
    Re,
    sorry for the misunderstanding.
    The system is updated to 5.8 weeks ago. In the end I used yum update with the 5.8 patch and base repo configured
    and the system is now up to date. Thanks to discuss this out. In the future I always use yum now.
    *T                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points