This discussion is archived
10 Replies Latest reply: Sep 27, 2012 4:54 PM by midhu RSS

v490 server not able to type at ok prompt

midhu Newbie
Currently Being Moderated
Hello Guyz
The problem is that when I power on the server with max diag post it will drop at ok prompt with all post result passed. But I am not able to type anything at ok prompt. Input device & Output device are set to ttya when checked from os console. Since autoboot parameter is true it will boot automatically when i do a normal power on. RSC is not configured and I am not getting anything on it. Also graphics card not available in server.Troubleshooting steps done till now.

1. Powered on server in normal mode and with disk drives removed. It will stop at ok prompt with error cant boot. But not able to type anything.
2. Replaced PCI riser card which includes NVRAM.
3. Tried powering on the server with all minimum configuration possible still no luck.
4. Swapped the only one system board to other one and checked.

My seniors suggested to replace system board. What you guys think? Please help. Thanks..
  • 1. Re: v490 server not able to type at ok prompt
    963543 Newbie
    Currently Being Moderated
    Hi,

    I would suggest setting up RSC first, then connecting through it.
    Also, try to change the OBP variables from the OS level.

    You can check this doc:
    How to set up and disable the RSC console on Sun Fire[TM] 280R, V480, V490, V880, V890 and V880z servers. (Doc ID 1011888.1)

    Rgds
  • 2. Re: v490 server not able to type at ok prompt
    midhu Newbie
    Currently Being Moderated
    I agree but still I should be able to type at ok prompt if i/p and o/p device are set to ttya r8..
  • 3. Re: v490 server not able to type at ok prompt
    rukbat Guru Moderator
    Currently Being Moderated
    midhu wrote:
    I agree but still I should be able to type at ok prompt if i/p and o/p device are set to ttya r8..
    ... not if your cabling and/or your terminal software is configured wrong.
    You haven't described any of that well enough for anyone to help yet.

    You are connecting from what? (a laptop? a desktop? another SPARC system?)
    Your cabling is of what sort (e.g. direct serial cabling or a kludge via USB-to-serial-to-crossover?).
    What terminal application are you using from that box you use to do your typing?
  • 4. Re: v490 server not able to type at ok prompt
    midhu Newbie
    Currently Being Moderated
    I am using putty software and cisco cable with usb-to-serial converter which is connected to ttya port of server on one end and usb port on my laptop for getting the console of server. Also I am using default baud rate which is 9600.
  • 5. Re: v490 server not able to type at ok prompt
    rukbat Guru Moderator
    Currently Being Moderated
    midhu wrote:
    I am using putty software and cisco cable with usb-to-serial converter which is connected to ttya port of server on one end and usb port on my laptop for getting the console of server. Also I am using default baud rate which is 9600.
    That all seems fine, except...
    Historically, USB-to-serial adapters will often just fail to function in such circumstances.
    There are numerous posts in these forums that go bazck more than a decade (through migrations from old Sun forums, even) that mention such USB adapters. They're not necessarily broken to where you need to replace it. They often just do not work. They won't send/receive the duplex signals you hope to have so that `send` at the laptop becomes `receive` at the V490, and `send` at the V490 becomes `receive` at the laptop. The symptoms are as you described: you can see but not type, or you can type but not see.

    I suggest you go beg, borrow, or claim by eminent domain an old computer that has an actual hardwired serial port and try again.

    I know. All this shouldn't be that hard, and it's frustrating. It should "just work".
  • 6. Re: v490 server not able to type at ok prompt
    midhu Newbie
    Currently Being Moderated
    Thanks for the reply.. Actually I even tried to access the servers console using another Sun Blade 2500 and cross over cable. But in that too the same issue was there. So I hope the issue is not there with the connectivity. Also I am using my same USB-to-serial converter and cisco cable for accessing other servers console and it is working as it should. This is the reason why I doubt on server hardware.
  • 7. Re: v490 server not able to type at ok prompt
    rukbat Guru Moderator
    Currently Being Moderated
    Okay, then. You have shown us that you have tried to eliminate most possibilities. That's good (and more than most forum posters ever do).

    Since you're posting to the forum, we can presume there's no contract coverage on this V490? Otherwise I'd just suggest opening a S.R. on it and get TechSupport to guide you.

    Glancing back at your initial post, I'm reluctant to suggest setting auto-boot to false because you may get into an unrecoverable situation with no input capability.

    So ...
    If there are ANY systems with support coverage, you might ask an associate to log a ticket on "something" with coverage, then as an oh-by-the-way have them bring up this V490's frustration during the conversation.
  • 8. Re: v490 server not able to type at ok prompt
    963543 Newbie
    Currently Being Moderated
    check eeprom output if the following variable is set:

    diag-out-console false
  • 9. Re: v490 server not able to type at ok prompt
    963543 Newbie
    Currently Being Moderated
    Did you follow this procedure:

    http://docs.oracle.com/cd/E19095-01/sfv490.srvr/817-3951-12/chp7.html#pgfId-1006869

    ??
  • 10. Re: v490 server not able to type at ok prompt
    midhu Newbie
    Currently Being Moderated
    Hi Team

    Issue got resolved after replacing the centerplane. :) Now I am able to type at ok prompt.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points