1 Reply Latest reply on Sep 21, 2012 6:55 PM by rukbat

    Unable to install gcc-c++-4.4.4-13.el6 due to multilib versions


      I am installing EBS 12.1.1 encountered problems relinking that lead to installing gcc-c++-4.4.4-13.el6

      1) yum install gcc-c++-4.4.4-13.el6
      Gave me these errors:

      Error: Package: gcc-c++-4.4.4-13.el6.x86_64 (ol6_ga_base)
      Requires: libstdc++ = 4.4.4-13.el6
      Installed: libstdc++-4.4.6-4.el6.i686 (@ol6_latest)
      libstdc++ = 4.4.4-15.el6
      libstdc++ = 4.4.6-4.el6
      Available: libstdc++-4.4.4-13.el6.i686 (ol6_ga_base)
      libstdc++ = 4.4.4-13.el6
      Error: Package: gcc-c++-4.4.4-13.el6.x86_64 (ol6_ga_base)
      Requires: libstdc++-devel = 4.4.4-13.el6
      Installed: libstdc++-devel-4.4.6-4.el6.i686 (@/libstdc++-devel-4.4.6-4.el6.i686)
      libstdc++-devel = 4.4.4-15.el6
      libstdc++-devel = 4.4.6-4.el6
      Available: libstdc++-devel-4.4.4-13.el6.i686 (ol6_ga_base)
      libstdc++-devel = 4.4.4-13.el6
      You could try using --skip-broken to work around the problem
      You could try running: rpm -Va --nofiles –nodigest

      2) I decided to remove the libstdc++-4.4.6-4.el6.i686 accepting it's dependencies to be removed
      yum remove libstdc++-4.4.6-4.el6.i686
      yum remove libstdc++-devel-4.4.6-4.el6.i686

      3) Install gcc-c++:
      yum install gcc-c++-4.4.4-13.el6

      It errors out:
      Resolving Dependencies
      --> Running transaction check
      ---> Package gcc-c++.x86_64 0:4.4.4-13.el6 will be installed
      --> Processing Dependency: libstdc++ = 4.4.4-13.el6 for package: gcc-c++-4.4.4-13.el6.x86_64
      --> Processing Dependency: libstdc++-devel = 4.4.4-13.el6 for package: gcc-c++-4.4.4-13.el6.x86_64
      --> Running transaction check
      ---> Package libstdc++.i686 0:4.4.4-13.el6 will be installed
      ---> Package libstdc++-devel.i686 0:4.4.4-13.el6 will be installed
      --> Finished Dependency Resolution
      Error: Protected multilib versions: libstdc++-4.4.4-13.el6.i686 != libstdc++-4.4.6-4.el6.x86_64
      Error: Protected multilib versions: libstdc++-devel-4.4.4-13.el6.i686 != libstdc++-devel-4.4.6-4.el6.x86_64
      You could try running: rpm -Va nofiles nodigest

      Gurus how should I handle this installation?