This discussion is archived
2 Replies Latest reply: Sep 26, 2012 3:05 AM by drookie RSS

Solaris 11 hp dl 180 g6 - installer doesn't start

drookie Newbie
Currently Being Moderated
Hi.

I'm trying to install solaris 11 on an hp dl 180 g6 server. My main problem is that the installer cannot start - after 'Preparing disk image for use' I got 'Login services cabbot run' and it starts the maintenance mode.
In this maintenance mode I have only a ram disk, it lacks like... everything, only some basic utilities are present.
This is second dl180 and a second failure. I tried all of the installation media options, and I got the same result.

Is there a way to install Solaris 11 manually ? Like manually create zpool (zpool and zfs utilities are present) and manually unpack the systrem from the distro ? Like it can be done in FreeBSD for example, or in Linux.
If there is such a way, then how can this be done ? Right now I'm struggling to determine where is the CD-drive having only utilities on the ramdik solaris creates.

May the the roor of the problem is in the fact that I'm installing Solaris using the dl180 ilo - so it uses the virtual image mounted via the java applet, and the hardware is treting it as an USB CD-Drive.
Did any of you guys try to install Solaris 11 viw the HP's ILO or from the USD CD drive ?

The fact is that Solaris 10 installs just fine. Looks like I will have to install it instead of the 11.
  • 1. Re: Solaris 11 hp dl 180 g6 - installer doesn't start
    drookie Newbie
    Currently Being Moderated
    Looks like this an USB-related problem.
    I've just managed to reproduce the problem with virtualbox and the USB Live image.
    And with the same vbox and the DVD image everything was ok.
  • 2. Re: Solaris 11 hp dl 180 g6 - installer doesn't start
    drookie Newbie
    Currently Being Moderated
    Okay. After hanging a little, experimenting with the NFS, configuring network with netcfg/netadm and finding out that dladm show-phys for some reasion doesn't think this machine is connected (and it is) I found the solution.

    I'm not sure what exactly helped, so I will post both steps:

    - Download and Boot from last HP SPP, install all the updates.
    - Don't use the LO100i Virtual Media built-in capability of handling ISO images. Use Daemontools virtual drive ! After this the Solaris was able to boot up, found it's media and launched the installation process.

    Hope it will help someone.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points