6 Replies Latest reply: Sep 26, 2012 5:15 AM by user2457908 RSS

    voting disk problem

      I had a problem with my votingdisks:
      First CSS would not start. CSS log said votingdisks were missing:

      C:\oracle\product\10.2.0>crsctl query css votedisk
      0. 0 \\.\votedsk1
      1. 0
      2. 0
      located 3 votedisk(s).

      I stopped the cluster and could add my voting disks:
      C:\oracle\product\10.2.0>crsctl query css votedisk
      0. 0 \\.\votedsk1
      1. 0
      2. 0
      3. 0 \\.\votedsk3
      4. 0 \\.\votedsk2
      located 5 votedisk(s).

      How can I get rid off the "empty" values?
        • 1. Re: voting disk problem
          Try deleting the empty disks using "crsctl delete css". I am not sure whether that will work, since the paths are empty.

          Other option is to reinitialize the OCR by running root.sh, after a complete clean-up.

          But make sure that the voting disk locations are set correctly by the OUI in "$ORA_CRS_HOME/install/rootconfig" script.

          • 2. Re: voting disk problem
            Thnx for your reaction.

            The first option does not work for the command requires a path to a disc.

            Secondly I am running on W2003. (forgot to mention)

            • 3. Re: voting disk problem
              I ran into the samething today and figured out how to get rid of them at least on a Win 2003 SP2R2 cluster. Mine were showing 0s for the path as well so after a lot of trial and error I finally just tried:

              crsctl delete css votedisk 0

              And it worked... What happens is, when you have to do a -force to create extra votedisks the cluster has to be stopped on all nodes or this will happen. We were doing a totally fresh install so we played with it a little to determine this is what happened. When we stopped everything before adding votedisks using -force and cleaning up the bad ones, everything went fine.
              • 4. Re: voting disk problem
                I kind of misworded that last sentence... we:

                1. Cleaned up the bad votedisks
                2. Stopped the cluster on both nodes involved
                3. Created the new, added votedisks using -force

                And I was also able to issue the "crsctl delete css votedisk 0" twice in a row to remove both extras... Sorry for any confusion.
                • 5. Re: voting disk problem
                  Yes, the CRS needs to be shutdown on all the nodes of the cluster before you add or delete the voting devices and also use the -force option with it. This has been well documented in one of the metalink notes.

                  • 6. Re: voting disk problem
                    I had the same problem on a nfs voting disk whos path disapeared in the crsctl query css votedisk.
                    We are on a 11gr1 extended RAC.
                    I deleted it by using the empty string "" as path.
                    ==> crsctl delete css votedisk ""

                    Edited by: user2457908 on 26 sept. 2012 03:14