This discussion is archived
5 Replies Latest reply: Sep 26, 2012 9:00 AM by 957621 RSS

Upgrading problem

957621 Newbie
Currently Being Moderated
Hi,

I'm trying to upgrade from version 12.1.0.2001 to 12.1.1.2076, I've downloaded the upgrade bundle and tried to make the update and got this:

/var/tmp/update/xvmoc_full_bundle]# ./install
Path to installation distribution was not provided with --install option
Using the current install Location /var/opt/sun/xvm/EnterpriseController_installer_12.1.0.2001
No previous Ops Center update installed.
This is a Full bundle
This is update "EC_patch_bundle" at version 12.1.1.2076
DEBUG: /opt/SUNWxvmoc/bin/satadm is present on the system
ERROR: This update requires services to be running. Please restart via satadm start.
If the proxy is enabled, start it using proxyadm start

I've checked the service and is offline

# /opt/SUNWxvmoc/bin/ecadm status
offline

I've tried to start it but the service is still offline

# /opt/SUNWxvmoc/bin/ecadm start -v
ecadm: Enable HTML redirect
ecadm: Disabling svc:/application/scn/ec-server-splashpage:default
ecadm: svc:/application/scn/ec-server-splashpage:default successfully stopped
ecadm: Starting Enterprise Controller with SMF...
ecadm: ... milestone "satellite-enable" successfully enabled


Anyone knows how to troubleshoot this problem?

Thanks in advance.

Edited by: 954618 on Aug 23, 2012 10:26 AM
  • 1. Re: Upgrading problem
    Eran_Steiner Newbie
    Currently Being Moderated
    When starting the EC - it can take a good few minutes for the service to start up.
    Next time, you can run:
    /opt/SUNWxvmoc/bin/ecadm start -w -v
    The "-w" is for "wait" - so the start command will actually wait until the service is up and running before going back to prompt.

    If it still fails, check what service doesn't start properly:
    # svcs '*scn*' '*common*'
    This can give you a good starting point.

    Last, once you're done with starting with "-w" (or even before you run it), try checking for known issues with the OCDoctor:
    # /var/opt/sun/xvm/OCDoctor/OCDoctor.sh --update
    then
    # /var/opt/sun/xvm/OCDoctor/OCDoctor.sh --troubleshoot                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   
  • 2. Re: Upgrading problem
    957621 Newbie
    Currently Being Moderated
    Thank you Eran for pointing me in the right direction!

    I"ve noticed that I have several services disabled and one in maintenance, but the most helpful thing was this output from OCDoctor:

    ERROR: SUNWj6rt version (1.6.0_31) does not match SUNWj6rtx version (1.6.0_26)
    Make sure that the 32 bit matches the 64 bit version, otherwise you may have issues starting the EC.

    So my first task will be to make both packagaes have the same version number, and then continue from there.

    I'll post here the results. Thanks again
  • 3. Re: Upgrading problem
    957621 Newbie
    Currently Being Moderated
    I've installed the patches 125136-37.zip 125137-37.zip, now the java versions are in the same release level but the problem persists.

    I've checked the running services and here's the output:

    [root->/]# svcs '*scn*' '*common*'
    STATE STIME FMRI
    legacy_run Aug_22 lrc:/etc/rcS_d/S88SUNWscn-update-agent-prepare-singleuser
    legacy_run Aug_22 lrc:/etc/rcS_d/S90SUNWscn-update-agent-singleuser
    disabled Aug_22 svc:/application/scn/singleuser-agent:default
    disabled Aug_22 svc:/application/scn/update-agent:default
    disabled Aug_22 svc:/application/management/common-agent-container-1:default
    disabled Aug_22 svc:/application/scn/db:remote
    disabled Aug_22 svc:/application/scn/ec-server-splashpage:default
    disabled Aug_22 svc:/application/scn/dhcpd:default
    online Aug_22 svc:/application/scn/satellite-enable:default
    online Aug_22 svc:/application/scn/ajaxterm:default
    online Aug_22 svc:/application/scn/oralistener:default
    online Aug_22 svc:/application/scn/oracle:default
    online Aug_22 svc:/application/scn/db:local
    online Aug_22 svc:/application/scn/db:default
    online Aug_22 svc:/application/scn/uce-scheduler:default
    online Aug_22 svc:/application/management/common-agent-container-1:oem-ec
    online Aug_22 svc:/application/scn/proxy-enable:default
    online Aug_22 svc:/application/management/common-agent-container-1:scn-proxy
    online Aug_22 svc:/application/scn/proxy-available:default
    offline Aug_22 svc:/application/scn/satellite-available:default
    maintenance 16:11:52 svc:/application/scn/uce-server:default


    I don't know if the disabled services are ok or if I should try to start them; regarding the service in maintenance mode, here's the problem shown in the log:

    [ Aug 22 12:18:24 Executing start method ("/opt/SUNWxvmoc/lib/methods/scn-uce-server start") ]
    (126)Cannot assign requested address: make_sock: could not bind to address 192.168.40.101:8002
    no listening sockets available, shutting down

    That IP (192.168.40.101) is not longer valid in the server (it was when I installed Enterprise Manager but now is wrong); my question is: where is this IP information stored in Enterprise Manager so I can change it to the correct value?


    Thanks in advance,
  • 4. Re: Upgrading problem
    936381 Newbie
    Currently Being Moderated
    I run into numerous problems with this upgrade, spent 6 full working days with different ways of upgrading and fiddling around to no avail.
    In the end I just reinstalled 12cU1 from scratch and manually re-added all assets and did the configuration again, it was way faster.

    Also the new agent version (b2083) seemed to fix a lot of problems so remember to upgrade your agents as well.

    - J
  • 5. Re: Upgrading problem
    957621 Newbie
    Currently Being Moderated
    Yes, I ended up doing exactly the same, I've uninstalled everything, downloaded the latest version and installed everything again. Hopefully next time the upgrade works

    Thanks for your comments!

    Edited by: 954618 on Sep 26, 2012 9:00 AM

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points