8 Replies Latest reply: Sep 26, 2012 12:34 PM by 943897 RSS

    Unable to install requird packages 4 Installing 11gR2 db in OEL 5.4 (64bit)

    943897
      Hi Friends,

      I have been facing 'checks failed' errors while trying to install Oracle db 11gR2 (for 64bit linux) in my Oracle Linux 5.4 (64bit) installed machine.

      Had followed Sergio's blog and had selected oracle-validated package during the setup of the oracle linux OS using the installation dvd. https://blogs.oracle.com/sergio/entry/installing_required_rpms_from_1


      Following are the package which still show as Failed :
      libaio-devel-0.3.106(i386)
      unixODBC-devel-2.2.11(i386)

      After inserting the Oracle installation DVD , i tried to install the missing packages. But was not able to succeed.

      [root@localhost Enterprise Linux dvd 20090908]# cd Server/
      [root@localhost Server]# rpm -Uvh unixODBC-devel-2.*
      Preparing... ########################################### [100%]
      package unixODBC-devel-2.2.11-7.1.x86_64 is already installed
      [root@localhost Server]# rpm -Uvh unixODBC-devel-2.2.11
      error: open of unixODBC-devel-2.2.11 failed: No such file or directory
      [root@localhost Server]# rpm -Uvh libaio-devel*
      Preparing... ########################################### [100%]
      package libaio-devel-0.3.106-3.2.x86_64 is already installed
      [root@localhost Server]# rpm -Uvh libaio-devel-0.3.106
      error: open of libaio-devel-0.3.106 failed: No such file or directory

      How can i get these packages installed , and proceed with my installation of 11gR2 database.
      Why are these packages missing even in the installation dvd ?

      Any help is much appreciated .

      Thanks in advance..


      Regards,
      Hari
        • 1. Re: Unable to install requird packages 4 Installing 11gR2 db in OEL 5.4 (64bit)
          Catch~22
          RPM does not resolve software dependencies. You're better off with YUM, which does.

          Simply configure Oracle Public Yum http://public-yum.oracle.com or point your configuration to the installation DVD. In the later case simply copy and paste the following to the command prompt (root):

          <pre>
          cat > /etc/yum.repos.d/dvd.repo <<EOF
          [Install_DVD_base]
          name=Install DVD
          baseurl=file:///mnt/Server
          gpgcheck=0
          enabled=1
          skip_if_unavailable=True
          EOF
          #
          </pre>

          Then mount your installation DVD:

          <pre>
          cd /
          umount /dev/cdrom
          mount -o loop -t iso9660 /dev/cdrom /mnt
          </pre>

          Then type:

          <pre>
          yum install oracle-validated
          </pre>

          It will install all prerequisite software, setup kernel parameters and create the oracle account and groups if they do not already exist.

          Btw, why bother with 5.4 when there is 5.8 ?!
          • 2. Re: Unable to install requird packages 4 Installing 11gR2 db in OEL 5.4 (64bit)
            943897
            Hi Dude,

            Thanks a lot for looking into this problem !

            Did exactly as you have told. Oracle-validated rpm is showing as already installed , and i am still facing the "Checks failed" message for the following packages :

            libaio-devel-0.3.106(i386)
            unixODBC-devel-2.2.11(i386)



            PSB for the o/p of the steps run :

            [root@localhost ~]# cat > /etc/yum.repos.d/dvd.repo <<EOF
            >
            [Install_DVD_base]

            name=Install DVD

            baseurl=file:///mnt/Server

            gpgcheck=0

            enabled=1

            skip_if_unavailable=True

            EOF
            [root@localhost ~]# cd /
            [root@localhost /]# umount /dev/cdrom
            [root@localhost /]# mount -o loop -t iso9660 /dev/cdrom /mnt
            [root@localhost /]# yum install oracle-validated
            Loaded plugins: security
            Install_DVD_base | 1.1 kB 00:00
            Install_DVD_base/primary | 1.0 MB 00:00
            Install_DVD_base 3024/3024
            Setting up Install Process
            Package oracle-validated-1.0.0-18.el5.x86_64 already installed and latest version
            Nothing to do

            What can i possibly do now ? Please advise.

            And , this is being done in oel 5.4 because i am trying to setup Siebel Server environment in Linux , and oel 5.4 is the max. supported version mentioned in the docs.


            Regards,
            Hari
            • 3. Re: Unable to install requird packages 4 Installing 11gR2 db in OEL 5.4 (64bit)
              Catch~22
              I was assuming you are installing Oracle 11gR2 11.2.0.1 for x86_64 since you did not mention any version.

              What exactly are you trying to install?
              • 4. Re: Unable to install requird packages 4 Installing 11gR2 db in OEL 5.4 (64bit)
                943897
                Am trying to install Oracle db 11gR2 (for 64bit linux) in an Oracle Linux 5.4 (64bit) installed machine.
                • 5. Re: Unable to install requird packages 4 Installing 11gR2 db in OEL 5.4 (64bit)
                  Catch~22
                  Am trying to install Oracle db 11gR2 (for 64bit linux) in an Oracle Linux 5.4 (64bit) installed machine.
                  I was wondering about the release version.
                  And , this is being done in oel 5.4 because i am trying to setup Siebel Server environment in Linux , and oel 5.4 is the max. supported version mentioned in the docs.
                  I don't know Siebel, but from a OS perspective this sounds very odd.
                  What can i possibly do now ? Please advise.
                  You can try the following:

                  yum install unixODBC-devel.i386 libaio-devel.i386

                  But chances are you will probably not need them at all and can simply press the "ingore" button in the OUI installer dialog.
                  • 6. Re: Unable to install requird packages 4 Installing 11gR2 db in OEL 5.4 (64bit)
                    943897
                    @Dude

                    yes , it worked. I did not try to install the missing packages , and like you advised , i ignored it , and the installation finished successfully !
                    I was focussed only on the problem that i never tried to explore/see other viabilities. Thks a lot for your direction.

                    Using dbca , i created a database instance (sid : oracle) successfully , but the instance is not up and running.

                    echo $ORACLE_HOME and echo $ORACLE_SID does not yield any o/p.

                    Checked whether any processes with name 'oracle' is running [#ps -ef |grep oracle], but cannot see any such process.
                    #ps -ef |grep tns >> no results.

                    Can you also please advice on how to get the db instance up and running.


                    Regards,
                    Hari
                    • 7. Re: Unable to install requird packages 4 Installing 11gR2 db in OEL 5.4 (64bit)
                      Catch~22
                      This isn't really a Linux question and belongs to the Database forum, but simply put:

                      <pre>
                      su - oracle
                      source oraenv

                      lsnrctl start

                      sqlplus / as sysdsba
                      startup

                      </pre>
                      • 8. Re: Unable to install requird packages 4 Installing 11gR2 db in OEL 5.4 (64bit)
                        943897
                        @Dude

                        thks a lot once again for your helping out promptly.
                        Have started the database instance successfully.

                        regards,
                        Hari