0 Replies Latest reply on Sep 27, 2012 4:44 PM by REDO LOG

    getting a problem when trying to run  a script on OMB Plus

      Hi all
      I followed the tutorial at the oracle website : http://www.oracle.com/webfolder/technetwork/tutorials/obe/db/11g/r1/owb/owb11gupdate_getting_started_intro/lesson1/less1_start.htm#t2s1_

      I arrived to the Run the Setup Scripts with are scripts downloaded from oracle contained in the newowbdemofile witch in compressed in "owbdemo_files.zip"(you can download the zip file from the same page)

      so, I modified the owbdemoinit.tcl file as follows:
      #define global variables used in procedures
      global debug
      global iconlocation
      global owbclient
      global owbclientpwd
      global host
      global port
      global service
      global udoappdefname
      global themodule
      #Set all common variables
      set owbclient rep_owner
      set owbclientpwd rep_owner
      set sysuser sys
      set syspwd elmaazouzdwh
      set host localhost
      set port 1521
      set service dwh
      set project OWB_DEMO
      set sourcedir C:\Documents and Settings\ouboujlal\Bureau\newowbdemo
      set dataspace USERS
      set indexspace USERS
      set tempspace TEMP
      set snapspace USERS
      set sqlpath E:\oracle\product\10.2.0\db_1\BIN
      set sid dwh
      #set the workspace info
      set workspaceOwner rep_owner
      set workspaceName  my_workspace
      the problem is that I shouldn't have no space in the value attribute set variable value(witch is not the case because, there is a two spaces at set sourcedir C:\Documents and Settings\ouboujlal\Bureau\newowbdemo)

      to avoid that problem I moved the directory newowbdemo to C:\ (not that naturally I have to change the set sourcedir C:\Documents and Settings\ouboujlal\Bureau

      \newowbdemo to C:\newowbdemo) I run the script owbdemoinit.tcl as the tutorial suggests with no problem, then I run the loadall.tcl script from the same directory

      (C:\neowbdemo) the operation did not complete because there was a problem in the set sourcedir ... there was a space I exit the OMB+ prompt and try again

      but I get the following message :

      OMB+> source loadall.tcl
      API0408: Within same namespace domain one object has already used the name OWB_DEMO.

      how can I remove the OWB_DEMO object? or undo the entire operations of the loadallscript

      any help will be highly appreciated
      thank you so much