7 Replies Latest reply: Nov 19, 2012 7:19 AM by Kalyan Pasupuleti-Oracle RSS

    wlst deploy via ant fails with NameNotFoundException

    963585
      All,

      I am trying to setup a deployment of a simple ear application to Weblogic using wlst via ant.

      The deployment keeps failing with a NameNotFoundException.

      -----------------------
      ####<Sep 20, 2012 4:41:35 PM CDT> <Error> <Deployer> <osb2-dev-1> <WLS_APPMGD1> <[ACTIVE] ExecuteThread: '8' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1348177295661> <BEA-149265> <Failure occurred in the execution of deployment request with ID '1348177287862' for task '131'. Error is: 'javax.naming.NameNotFoundException: Unable to resolve 'ejb.xxxxServiceSLSBLocalHome'. Resolved 'ejb'; remaining name 'xxxxServiceSLSBLocalHome''
      javax.naming.NameNotFoundException: Unable to resolve 'ejb.xxxxServiceSLSBLocalHome'. Resolved 'ejb'; remaining name 'xxxxServiceSLSBLocalHome'
      at weblogic.jndi.internal.BasicNamingNode.newNameNotFoundException(BasicNamingNode.java:1139)
      at weblogic.jndi.internal.BasicNamingNode.lookupHere(BasicNamingNode.java:252)
      --------------------------

      Note that I struck out the actual service name with xxxx. Here is output from ant:

      --------------------------
      wl-deploy-only:
      [wldeploy] weblogic.Deployer -verbose -upload -noexit -name xxxx -source artifacts\xxxx.ear -targets APPMGD_Cluster -adminurl t3://soaadmin-dev-1:7003 -user weblogic -password ******** -deploy -appversion anthill-2240
      [wldeploy] weblogic.Deployer invoked with options: -verbose -upload -noexit -name xxxx -source artifacts\xxxx.ear -targets APPMGD_Cluster -adminurl t3://soaadmin-dev-1:7003 -user weblogic -deploy -appversion anthill-2240
      [wldeploy] <Sep 20, 2012 4:01:34 PM CDT> <Info> <J2EE Deployment SPI> <BEA-260121> <Initiating deploy operation for application, xxxx [archive: artifacts\xxxx.ear], to APPMGD_Cluster .>
      [wldeploy] Task 129 initiated: [Deployer:149026]deploy application xxxx [Version=anthill-2240] on APPMGD_Cluster.
      [wldeploy] Task 129 failed: [Deployer:149026]deploy application xxxx [Version=anthill-2240] on APPMGD_Cluster.
      [wldeploy] Target state: deploy failed on Cluster APPMGD_Cluster
      [wldeploy] java.lang.Exception: [DeploymentService:290069]Commit failed message received for id: '1,348,174,902,597' . But exception details cannot be transported. Please look at target server log file for more details.
      [wldeploy]
      [wldeploy] java.lang.Exception: [DeploymentService:290069]Commit failed message received for id: '1,348,174,902,597' . But exception details cannot be transported. Please look at target server log file for more details.
      [wldeploy]
      [wldeploy]
      [wldeploy] Target Assignments:
      [wldeploy] + xxxx APPMGD_Cluster

      BUILD FAILED
      weblogic.Deployer$DeployerException: weblogic.deploy.api.tools.deployer.DeployerException: Task 129 failed: [Deployer:149026]deploy application xxxx [Version=anthill-2240] on APPMGD_Cluster.
      Target state: deploy failed on Cluster APPMGD_Cluster
      java.lang.Exception: [DeploymentService:290069]Commit failed message received for id: '1,348,174,902,597' . But exception details cannot be transported. Please look at target server log file for more details.

      java.lang.Exception: [DeploymentService:290069]Commit failed message received for id: '1,348,174,902,597' . But exception details cannot be transported. Please look at target server log file for more details.



      at weblogic.Deployer.run(Deployer.java:72)
      at weblogic.Deployer.mainWithExceptions(Deployer.java:62)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at weblogic.ant.taskdefs.management.WLDeploy.invokeMain(WLDeploy.java:420)
      at weblogic.ant.taskdefs.management.WLDeploy.execute(WLDeploy.java:349)
      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
      at org.apache.tools.ant.Task.perform(Task.java:348)
      at org.apache.tools.ant.Target.execute(Target.java:357)
      at org.apache.tools.ant.Target.performTasks(Target.java:385)
      at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
      at org.apache.tools.ant.Project.executeTarget(Project.java:1307)
      at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
      at org.apache.tools.ant.Project.executeTargets(Project.java:1191)
      at org.apache.tools.ant.Main.runBuild(Main.java:758)
      at org.apache.tools.ant.Main.startAnt(Main.java:218)
      at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
      at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
      Caused by: weblogic.deploy.api.tools.deployer.DeployerException: Task 129 failed: [Deployer:149026]deploy application xxxx [Version=anthill-2240] on APPMGD_Cluster.
      Target state: deploy failed on Cluster APPMGD_Cluster
      java.lang.Exception: [DeploymentService:290069]Commit failed message received for id: '1,348,174,902,597' . But exception details cannot be transported. Please look at target server log file for more details.

      java.lang.Exception: [DeploymentService:290069]Commit failed message received for id: '1,348,174,902,597' . But exception details cannot be transported. Please look at target server log file for more details.



      at weblogic.deploy.api.tools.deployer.Jsr88Operation.report(Jsr88Operation.java:542)
      at weblogic.deploy.api.tools.deployer.Deployer.perform(Deployer.java:140)
      at weblogic.deploy.api.tools.deployer.Deployer.runBody(Deployer.java:88)
      at weblogic.utils.compiler.Tool.run(Tool.java:158)
      at weblogic.utils.compiler.Tool.run(Tool.java:115)
      at weblogic.Deployer.run(Deployer.java:70)
      at weblogic.Deployer.mainWithExceptions(Deployer.java:62)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at weblogic.ant.taskdefs.management.WLDeploy.invokeMain(WLDeploy.java:419)
      at weblogic.ant.taskdefs.management.WLDeploy.execute(WLDeploy.java:349)
      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
      at org.apache.tools.ant.Task.perform(Task.java:348)
      at org.apache.tools.ant.Target.execute(Target.java:357)
      at org.apache.tools.ant.Target.performTasks(Target.java:385)
      at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
      at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
      at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
      at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
      at org.apache.tools.ant.Main.runBuild(Main.java:758)
      at org.apache.tools.ant.Main.startAnt(Main.java:217)
      ... 2 more

      Total time: 25 seconds
      --------------------------

      I tried redeploy instead of undeploy, but is still fails. Is there anything I am missing?

      Thanks.

      Edited by: 960582 on Sep 21, 2012 7:18 AM