4 Replies Latest reply: Oct 11, 2012 5:12 PM by 933475 RSS

    APEX 4.1 Blank Login Page

    Incognito
      Hello,

      I have Oracle 11g installed on a windows 7 machine and have installed Apex 4.1. I followed the install guide to install 4.1 using EPG. I didn't get any errors during installation and have validated the install by using

      SELECT STATUS FROM DBA_REGISTRY WHERE COMP_ID = 'APEX';

      I am using Firefox 9.0.1 browser but when I enter the URL http://localhost:8081/apex_apex_admin I get a blank page returned without a login prompt.

      has anybody any ideas why i am not getting a lLogin prompt?

      Regards
        • 1. Re: APEX 4.1 Blank Login Page
          riedelme
          I saw this a month or two ago installing Apex on 11gR2 (XP). My case had dual causes, both due to set-up:
          * a PL/SQL script in the installation instructions failed because I had interpreted "+/tmp+" as the "/tmp" folder instead of the
          folder where I had unzipped the Apex installataion files
          * I had not unlocked the APEX_PUBLIC_USER account

          After running the script with the proper folder specified and unlocking the account I got the proper login screen.

          Re-check the post-installation tasks to make sure you didn't miss anything :)

          BTW, I'm using the internal listener. The one you chose may/may not make a difference
          • 2. Re: APEX 4.1 Blank Login Page
            Incognito
            Hi Riedelme,

            The same PL/SQL script failed for me as i had specified the apex folder instead of the folder above where apex had been unzipped. I've run the script again and can now login to Apex and apex Admin.

            Many thanks for your help
            • 3. Re: APEX 4.1 Blank Login Page
              923947
              I have a similar problem running Apex through Oracle HTTP Server.

              Which script needs to be rerun?

              Thanks - JR
              • 4. Re: APEX 4.1 Blank Login Page
                933475
                The right order of installation is :

                SQL> @apexins sysaux sysaux temp /i/
                .......................

                SQL> apxldimg /mnt/hgfs/vm_share/
                PL/SQL procedure successfully completed.

                old 1: create directory APEX_IMAGES as '&1/apex/images'
                new 1: create directory APEX_IMAGES as '/mnt/hgfs/vm_share/apex/images' -- make sure here is the right directory....+_

                Directory created.


                PL/SQL procedure successfully completed.


                PL/SQL procedure successfully completed.


                PL/SQL procedure successfully completed.


                Commit complete.

                timing for: Load Images
                Elapsed: 00:01:17.23

                Directory dropped.

                SQL> @apxchpwd
                Enter a value below for the password for the Application Express ADMIN user.


                Enter a password for the ADMIN user []

                Session altered.

                ...changing password for ADMIN

                PL/SQL procedure successfully completed.


                Commit complete.

                SQL>