This discussion is archived
3 Replies Latest reply: Nov 28, 2012 4:27 AM by 871780 RSS

variable "Sender" is not defined

robert224810 Explorer
Currently Being Moderated
Hi all,
I have started getting an error when building or rebuilding some of my ABCS'. I did get this error once over a year ago:
Composite errors after upgrade to
On the previous occasion I was unable to resolve it and simply recreated all the affected ABCS'

The Errors I am getting are as follows:
[scac] Validating composite "H:\JDev_ADF_SOA\mywork\AAAS\AccessQueryListEbizOSSProvABCS\composite.xml"
[scac] Setting BPELC option 'classpath' to C:\oracle\products\JDeveloper_ADF_SOA\Middleware_11_1_1_5_0\jdeveloper\jdev\extensions\;C:\oracle\products\JDeveloper_ADF_SOA\Middleware_11_1_1_5_0\jdeveloper\soa\modules\oracle.soa.fabric_11.1.1\fabric-runtime.jar;C:\oracle\products\JDeveloper_ADF_SOA\Middleware_11_1_1_5_0\jdeveloper\soa\modules\oracle.soa.mgmt_11.1.1\soa-infra-mgmt.jar;C:\oracle\products\JDeveloper_ADF_SOA\Middleware_11_1_1_5_0\oracle_common\modules\oracle.fabriccommon_11.1.1\fabric-common.jar;C:\oracle\products\JDeveloper_ADF_SOA\Middleware_11_1_1_5_0\jdeveloper\soa\modules\oracle.soa.bpel_11.1.1\orabpel.jar;C:\oracle\products\JDeveloper_ADF_SOA\Middleware_11_1_1_5_0\jdeveloper\soa\modules\oracle.soa.mediator_11.1.1\mediator_client.jar;C:\oracle\products\JDeveloper_ADF_SOA\Middleware_11_1_1_5_0\oracle_common\modules\oracle.mds_11.1.1\mdsrt.jar;C:\oracle\products\JDeveloper_ADF_SOA\Middleware_11_1_1_5_0\jdeveloper\lib\aia.jar;;H:\JDev_ADF_SOA\mywork\AAAS\AccessQueryListEbizOSSProvABCS\SCA-INF\classes
[scac] error: in AccessQueryListEbizOSSProvABCSProcess.bpel(85): XML element "{}Sender" of variable "Sender" is not defined
[scac] error: in AccessQueryListEbizOSSProvABCSProcess.bpel(87): XML element "{}EBMHeader" of variable "EBM_HEADER" is not defined
[scac] error: in AccessQueryListEbizOSSProvABCSProcess.bpel(469): XML element "{}EndpointReference" of variable "EndpointReference" is not defined

I am working on a complicated project with mutiple ABCS'. This error appeared on on of the ABCS' when I created it. After spending a day generating the ABCS about 8 times on mutiple machines I always got the error with the same 3 variables reporting themselves to not be defined.
I then asked the SOA server and Database backend to be restarted. This cleared the error and the composite complied normally.

Now a couple of days later I have opened different ABCS and made one very small change. When I compile this composite the error has appeared. (3 variables not being defined)
I tried un-doing the change and re-compiling, and I still get the problem.
I have tried uploading the file to the Weblogic server and deploying using a deployment plan but I still get the same error.
I have tried mutiple full restarts of the server and database but this time it is not making the error go away.

I have weblogic
I am on a cluster enviroment with 2 machines in the cluster.

I have also redeployed the AIAConfigurationProperties file but that didn't work. After this I restarted weblogic and it's database and then the probem went away again; however a subsequent attempt to rebuild the composite resulted in the error returning.

I have looked through vaious logs but can not find anything that points to a possible cause.
Can anyone suggest any further avenues of enquiry?
  • 1. Re: variable "Sender" is not defined
    robert224810 Explorer
    Currently Being Moderated
    Update, after the last redeploy and reboot the error seems to occur when rebuilding any ABCS not just the initial two that were failing.
    The error still occurs of different machines.
  • 2. Re: variable "Sender" is not defined
    robert224810 Explorer
    Currently Being Moderated
    FYI my scac log conatins the following:
    04-Oct-2012 14:46:49 oracle.adf.share.ADFContext getCurrent
    WARNING: Automatically initializing a DefaultContext for getCurrent.
    Caller should ensure that a DefaultContext is proper for this use.
    Memory leaks and/or unexpected behaviour may occur if the automatic initialization is performed improperly.
    This message may be avoided by performing initADFContext before using getCurrent().
    To see the stack trace for thread that is initializing this, set the logging level of oracle.adf.share.ADFContext to FINEST
    04-Oct-2012 14:46:51 oracle.fabric.common.wsdl.SchemaManager isIncrementalBuildSupported
    INFO: XMLSchema incremental build enabled.
    04-Oct-2012 14:46:52 com.collaxa.cube.CubeLogger info
    INFO: validating "AccessQueryListEbizOSSProvABCSProcess.bpel" ...
    oracle.jrf.UnknownPlatformException: JRF is unable to determine the current application server platform.
         at oracle.jrf.ServerPlatformSupportFactory.getInstance(
         at oracle.integration.platform.blocks.WLSPlatformConfigurationProvider.<clinit>(
         at oracle.integration.platform.blocks.FabricConfigManager.<clinit>(
         at oracle.integration.platform.blocks.xpath.FabricXPathFunctionResolver.loadXpathFunctions(
         at oracle.integration.platform.blocks.xpath.FabricXPathFunctionResolver.loadXPathConfigFile(
         at oracle.integration.platform.blocks.xpath.FabricXPathFunctionResolver.init(
         at com.collaxa.cube.xml.xpath.BPELXPathFunctionNameResolver.loadFabricXpathFunctions(
         at com.collaxa.cube.xml.xpath.BPELXPathFunctionNameResolver.<init>(
         at com.collaxa.cube.xml.xpath.BPELXPathFunctionNameResolver.<clinit>(
         at com.collaxa.cube.lang.compiler.bpel.XPathExprValidatorVisitor.<init>(
         at com.collaxa.cube.lang.compiler.bpel.AssignValidator.<init>(
         at com.collaxa.cube.lang.compiler.bpel.BpelParser.<init>(
         at com.collaxa.cube.lang.compiler.bpel.BPELValidator.validate(
         at com.collaxa.cube.lang.compiler.BPEL1Processor.validate(
         at com.collaxa.cube.lang.compiler.BPEL1Processor.process(
         at com.collaxa.cube.lang.compiler.CubeParserHelper.compile(
         at oracle.fabric.bpel.bpelc.BPELComponentValidator.validate(
         at oracle.soa.scac.ValidateComposite.validateComponentTypeServicesReferences(
         at oracle.soa.scac.ValidateComposite.doValidation(
         at oracle.soa.scac.ValidateComposite.main(

    Although this error appears when building ABCS' that both work and do not work
  • 3. Re: variable "Sender" is not defined
    871780 Newbie
    Currently Being Moderated
    Just Try to Edit the variables "sender","EBM Header" etc and Re-Select the Message Type.

    It should Work.



  • Correct Answers - 10 points
  • Helpful Answers - 5 points