0 Replies Latest reply: Oct 8, 2012 8:02 AM by 810016 RSS

    Problem with webcam live-streaming (ultracam.jar)

    810016
      I've got an IP-web-cam that when I access it using firefox, it keeps insisting that I have a missing plug-in and when I click on the "install plugin" link, it wants me to install the java JRE version 1.7.something. I already have the 1.6.something installed and working, so I don't know why it thinks it needs to install the JRE.

      I've come across this elsewhere on the web:

      ========
      I troubleshot the Firefox installation and found an incompatibility with /library/internet plug-ins/javaplugincocoa.bundle. Once that plug-in was removed, the video stream worked under Firefox with the same ultracam applet. Also tested successfully with Opera v9.62.
      ========

      This guy had the same camera, but found a way to get the streaming working on a mac (I'm on windows). I think the problem is with the file ultracam.jar. When I try to "install" it (by double-clicking on it) I get "Failed to load Main-Class manifest attribute". When I unpack it and look at manifest.mf, I don't see "Main-Class". What I see is:

      ======
      Manifest-Version: 1.0
      Created-By: 1.6.0_17 (Sun Microsystems Inc.)

      Name: ultracam.class
      SHA1-Digest: 7UxuH4Scb0tsxTPC2MGlW7YwHa0=

      Name: ultracam$Buffer.class
      SHA1-Digest: gho1wytYUzp5YTuv0RJiF/4Z9FU=
      =======

      That's it. That's the complete contents of manifest.mf.

      So what's the deal here? What do I need to do with this ultracam.jar and firefox so that I can get streaming video from this IP-webcam?