3 Replies Latest reply: Oct 8, 2012 12:24 PM by Kalyan Pasupuleti-Oracle RSS

    Weblogic 10.3 is not starting - /WEB-INF/netuix-config.xml malformed

    966588
      Hi,
      I am trying to start WebLogic server, but it throws me an error with malformed netuix-config.xml.



      I found this (Weblogic 10.3 admin console will not start thread and I also tried to replace {WL_HOME/server/lib/consoleapp} from working installation from my friend, but it still doesn't work :(

      I am starting it in Ubuntu from console and there are only Info messages until this:

      <6.10.2012 16:34:04 CEST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STANDBY>
      <6.10.2012 16:34:04 CEST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STARTING>
      <6.10.2012 16:34:42 CEST> <Alert> <OSB Security> <BEA-387068> <There is no PKI credential mapper provider configured in your security realm. Service key provider management will be disabled. Configure a PKI credential mapper provider if you need service provider support. This is typically the case if you have Oracle Service Bus proxy services with web service security enabled or outbound 2-way SSL connections.>
      <6.10.2012 16:34:50 CEST> <Warning> <WliSbTransports> <BEA-381917> <MQ Transport could not be registered due to : Missing MQ Library>
      <6.10.2012 16:35:02 CEST> <Error> <netuix> <BEA-423103> <[console] Deployment descriptor /WEB-INF/netuix-config.xml malformed.>

      and it stops doing anything. The only way to interruption is close the terminal. But then if I try start it again:

      ERROR: transport error 202: bind failed: Address is using
      ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
      JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:708]
      FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)
      Aborted (core dumped)
      Stopping Derby server...
      Derby server stopped.

      So I have to restart the computer.

      The admin server log says:
      ...
      ...
      ####<6.10.2012 16:34:55 CEST> <Info> <WebLogicServer> <johny-PC> <AdminServer> <[STANDBY] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1349534095534> <BEA-000256> <Invoking weblogic.transaction.internal.StartupClass.main(null)>
      ####<6.10.2012 16:34:55 CEST> <Info> <Deployer> <johny-PC> <AdminServer> <[STANDBY] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1349534095574> <BEA-149059> <Module dms.war of application DMS Application [Version=11.1.1.1.0] is transitioning from STATE_PREPARED to STATE_ADMIN on server AdminServer.>
      ####<6.10.2012 16:34:55 CEST> <Info> <Deployer> <johny-PC> <AdminServer> <[STANDBY] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1349534095575> <BEA-149060> <Module dms.war of application DMS Application [Version=11.1.1.1.0] successfully transitioned from STATE_PREPARED to STATE_ADMIN on server AdminServer.>
      ####<6.10.2012 16:34:57 CEST> <Info> <netuix> <johny-PC> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1349534097264> <BEA-423101> <[console] Initializing the NetUIx container>
      ####<6.10.2012 16:35:02 CEST> <Error> <netuix> <johny-PC> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1349534102056> <BEA-423103> <[console] Deployment descriptor /WEB-INF/netuix-config.xml malformed.>

      Can you please help me? I don't know what to do... :(

      Edited by: 963585 on 6.10.2012 7:51

      Edited by: 963585 on 6.10.2012 9:09