1 Reply Latest reply: Oct 11, 2012 12:35 PM by Gary Graham-Oracle RSS

    Data tab not working

      For some reason when I open a table and click on the "Data" tab, nothing happens. All of the other tabs work just fine, I can see the "columns", "constraints", etc. But the Data one won't do anything. Anyone know what might be causing this? I've tried reinstalling the application and I continue to get the same issue. I've even tried downloading an older version, but I still end up with the same problem. It used to work just fine, but now im thinking it has to be something about my machine (using macbook pro version 10.7.5)
        • 1. Re: Data tab not working
          Gary Graham-Oracle
          But the Data one won't do anything
          If clicking on the Data tab gives it the focus but no data rows appear, that likely means you have privileges on the metadata (like SELECT_CATALOG_ROLE or SELECT ANY DICTIONARY) but not any SELECT on the table itself. That might happen if you drill-down through the Other Users node in the Connections view to examine their tables -- possibly you had the SELECT privilege on a table but someone revoked it?

          Otherwise if clicking on the Data tab does nothing at all (not even gaining the focus), searching the forum, we can see bugs against very old SQL Developer versions that might match your situation. Also there have been cases where a new version is installed in the same directory as the prior installation and results are unpredictable.

          You really need to provide more details about your environment (SQL Dev & Java versions tested), user privileges/roles, and the test case.

          SQL Developer Team