This discussion is archived
8 Replies Latest reply: Oct 19, 2012 8:43 AM by mybro62 RSS

LivePatch not working after fresh install of MW 2.18

967559 Newbie
Currently Being Moderated
Hi,
I just installed MW 2.18. (BTW, the install will fail if you use a '!' char in your system user password).
I then created a customer. I did not create a project yet.
I clicked on the LivePatch tab because I want to get to 2.19 before I create my project. The following errors below were displayed. Is this something I can fix now? Do I need to have a aru_mw_r12_version.txt file (I don't currently have one). I'd like to know my install is valid/working/good.
Thanks, Dean
----
LivePatch Version Check
Current LivePatch Version is 2.18
Latest LivePatch Version is UNKNOWN
A later version of the Maintenance Wizard is available.
Running phase 1 of Automatic LivePatch...
LivePatch Phase 1 Output

ERROR: std.err had output:
tail: cannot open `/Stage/patches/MWiz/aru_mw_r12_version.txt' for reading: No such file or directory
tail: cannot open `/Stage/patches/MWiz/aru_mw_r12_version.txt' for reading: No such file or directory
/mwiz/oracle/mwizdb/10.2.0/eof/scripts/COMMON/auto_livepatch.sh[1596]:
/mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: cannot create [No such file or directory]
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
egrep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
/mwiz/oracle/mwizdb/10.2.0/eof/scripts/COMMON/auto_livepatch.sh[1596]:
/mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: cannot create [No such file or directory]
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
egrep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
/mwiz/oracle/mwizdb/10.2.0/eof/scripts/COMMON/auto_livepatch.sh[1596]:
/mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: cannot create [No such file or directory]
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
egrep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
/mwiz/oracle/mwizdb/10.2.0/eof/scripts/COMMON/auto_livepatch.sh[1596]:
/mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: cannot create [No such file or directory]
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
egrep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
/mwiz/oracle/mwizdb/10.2.0/eof/scripts/COMMON/auto_livepatch.sh[1596]:
/mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: cannot create [No such file or directory]
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
egrep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
grep: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_.log: No such file or directory
ls: p*: No such file or directory
cp: cannot create regular file `/mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_-99_.sh': No such file or directory
=====================================================================
Beginning phase 1 of LivePatch at Wed Oct 10 14:13:31 EDT 2012...
Using existing LivePatch directory for log files: /mwiz/oracle/mwizdb/10.2.0/eof/livepatch
Downloading the most recent version of the Maintenance Wizard LivePatch.

Running Download script get_from_url_-99_.sh in /Stage/patches/MWiz

################################################

ERROR - Looks like ftp failed, see ls -l p\* (above) of EOF_PATCH_TOP
EOF_PATCH_TOP=/Stage/patches/MWiz
Log of session: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_\*.log
===================================================================
1) Have the administrator try running the ftp script manually.
OR
2) set HOME/.netrc, then try Script: /mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_-99_.sh

Running Get_Patch_Updates utility to download p_R12_GENERIC.zip from updates.oracle.com
ERROR: Unable to download the latest MW patch.
Please manually download and apply it now.
=====================================================================
ERROR! Failed to download the patch from updates.oracle.com.
Please review /mwiz/oracle/mwizdb/10.2.0/eof/livepatch/auto_lp_26574.log for a more detailed error.
=====================================================================
  • 1. Re: LivePatch not working after fresh install of MW 2.18
    967559 Newbie
    Currently Being Moderated
    Can someone provide me with example contents of file aru_mw_r12_version.txt for version 2.18?
    I'm thinking if I can create that missing file, livepatch might work.
    Thanks, Dean
  • 2. Re: LivePatch not working after fresh install of MW 2.18
    mybro62 Journeyer
    Currently Being Moderated
    I think just touching the file might work. Here is my content.


    6694618,2.08,MAINTENANCE WIZARD LIVE PATCH RELEASE 2.08
    6821008,2.09,MAINTENANCE WIZARD LIVE PATCH RELEASE 2.09
    7345662,2.12,MAINTENANCE WIZARD LIVE PATCH RELEASE 2.12
    7479670,2.13,MAINTENANCE WIZARD LIVE PATCH RELEASE 2.13
    8467769,2.14,MAINTENANCE WIZARD LIVE PATCH RELEASE 2.14
    8912213,2.15,MAINTENANCE WIZARD LIVE PATCH RELEASE 2.15
    9494244,2.16,MAINTENANCE WIZARD LIVE PATCH RELEASE 2.16
    10030826,2.17,MAINTENANCE WIZARD LIVE PATCH RELEASE 2.17
    11073195,2.18,MAINTENANCE WIZARD LIVE PATCH RELEASE 2.18
    12728371,2.19,MAINTENANCE WIZARD LIVE PATCH RELEASE 2.19
  • 3. Re: LivePatch not working after fresh install of MW 2.18
    967559 Newbie
    Currently Being Moderated
    Hi,
    Creating the aru.txt file with the contents you supplied gets me a little further.
    It then creates the file get_from_url_-99_12728371.sh but seems to fail when executing it.
    I've checked the .netrc that was created and it logs me into updates.oracle.com properly.
    The log file '/mwiz/oracle/mwizdb/10.2.0/eof/log/INSTANCE_-99/get_from_url_12728371\*.log' never gets created so I can't see what the error is.
    Below is the contents of the script.
    $ cat get_from_url_-99_12728371.sh
    /mwiz/oracle/mwizdb/10.2.0/jre/*/bin/java -Dbug_number="12728371" -Daction="download_file" -Dplatform="46" -Ddownload_directory="./" oracle.support.mw.AruExecutor
    ls -l p12728371__*.zip
    --
    How do I set the environment properly to get the script to run. Looks like I need classpath set to something. Anything else? I tried EOF.env, didn't help.
    [oraerpt@txsdbsnwh901 MWiz]$ ./get_from_url_-99_12728371.sh
    Exception in thread "main" java.lang.NoClassDefFoundError: oracle/support/mw/AruExecutor
    ls: p12728371__*.zip: No such file or directory
    Thanks, Dean
  • 4. Re: LivePatch not working after fresh install of MW 2.18
    mybro62 Journeyer
    Currently Being Moderated
    You may want to use the manual method to upload the livepatch.

    If you wish to continue to troubleshoot this with me that is fine also.

    Sometime after the release of Maintenance Wizard 2.18, Oracle modified their method of connection to the updates.oracle.com server causing logins and downloads to fail.

    The fix is in 2.19 and that is the reason that the ftp failed to download the patch. You could manually place the patch in the $EOF_HOME/patch directory. This should cause the tool to use the already downloaded patch and not attempt to ftp the patch again from the update server.

    Thanks
  • 5. Re: LivePatch not working after fresh install of MW 2.18
    967559 Newbie
    Currently Being Moderated
    Hi,
    OK, since you say 2.19 fixes the download issue, I am perfectly fine copying the patch to the patch directory and running LivePatch.
    The only reason I was going to all this trouble to fix LivePatch was that I figured MW also would not be able to download patches for my R12 upgrade (which is critical).
    I copied the file in and ran LivePatch phase 1 & 2. No issues. It all seems to have worked.
    Is there anything you want me to check/verify?
    I will begin working on my 11.5.10.2 upgrade to R12 using MW. Please let me know if I need to be aware of any other critical issues with MW.
    Thanks, Dean
  • 6. Re: LivePatch not working after fresh install of MW 2.18
    mybro62 Journeyer
    Currently Being Moderated
    If you could tell me your 11i configuration and your target R12 configuration, I would be glad to tell you if there are any gotchas'.

    Thanks
  • 7. Re: LivePatch not working after fresh install of MW 2.18
    967559 Newbie
    Currently Being Moderated
    I am using 11.5.10.2 on RH Linux 5 (32bit for apps, 64 for DB), 11.2.0.2 RAC 2 node, 1TB, 4 apps tier nodes (2 nodes shared appl top, 1 node not, 1 node ASCP conc mgr on HP UX 10, 3 of the nodes are conc mgrs). Modules FIN, HR, MAN. OATM already done, ADI 6 already done.
    Our first test clone will be everything on a single 64bit node except the DB.
    Also, does MW expect you to have the R12 upgrade file system installed before you begin your MW project? I noticed MW was asking me for R12 config info when creating a project but I have not seen it in documentation anywhere if you are supposed to have already installed R12 tech/upgrade stack. Please advise.
    Thanks, Dean
  • 8. Re: LivePatch not working after fresh install of MW 2.18
    mybro62 Journeyer
    Currently Being Moderated
    964556 wrote:
    I am using 11.5.10.2 on RH Linux 5 (32bit for apps, 64 for DB), 11.2.0.2 RAC 2 node, 1TB, 4 apps tier nodes (2 nodes shared appl top, 1 node not, 1 node ASCP conc mgr on HP UX 10, 3 of the nodes are conc mgrs). Modules FIN, HR, MAN. OATM already done, ADI 6 already done.
    Our first test clone will be everything on a single 64bit node except the DB.
    MW does not currently support a RAC configuration. Oracle also recommends that customers, as a best practice and performance increase in completing the upgrade, disabling RAC during a R12 upgrade. You should also disable archive logging. Please refer to NOTE 269.1 for 11i - R12 upgrade advisor note.


    964556 wrote:
    Also, does MW expect you to have the R12 upgrade file system installed before you begin your MW project? I noticed MW was asking me for R12 config info when creating a project but I have not seen it in documentation anywhere if you are supposed to have already installed R12 tech/upgrade stack. Please advise.
    You can do it either way. I prefer to to the rapidinstall before the MW node configuration so that it reads from the actual xml config file. If you setup the project before laying down R12 you can manually point to where the files will be after the install, and you will have to manually create the foundation directories and env files so the config step passes.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points