11 Replies Latest reply: Oct 15, 2012 8:58 AM by Looney128 RSS

    Etherchannel LACP support?

    Looney128
      Now that I got my ISCSI working..... and now have it with ALB bonded with two ports. (ALB works)

      Figured I would get better performance using Dynamic Link Aggregation.
      So I set the bond to Dynamic Link Aggregation.

      I also set my Cisco 6509 to....

      Interface Port-channel4
      description OVMS2_stor
      switchport
      switchport access vlan 2
      switchport mode access

      interface GigabitEthernet3/22
      description OVMS2_stor
      switchport
      switchport access vlan 2
      no ip address
      spanning-tree portfast
      channel-protocol lacp
      channel-group 4 mode active

      interface GigabitEthernet3/30
      description OVMS2_stor
      switchport
      switchport access vlan 2
      no ip address
      spanning-tree portfast
      channel-protocol lacp
      channel-group 4 mode active


      I do not get a connection......

      show etherchannel 4 sum
      Flags: D - down P - bundled in port-channel
      I - stand-alone s - suspended
      H - Hot-standby (LACP only)
      R - Layer3 S - Layer2
      U - in use f - failed to allocate aggregator

      M - not in use, minimum links not met
      u - unsuitable for bundling
      w - waiting to be aggregated
      Number of channel-groups in use: 3
      Number of aggregators: 3

      Group Port-channel Protocol Ports
      ------------------------------+-------------------------
      4 Po4(SD) LACP Gi3/22(I) Gi3/30(I)


      Any ideas?
        • 1. Re: Etherchannel LACP support?
          user12273962
          LACP requires you set the proper bonding mode on the VM server. Have you tried that?
          • 2. Re: Etherchannel LACP support?
            budachst
            +1

            I have LACP etherchannels running to all of my VM servers without issues. As far as the speed bump goes - it depends. There are some instances where you will get more speed than on a single conenction. but that involves multipathing, where multipathd is running in round-robin mode. There are a lot of tuning opportunities for you to explore here… ;)

            …also I think you are missing the "switchport mode access" option in your actual interface configurations g3/22 and g3/30, since you configured your port-channel like that.
            • 3. Re: Etherchannel LACP support?
              Looney128
              I have the bond set to "Dynamic Link Aggregation"... Does the server need to be rebooted after it being set?
              • 4. Re: Etherchannel LACP support?
                budachst
                Usually, the server doesn't need to be restartet, after a Bond has been configured. Did you add the missing switchport mode access to your interface configurations?
                What does "show interface port-channel 4" show on your 6509?
                • 5. Re: Etherchannel LACP support?
                  Looney128
                  this is what is set now....


                  interface Port-channel4
                  description OVMS1_stor
                  switchport
                  switchport access vlan 2
                  switchport mode access

                  interface GigabitEthernet2/18
                  description OVMS1_stor
                  switchport
                  switchport access vlan 2
                  switchport mode access
                  channel-protocol lacp
                  channel-group 4 mode active

                  interface GigabitEthernet2/42
                  description OVMS1_stor
                  switchport
                  switchport access vlan 2
                  switchport mode access
                  channel-protocol lacp
                  channel-group 4 mode active
                  • 6. Re: Etherchannel LACP support?
                    Looney128
                    6509#show etherchannel 4 summary
                    Flags: D - down P - bundled in port-channel
                    I - stand-alone s - suspended
                    H - Hot-standby (LACP only)
                    R - Layer3 S - Layer2
                    U - in use N - not in use, no aggregation
                    f - failed to allocate aggregator

                    M - not in use, no aggregation due to minimum links not met
                    m - not in use, port not aggregated due to minimum links not met
                    u - unsuitable for bundling
                    d - default port

                    w - waiting to be aggregated
                    Number of channel-groups in use: 6
                    Number of aggregators: 6

                    Group Port-channel Protocol Ports
                    ------------------------------+----------------------------------------------
                    4 Po4(SD) LACP Gi2/18(I) Gi2/42(I)

                    Last applied Hash Distribution Algorithm: -
                    • 7. Re: Etherchannel LACP support?
                      Looney128
                      6509#show interface port-channel 4
                      Port-channel4 is down, line protocol is down (notconnect)
                      Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)
                      Description: OVMS1_stor
                      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
                      reliability 255/255, txload 1/255, rxload 1/255
                      Encapsulation ARPA, loopback not set
                      Keepalive set (10 sec)
                      Auto-duplex, Auto-speed, media type is unknown
                      input flow-control is off, output flow-control is off
                      ARP type: ARPA, ARP Timeout 04:00:00
                      Last input never, output never, output hang never
                      Last clearing of "show interface" counters never
                      Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
                      • 8. Re: Etherchannel LACP support?
                        Looney128
                        Queueing strategy: fifo
                        Output queue: 0/40 (size/max)
                        5 minute input rate 0 bits/sec, 0 packets/sec
                        5 minute output rate 0 bits/sec, 0 packets/sec

                        Can't post the rest of the show because the forum gives an error

                        Error      Sorry, this content is not allowed

                        Guess it does not like switch speak
                        • 9. Re: Etherchannel LACP support?
                          Looney128
                          Well...... I tried rebooting the server....and the bond it now up?????
                          • 10. Re: Etherchannel LACP support?
                            budachst
                            Odd - I hace configured LACP bonds on a couple of VM servers already an I am pretty sure, that none of them needed a reboot ever. Did the switch indicated the links being up before you rebooted the VM server?
                            • 11. Re: Etherchannel LACP support?
                              Looney128
                              Nope.....the switch said the link was down, but the server said the link was up (as well as the two nics).....so I don't know which end the problem would have been on ....switch or server.
                              thanks for the Help