1 Reply Latest reply: Oct 18, 2012 10:03 AM by 968630 RSS

    JavaFx2 project with LTI-CIVIL issue

    968630
      Hi all,

      Some time ago, i built a video api for my company, using LTI-CIVIL. All worked fine until we updated our main app, and started using JavaFX for some layout components.
      To be able to use those Javafx components we had to change the project in netbeans, from a normal Java to a JavaFx with swing project. All worked well running from the IDE, both the video API and Javafx stuff coexisted peacefully... until..

      well, unitl i decided to run the app using the compiled JAR... The app opens, but when i start the video aquisition from the webcam, the app crashes.
      I narrowed it down, and it crashes when the CaptureStream from LTI-CIVIL is started.. it really does not make any sense..

      I tried the exact same source code from the video api compiled inside a normal java project, and inside a javaFx project. On the normal project all woks fine, inside the javaFx project it crashes.. so im pretty sure its not my fault. And besides, it works well for bot projects running from the IDE..

      Btw: LTI-CIVIL relies heavily on native code..

      Any you have any idea of what might be causing this?

      Thanks in advance for all the help
      Best regards
      Pedro
        • 1. Re: JavaFx2 project with LTI-CIVIL issue
          968630
          Hi all,

          I did some more tests around this, and when i used the source code of civil instead of the compiled JAR, e get an error..

          But its a very strange error which only occurs when running the JAR.. It does not occur when running a normal JAVA project with the exact same code.

          This is the error..

          "Exception in thread "Thread-155" java.lang.IncompatibleClassChangeError: Class com.lti.civil.impl.jni.NativeVideoFormat does not implement the requested interface com.lti.civil.VideoFormat"

          The "NativeVideoFormat" implements the "VideoFormat".. why is it giving this error then? looks like some kind of compile issue..

          I know this not an issue that looks like it has high priority because it affects a third party API.. But since LTI-CIVIL is the only viable cross platform webcam capture API out there, this is really important to be solved.
          Otherwise no one will ever use JavaFX on an app with webcam support.. :(

          if needed i can try to cook a fully working trimmed down project just to trigger the error.

          regards