0 Replies Latest reply: Oct 19, 2012 8:19 AM by udo mehlem RSS

    DADs on WLS 11g (version 10.3.6.0) do not work (Error 404--Not Found)

    udo mehlem
      Actually we use Application Server 10g (version 10.1.2.3.0) for different Forms 10g Applications (roundabout 1000 Forms) and want to change to Forms 11g and Weblogic Server 11g (version 10.3.6.0). A Test-Application on the Weblogic Server works fine, but DAD’s do not work at all.

      In Enterprise Manager 10g i can configure DADs within the GUI of the Enterprise Manager, where i can see, if a connection could be established or not.
      In Enterprise Manager 11g Fusion Middleware Control this doesn't seem to exist anymore, so i tried to configure the DADs manually, but something has to be wrong or missing, because there is no connection to the database and the following error appears:

      Error 404--Not Found
      From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
      10.4.5 404 Not Found
      The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.
      If the server does not wish to make this information available to the client, the status code 403 (Forbidden) can be used instead. The 410 (Gone) status code SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding address.


      I added several DAD’s to /opt/oracle/product/Middleware/asinst_1/config/OHS/ohs1/mod_plsql/dads.conf like this:

      <Location /pls/jd-download-dev>
      SetHandler pls_handler
      Order allow,deny
      Allow from All
      AllowOverride None
      PlsqlDatabaseUsername w_web_user_download
      PlsqlDatabasePassword @BWKChfgPacV6yQL40lIKZqXUUA9wC4cmAw==
      PlsqlDatabaseConnectString jddev TNSFormat
      PlsqlNLSLanguage German_Germany.WE8ISO8859P1
      PlsqlAuthenticationMode Basic
      PlsqlDefaultPage w_anwendung.p_web_show_document
      PlsqlAlwaysDescribeProcedure Off
      PlsqlErrorStyle DebugStyle
      </Location>


      The passwords were obfuscated with dadTool.pl and the http-Server restarted with /opt/oracle/product/Middleware/asinst_1/bin/opmnctl restartproc process-type=OHS

      The files /opt/oracle/product/Middleware/asinst_1/config/OHS/ohs1/mod_plsql.cache.conf and /opt/oracle/product/Middleware/asinst_1/config/OHS/ohs1/moduleconf.plsql.conf were left unchanged.

      Our Test-Application generates the following link

      'http://172.106.2.7:9001/pls/jddevdev/B_ARCHIVE.P_ARCHIVE_VIEW?docfid=200'

      that seems to be ok, because when i replace IP and port with our old IAS it works fine, but the WebLogic Server generates the above mentioned error.

      To get some more information i searched an error_log in /opt/oracle/product/Middleware/asinst_1/diagnostics/logs/OHS/ohs1 but there isn’t any.

      I used the following Documentation for configuring the DADs which is for HTTP Server 11g Release 1 (version 11.1.1), because I could not find one for version 10.3.6.0:

      http://docs.oracle.com/cd/E23943_01/web.1111/e10144/under_mods.htm#i1055269

      So probably there are differences between configuring version 10.3.6.0 and version 11.1.1 and so something is wrong configured or missing...

      Thank you in advance for your help
      Udo