2 Replies Latest reply: Oct 19, 2012 11:45 AM by Al Hoenes-Oracle RSS

    Help Using "emctl jmxcli" Command

    Al Hoenes-Oracle
      I am new to EM and am working on learning how to create plugins. Someone installed EM 12C for me and then I installed the EDK and emcli. I was able to get the EDK's demo HostSample plugin which uses OSLineToken fetchlet to deploy and work. I then wrote a simple plugin which uses the SQL fetchlet. That worked as well. I am now trying to write a plugin which monitors a JMX application deployed on an Oracle WebLogic application server. In the Cloud Control Extensibility Programmer’s Reference PDF it says to use the "emctl jmxcli" command. However, when I try to run that command it just returns the syntax of the command. It doesn't seem to recognize "jmxcli" as an option. When I run "emctl getversion" this is the result:

      Oracle Enterprise Manager 11g Database Control Release
      Copyright (c) 1996, 2011 Oracle Corporation. All rights reserved.
      Enterprise Manager 11g DB Control Version
      Enterprise Manager 10g Agent Version

      I think I have the correct version of everything installed. Am I doing something wrong? Any help would be greatly appreciated.