13 Replies Latest reply on Oct 24, 2012 11:42 PM by Gary Graham-Oracle

    SQL Developer wont open

      Hi there,

      downloaded sql developer v3.0.04 as that is the version I use on my uni campus. I have windows 7 professional 64 bit by the way. Downloaded the right version of jdk (1.6.37) after it didnt like the newer jdk. now i unzipped the download into an empty directory using winzip, with filepaths intact but it wont open! I am opening the file located at ...SqlDEveloper > SqlDEveloper > bin > SqlDEveloper.exe , not the one in the top level folder.

      All I get is the black command window with one line:

      _execv() failed, err=2Registered TimesTen

      Hoping someone can help so I dont have to solely use it on campus :)


      Edited by: 966404 on Oct 18, 2012 5:12 PM
        • 1. Re: SQL Developer wont open
          Gary Graham-Oracle
          Hi Dan,

          You might want to try downloading the 32-bit version that includes JDK1.6.0_11, then unzip it into an empty directory. That is the most basic configuration, and using it avoids many of the common "getting started" problems.

          If you really want to specify which JDK to use, or whether to use 64-bit or 32-bit, keep these rules in mind (perhaps you are already aware of them, but just in case):

          1. On a 64-bit OS, you may use either the 32-bit or 64-bit SQL Developer releases.
          2. If you choose 32-bit, then your JDK must be 32-bit; 64-bit requires a 64-bit JDK.
          3. A 32-bit JDK will install into C:\Program Files (x86)\Java; 64-bit into C:\Program Files\Java
          4. Use the SetJavaHome line in your sqldeveloper.conf file to point to the desired JDK.
          5. When updating sqldeveloper.conf always specify a JDK, not a JRE.

          Hope this helps,
          • 2. Re: SQL Developer wont open
            Jim Smith
            I think there is something else going on here because this line
            966404 wrote:
            _execv() failed, err=2Registered TimesTen

            indicates that it has found a jdk and has actually started. The "execv failed" seems to be normal for 64 bit SQL Developer. "Registered TimesTen" shows that something is going on...

            Try enabling debug

            1. Change the following at the end of your ...\sqldeveloper\sqldeveloper\bin\sqldeveloper.conf file
            IncludeConfFile sqldeveloper-nondebug.conf
            should be changed to...
            IncludeConfFile sqldeveloper-debug.conf
            • 3. Re: SQL Developer wont open
              Thanks guys, I think I will try downloading the 32 bit first and if i still have problems i'll try to debug.

              Also does it matter where I install it to?since I have a small ssd drive with windows on it and I tend to stick everything else on a storage drive.

              • 4. Re: SQL Developer wont open
                Ok so I dl the 32-bit version and the black console opens empty which I assume is better than the errors i was getting...BUT the sql developer window seems frozen - I cant click on anything or use it in anyway. Any ideas why this would be?

                • 5. Re: SQL Developer wont open
                  Jim Smith
                  Could be you can't write to your home directory, or possibly the install directory.

                  If SQL Developer is hung, it might be worth posting a thread dump for opne of the development team to look at.

                  Goto the console window and click on the top left corner and select Properties...
                  In Layout, set the Screen buffer height to 3000 and click on OK.
                  Still with the focus on the console window, hit Ctrl-Break. A thread dump should appear.

                  Copy and past the thread dump into a posting here.
                  • 6. Re: SQL Developer wont open
                    Ok so I tried the debug option and it gave me a few lines inside the developer window which I couldnt scroll through as it is still frozen, and in the black console window it just says Registered TimesTen

                    I also tried the CTRL_BREAK but it doesn't do a thing...nothing whatsoever :-s
                    • 7. Re: SQL Developer wont open
                      Jim Smith
                      Ctrl-Break in the command window?
                      • 8. Re: SQL Developer wont open
                        Gary Graham-Oracle

                        And if you did do the Ctrl-Break from the context of the command line window, it begins to make me wonder if you can successful run any large memory footprint Java application on your system. Have you tried something like OpenOffice? Perhaps your system has very little RAM? More details about your system might shed some light.

                        • 9. Re: SQL Developer wont open
                          Yes I was in the console window when attempting CTRL-BREAK but nothing would happen.

                          My system runs openoffice fine, a tad slow compared to other programs but I assume that is down to the program not the computer.

                          My system specs are:

                          (Built by myself in April/June this year)

                          Intel Core I5 2500k & stock cooler (not oc'd)
                          compatible mobo with 8g of compatible ram

                          1 60GB ssd with windows 7 proffessional 64-bit installed
                          1 Storage drive where I tend to keep everything (including program files)

                          Assuming you dont need any other specs like which case I opted for haha! but on a serious note I would think the system can handle the program with ease, or is the fact its homebuilt an issue at all? I have not had a single problem with it so far in case you were wondering.

                          Ta in advance, Dan
                          • 10. Re: SQL Developer wont open
                            Gary Graham-Oracle

                            Since you built it yourself and it otherwise works fine with Java apps, I suppose the next step is to suspect an issue with the video driver, so either...
                            1. See if a newer version of the driver is available.
                            2. See if the advice on the sun.java2 settings in the following link may be applicable in your case.

                            Re: Lockup on table refresh

                            If both of those ideas are off-the-mark, I hope Jim has something more to add -- I'm running out of ideas.

                            • 11. Re: SQL Developer wont open
                              Jim Smith
                              I'm pretty much out of ideas.

                              You could try using jstack to produce a thread dump.

                              Find the process id of sqldeveloper.exe
                              In another command window type
                              jstack -l process_id
                              You can also use jps.exe to list running java processes.

                              Both are in the bin directory of jdk
                              • 12. Re: SQL Developer wont open
                                Gary, I have updated my graphics driver but no luck there.

                                Jim, tried the Jstack bit in my jdk folder i have a jre folder with a bin folder, is that the one you meant? the only other subfolder in /jdk was lib.

                                Anyway trying it in /jdk/jre/bin resulted in: 'jstack' is not recognized as an internal or external command, operable program or batch file... presumably because it isnt there?

                                Im starting to think I should just use this program on campus!

                                • 13. Re: SQL Developer wont open
                                  Gary Graham-Oracle

                                  If you decide to give up on a direct installation, but still have the time, energy, and disk space, you can always try running a VM that includes SQL Developer under Virtual Box.

                                  For example...
                                  Oracle VM Virtual Box: http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html
                                  DBDev App VM Image: http://www.oracle.com/technetwork/community/developer-vm/index.html

                                  That VM is Linux and has a more recent SQL Developer release installed than you might want. Sorry to hear this has not gone smoothly for you. The regular 32-bit SQL Developer download with JDK really does work for most user in just 5 minutes.