This discussion is archived
1 2 Previous Next 22 Replies Latest reply: Nov 3, 2012 12:06 PM by 969994 RSS

Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare

969994 Newbie
Currently Being Moderated
I recently downloaded and installed Oracle Enterprise Linux 6.3 UEK under VMWare. Networking locally appears fine and I can ping oracle.com and google.com with no problem. nslookup works fine as well. I cannot, however, connect to 'public-yum.oracle.com' in order to get yum updates.

I then opened up a command prompt under Windows and tried to connect outside of VMWare to see if that worked. It did not. I can also ping oracle.com but not public-yum.oracle.com. It says "request timed out". Pinging and nslookkup shows the IP Address to be 141.146.44.34, yet even pinging that IP address gets a timeout error.

If I use Internet Explorer and type in http://141.146.44.34 it goes to the proper webpages.

Any ideas on what I need to do in order to get my command prompt and VMWare to work so I can get updates from public-yum.oracle.com??

I'm sure it's something simple but checking googe searches and this forum has not been successful after many hours of searching.
  • 1. Re: Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare
    Dude! Guru
    Currently Being Moderated
    Have you configured yum accordingly?

    1. Remove any 3rd party or obsolete repository configuration files (wget does not replace files):
    cd /etc/yum.repos.d
    mkdir old
    mv *.repo old

    2. Get a new copy of the repo conf file:
    cd /etc/yum.repos.d
    wget http://public-yum.oracle.com/public-yum-ol6.repo

    3. Check your repo:
    yum repolist

    Does the above work. If not, please post the output including your commands.
  • 2. Re: Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare
    969994 Newbie
    Currently Being Moderated
    I found that webpage and here are two problems:

    1. there is no "wget" anywhere. Not even sure what that is.
    2. cannot even get to the repo site due to the time out of getting to the oracle public yum website.

    I can worry abou the rest later, but right now I just need to be able to figure out a way to be able to:

    ping public-yum.oracle.com

    Without that not much I can do.

    I'm wondering if I need to configure some firewall setting to allow this.

    Again, even ping using command prompt from Windows does not work on any of my systems, but IE does work.

    That's my real problem....actually getting to the website from a command prompt (terminal window).
  • 3. Re: Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare
    969994 Newbie
    Currently Being Moderated
    NOT WORKING:

    C:\Users\Craig>ping public-yum.oracle.com

    Pinging bigip-public-yum.oracle.com [141.146.44.34] with 32 bytes of data:
    Request timed out.

    Ping statistics for 141.146.44.34:
    Packets: Sent = 1, Received = 0, Lost = 1 (100% loss)

    ---------------------------
    WORKS:

    C:\Users\Craig>ping oracle.com

    Pinging oracle.com [137.254.16.101] with 32 bytes of data:
    Reply from 137.254.16.101: bytes=32 time=43ms TTL=252
    Reply from 137.254.16.101: bytes=32 time=45ms TTL=252
    Reply from 137.254.16.101: bytes=32 time=44ms TTL=252

    Ping statistics for 137.254.16.101:
    Packets: Sent = 3, Received = 3, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 43ms, Maximum = 45ms, Average = 44ms


    --------------------------


    C:\Users\Craig>nslookup oracle.com
    Server: Wireless_Broadband_Router.home
    Address: 192.168.1.1

    Non-authoritative answer:
    Name: oracle.com
    Address: 137.254.16.101


    C:\Users\Craig>nslookup public-yum.oracle.com
    Server: Wireless_Broadband_Router.home
    Address: 192.168.1.1

    Non-authoritative answer:
    Name: bigip-public-yum.oracle.com
    Address: 141.146.44.34
    Aliases: public-yum.oracle.com



    ----------------


    find / -name "*wget*" -print


    results in no files found


    --------------------
  • 4. Re: Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare
    Avi Miller Guru
    Currently Being Moderated
    966991 wrote:
    I then opened up a command prompt under Windows and tried to connect outside of VMWare to see if that worked. It did not. I can also ping oracle.com but not public-yum.oracle.com.
    public-yum.oracle.com does not respond to pings. You need to use a web browser, wget or CURL to connect.
  • 5. Re: Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare
    969994 Newbie
    Currently Being Moderated
    OK, after verifying my public yum.repo file is the same as on the website and changing the UEK section to set "enable-1", I try typing "yum list" and get a timeout error.

    Am I suppose to set my firewall to allow FTP port 20,21 or Yum port of 3128 on my windows host system?

    I turned of all SELINUX security.

    I'm sure I'm still missing something basic and still cannot figure out why I cannot find "wget" anywhere on my system.
  • 6. Re: Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare
    Avi Miller Guru
    Currently Being Moderated
    966991 wrote:
    Am I suppose to set my firewall to allow FTP port 20,21 or Yum port of 3128 on my windows host system?
    No, yum uses HTTP (80).
    I turned of all SELINUX security.
    Yum works fine with SElinux enabled.

    Can you get to http://public-yum.oracle.com from your Windows desktop? If so, there is something wrong with the networking inside your VMware guest. Can you ping anything from inside the Oracle Linux guest?
  • 7. Re: Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare
    969994 Newbie
    Currently Being Moderated
    Yes, I can get to the website using URL on IE within Windows.

    Yes, I can ping "oracle.com" and "google.com" from within Oracel EL within VMWare.
  • 8. Re: Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare
    Avi Miller Guru
    Currently Being Moderated
    So what happens if you do this:
     # yum repolist 
    # yum list updates
  • 9. Re: Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare
    969994 Newbie
    Currently Being Moderated
    That's when I get my timeout error and says it's checking the mirror site.

    If I had it working I could cut and paste the error.

    I may just try to figure out how to create a repo dir from my Linux DVD and use that.

    It's a brand new install so cannot figure out what is giong wrong. Again it's weird how I cannot find "wget" anywhere, but checking the website my .repo file looks just like on the Oracle web site address given in the "wget" command line.
  • 10. Re: Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare
    Avi Miller Guru
    Currently Being Moderated
    966991 wrote:
    If I had it working I could cut and paste the error.
    You should be able to take a screenshot and put that online somewhere?
    It's a brand new install so cannot figure out what is giong wrong. Again it's weird how I cannot find "wget" anywhere, but checking the website my .repo file looks just like on the Oracle web site address given in the "wget" command line.
    If you did a minimal install, wget is not installed by default. It's only installed with a Basic Server install (or greater).
  • 11. Re: Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare
    969994 Newbie
    Currently Being Moderated
    I'm grabbing at straws now, but could it have anything to do with me installing a 32-bit EL onto my 64-bit machine? Is somehow the public-yum webstie getting confused? It looks like it's going to the "i386" webpage like it should.
  • 12. Re: Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare
    Avi Miller Guru
    Currently Being Moderated
    966991 wrote:
    I'm grabbing at straws now, but could it have anything to do with me installing a 32-bit EL onto my 64-bit machine?
    Nope. It's more to do with not being able to connect via HTTP to public-yum.oracle.com for some reason.
  • 13. Re: Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare
    969994 Newbie
    Currently Being Moderated
    I'd love to know how to get various options for installing OEL 6.3. It only seems like I have a few options when I load the disc so I choose the top one (install or upgrade) and then unlike previous versions 5.x and below, their doesn't seem to be any way for me to select GUI installation nor optional packages to install.

    If it did, I wouldn't be worried about using YUM in the first place.

    I just want a GUI desktop (GNOME) when I boot.

    Any thoughts on how to create a GUI install, install with desktop or optional packages that can be added during initial install would be very helpful and then I can forget about getting yum to work.
  • 14. Re: Help resolving public-yum.oracle.com with OEL 6.3 UEK from VMWare
    Avi Miller Guru
    Currently Being Moderated
    966991 wrote:
    I'd love to know how to get various options for installing OEL 6.3. It only seems like I have a few options when I load the disc so I choose the top one (install or upgrade) and then unlike previous versions 5.x and below, their doesn't seem to be any way for me to select GUI installation nor optional packages to install.
    You can customise the install of OL6 during the graphical part of the installation. After you configure your disk layout, you are prompted with the software set selection. The default is "Basic Server", but you can change that to Desktop or Software Development Workstation. Both of those will install the GUI for you. None of the Server options install a GUI.
1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points