This discussion is archived
4 Replies Latest reply: Oct 24, 2012 4:49 AM by 21844 RSS

Oracle SQL Developer issue when using VPN (Cisco)

21844 Newbie
Currently Being Moderated
All,

We've got a somewhat obscure issue with SQL Developer connectivity to our databases from a remote employee's laptop.

The database is hosted inside our firewall and when the employee tries to connect to the database he receives the following error:
+"Error Encountered: An error was encountered performing the requested operation: The network adaptor could not establish the connection. Vendor Code 20"+

I believe I may have seen the following error at one point as well...
Status : Failure -Test failed: IO Error: The Network Adapter could not establish the connection

Note: He gets this error when logged into our VPN & while he can connect via SQL*Plus to that same database. He gets the error regardless if he uses the tnsnames entry option in SQL Developer or if he is using the "Basic" connection type.

What's interesting is that if he disconnects from the VPN, turns off his wireless connectivity and then hard-wires into our network he can connect, no issue.

The strangest part for me is that while he can not connect to the database via SQL Developer, he can connect via SQL*Plus. He can ping the source IP address fine, he can tnsping the database no problem, he can connect via SQL*Plus, he just can't connect via SQL*Developer. Since SQL*Plus and tnsping are working, I know he can access the db server via port 1521, so I don't think it's a port issue.

Another strange thing: When he connects to our network via an "old" VPN (open VPN) he has no issues.

His machine is Windoz 64 bit (HP laptop) and he's using the latest version of SQL Developer and a newer JVM.

Also interesting: I also have a Windoz 64 bit laptop (Lenovo) and I do not have the same issues as he does. I however am running an older version of SQL Developer and probably an older JVM.

I dug around a bit, seems like perhaps this has something to do with IPv6? No idea what to do next except have my network guy look at firewall logs to try to capture where the connectivity is being dropped.

Any thoughts or suggestions would be appreciated. I've tried all kinds of things (giving him my tnsnames.ora and sqlnet.ora file, manually editing those files, tried IP addresses instead of host names, tried host names with the .doman.org extensions, etc.).

Again, any suggestions would be appreciated and thank you very much.

Rich

Edited by: rmurnane on Oct 23, 2012 10:58 AM

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points