This discussion is archived
4 Replies Latest reply: Oct 25, 2012 11:30 AM by 141436 RSS

SQL Developer Cart Deployment Losing Time on Date Columns

141436 Newbie
Currently Being Moderated
I tried using the SQL Developer cart feature to migrate from AWS to Oracle Cloud and I found that the time element of any date attributes is not migrated. I checked the deployment file contents and found that both the SQL*Loader control file and the data file (ldr) do not account for any time information in a date table attribute.

Any one run into this issue and know how to get SQL Developer to pick up the time when it pulls date attribute values?
  • 1. Re: SQL Developer Cart Deployment Losing Time on Date Columns
    Gary Graham Expert
    Currently Being Moderated
    Hi,

    There is no special preference controlling the date format in Database | Utilities | Cart, so the behavior either must be automatic or dependent on the NLS setting.

    You might check if Tools | Preferences | Database | NLS | Date Format already contains a time format component. If the Cart deploy of dates does not work even with the correct NLS format, then this may need to be bugged. Perhaps an improvement has already been made for the next release. Please let us know. I will ping the developer on this.

    Regards,
    Gary
    SQL Developer Team
  • 2. Re: SQL Developer Cart Deployment Losing Time on Date Columns
    Irian Pro
    Currently Being Moderated
    Maybe it has nothing to do with your issue, but since you are having problems with the time part of date objects you could try to change the
    AddVMOption -Doracle.jdbc.mapDateToTimestamp=false
    from false to true in
    [SQLDev install dir]/sqldeveloper/bin/sqldeveloper.conf
    If this actually works then probably there really is a little glitch to be fixed in the Cart.
  • 3. Re: SQL Developer Cart Deployment Losing Time on Date Columns
    JoyceScapicchio Journeyer
    Currently Being Moderated
    Gary and Irian both have good suggestions to identifying your problem.

    I believe when you install SQL Developer, the NLS setting for DATE does not include time portion. Select tools-preferences->NLS. When I set the DATE format, in my case to DD-MON-RR HH.MI.SS, the date field with the time portion is deployed to the cloud as expected. When I set the mask to just DD-MON-RR , the time portion is all 0. This is the correct behavior.

    SQLDeveloper Team
    Joyce Scapicchio
  • 4. Re: SQL Developer Cart Deployment Losing Time on Date Columns
    141436 Newbie
    Currently Being Moderated
    Thank you all who responded. Once I changed the NLS Date Format to include the time elements (HH:MI:SS) the export data included the time for all date attributes and was deployed with this information intact.

    Thanks again,
    Jason

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points