3 Replies Latest reply: Oct 29, 2012 11:48 AM by TheNewBee RSS

    Custum template for content presenter.

      Hi All,

      I am facing an error while using my custum template which i have created for single content
      I am creating a portal resourse of it and giving the view id (viewid123) in template view of my content presenter at design time in bindings parameter. when i am runing the project i am getting following message and my CDF is displayed as .xml file (content presenter is not using my template and using default template)

      _<TemplateRegistry> <getListTemplateViewId()> No default template view specified for category id 'null'. Returning the default view for the default category._

      my content presenters binding paramenter are as

      taskFlowInstId     ${'57d1a6be-6ce4-4f8a-8a60-7dd6d50129b3'}

      datasourceType     ${'dsTypeQueryExpression'}

      datasource     ${'SELECT * FROM ora:t:IDC:GlobalProfile WHERE ora:p:xRegionDefinition=\'RD_BC_LANDING\' AND ora:p:xLanguage=\'Spanish\''}

      templateCategory     ${''}

      templateView     ${'viewid123'}

      regionTemplate     ${false}

      maxResults     ${''}
        • 1. Re: Custum template for content presenter.
          Yannick Ongena
          That is probably caused because you defined the template as the default view.

          Right click on your CP Template and select Update portal resource
          Make sure the set the Content Type Default View to false. If that's already the case then it must be something else...
          • 2. Re: Custum template for content presenter.
            Hi Yannick

            Thanks for your reply.We tried this and its working fine for one of my colleague but not for me :(
            I not able to understand what can be the possible cause. Though i can again create this part, but I want to understand the possible cause can you u provide some link so that i can understand how custom template works.

            I refered this link till date for creating custom templates

            http://docs.oracle.com/cd/E21764_01/webcenter.1111/e10148/jpsdg_content_presenter.htm , and your and ATEAMS blog

            and also same thing happens for region templates.
            every thing work fine when i do it at run time but i want to do this at design time (as requirement says).

            Thanks again for your valuable reply.
            • 3. Re: Custum template for content presenter.
              Got the problem i was not setting escape ="false".
              but there i another problem i am facing please let me now your point of view on this
              when i am inserting a video using Insert flash in WYSIWYG element. and accessing trying to access it as follow

              <af:outputText value="#{node.propertyMap['5RD:e1'].asTextHtml}"
              id="ot4" escape="false"
              inlineStyle="font-size:14px; font-weight:bold;"/>

              its ocuppying the space on portal page but no video is rendered when i see the view source its like:

              <p><embed menu="true" loop="true" play="true" type="application/x-shockwave-flash" src="" width="500" height="200"></embed></p>

              what i need to do to make it work.
              do i need to embed to video player than give the the src.
              please help me in this.

              Edited by: TheNewBee on Oct 29, 2012 9:48 AM