This discussion is archived
1 Reply Latest reply: Oct 29, 2012 1:20 PM by DavidGreenfield RSS

Privileges

user798043 Newbie
Currently Being Moderated
Hello,

fresh install of OLAP at customer's site. When trying to create a cube in AWM, we get CREATE privilege missing. The user we have created tje AW with, has OLAP_USER rights and was also granted "create dimension" as well as "create cube dimension". Yet, only upon granting OLAP-DBA, does the error message go away. Since the user is working solely in his own schema, that error doesn't make much sense to us.

Any help appreciated.
  • 1. Re: Privileges
    DavidGreenfield Expert
    Currently Being Moderated
    Which version of AWM and the database are you using? Is the error coming from AWM or the database? You could try creating a dimension and cube using the DBMS_CUBE.IMPORT_XML procedure in PL/SQL to see if that works.
    begin 
    dbms_cube.import_xml(q'!
    <Metadata Version="1.1">
      <StandardDimension Name="TEST_DIM">
        <Organization>
          <AWPrimaryDimensionOrganization>
            <AW Name="TEST_AW"/>
          </AWPrimaryDimensionOrganization>
        </Organization>
      </StandardDimension>
      <Cube Name="TEST_CUBE">
        <Dimensionality Name = "TEST_DIM">
          <Dimension Name = "TEST_DIM"/>
        </Dimensionality>
        <Organization>
          <AWCubeOrganization>
            <AW Name="TEST_AW"/>
          </AWCubeOrganization>
        </Organization>
      </Cube>
      <AW Name="TEST_AW"/>
    </Metadata>
    !');
    end;
    /
    Run this directly as the user with the OLAP_USER role. If it doesn't work, then paste the error message here.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points