10 Replies Latest reply: Oct 31, 2012 3:37 AM by Nicolas.Gasparotto RSS

    java.lang.UnsupportedClassVersionError when loading IB gateway connectors

      Going from one problem to the other.. PeopleTools 8.52 installation on OEL5. Everything is running; Database, Application server, process scheduler etc. However when I try to load the Integration broker gateway connectors I get the following error:

      java.lang.UnsupportedClassVersionError: Bad version number in .class file

      8.52 came with JRE 1.6.0 installed in the PS_HOME directory. $JAVA_HOME is pointing here and $JAVA_HOME is one of the first variables in my $LD_LIBRARY_PATH. I've created a new domain after setting this correctly, because initially the JRE in the Tuxedo directory came before the one in PS_HOME. I've modified this in the tux.env as well; everything seems to be pointing to the JRE in the PS_HOME now. I'm still getting this error however and it seems I'm missing something. Does anyone have a clue? When running "which java" I get the correct path and "java -version" specifies the correct version. I've tried several of the solutions posted on Oracle support, but to no avail. The latest certified version of Java is build 1.6.0_23-b05, but I'm unable to find a download location for that. I doubt it is necessary to update the JRE since it's already running on 1.6.0.