4 Replies Latest reply on Mar 7, 2013 9:48 PM by 744772

    Error After Upgrade APEX 4.2 - Ora-01403


      I installed APEX 4.2 over XE 11.2
      The Installationprocess succeeded.

      1-Install Oracle Database Express Edition 11g (APEX 4.0 work fine and publicate Apex Application Sample correctly)
      2-Download APEX 4.2
      3-Run @apexins.sql USERS USERS TEMP /i/
      4-Run @apxchpwd.sql
      5-Run @apex_epg_config.sql C:\Temp
      6-Run @apxldimg.sql C:\Temp
      8-Unlock Account Anonymous User

      Temp is the directory where unzip apex_4.2.zip file

      After this, when i try to enter
      The error is
      "Error     Error processing request.
      ORA-01403: no data found

      And is imposible to publicate the Apex Application Sample

      Any Ideas ??

        • 1. Re: Error After Upgrade APEX 4.2 - Ora-01403
          Bas de Klerk

          page has changed in 4.2
          Try :

          You can also try to reset the default page with :
          -- Set default application
          sys.dbms_epg.set_dad_attribute(dad_name => 'APEX',
          attr_name => 'default-page',
          attr_value => 'f?p=4550'); 
          after this should redirect to the correct page
          • 2. Re: Error After Upgrade APEX 4.2 - Ora-01403
            Bas de Klerk Thanks fow answer.
            Its correct, the apex work fine in this direction
            But i still can't public the application sample in Internet. (http://japex.sytes.net:8080/apex/f?p=100)
            Befor upgrade the version, work fine with APEX 4.0 version.
            Remember i not user Oracle HTTP server, only have Oracle Database Express Edition.
            • 3. Re: Error After Upgrade APEX 4.2 - Ora-01403
              Hilary Farrell-Oracle
              Hi user4783187,

              If you are using the Embedded PL/SQL Gateway (EPG), have you executed
              exec dbms_xdb.setListenerLocalAccess (l_access => FALSE);
              for your instance? For further information on the SETLISTENERLOCALACCESS procedure, you can refer to the DBMS_XDB package documentation here: http://docs.oracle.com/cd/B28359_01/appdev.111/b28419/d_xdb.htm.

              • 4. Re: Error After Upgrade APEX 4.2 - Ora-01403
                I am using OHS HTTP server with mod_plsql to connect to 11g on a sep. AIX 6.1 DB server. and getting the same error. I tried your procedure, it executed fine, but I'm still getting the error.

                I just upgraded to 4.2 from 3.2.

                I didn't reset my pw or anything, as the instructions said only to do that for a new install. All I did post install was copy the new Images to the correct directory.

                This is the connect string I was using before, modified to 4550, as per your instructions.


                I also removed the last bit up to /apex, I get the same error.