3 Replies Latest reply on Nov 1, 2012 1:07 AM by Gary Graham-Oracle

    Trace Session in SQL Developer throws error

      Hi Everyone,

      I'm running into an error when I try to use the TRACE SESSION option when using MONITOR SESSIONS in SQL Developer.

      Some details:
      SQL Developer Version 64-Bit on Windows 7 64-Bit
      Java: 1.6.0_17
      Oracle IDE:
      Versioning Support
      connected to Oracle 64-Bit on SUSE Linux Enterprise Server 10 64-Bit

      I navigate to Tools > Monitor Sessions and then right click on a session and select TRACE SESSION. Clicking APPLY results in a TRACE SESSION SUCCEEDED message to which I click OK. This then creates three entries in the Logging Page pane all at level SEVERE and all containing the same source and message as follows:

      SOURCE: oracle.dbtools.raptor.controls.sqldialog.ObjectActionController$EditorObjectActionListener
      MESSAGE: null at oracle.dbtools.raptor.controls.sqldialog.ObjectActionController$EditorObjectActionListener$Filter$1.accept(ObjectActionController.java:689)

      I guess I'm missing something in my setup but am not sure what that might be. Any ideas?
        • 1. Re: Trace Session in SQL Developer throws error
          Gary Graham-Oracle
          Hi Martin,

          The error you see is definitely unexpected -- that spot in the code controls refreshing the content of any editors that could be affected by the SQL that just got processed. In the case of TRACE SESSION, I don't think any editors should be affected since the result is to begin writing to a trc file on the server.

          If I put a break-point at that line in the Java class and run the debugger, the debugger never even reaches that code for the scenario you describe (Monitor Sessions [select a SYSDBA connection], then Trace Session [select an ordinary user like SCOTT]).

          Knowing what other editors you had open within SQL Developer may help. Or maybe some other SQL was running simultaneously, completing around the same point in time. Not really sure what more to suggest...

          SQL Developer Team
          • 2. Re: Trace Session in SQL Developer throws error
            Hi Gary,

            Thanks for getting back to me.

            I've tried running the trace session again without any other editor open and I still get the error thrown only this time the error only appears once in the Logging Page pane whereas before it appeared three times. If I open a SQL editor and try the trace the error appears twice, opening another SQL editor makes the error appear three times and so on. So, running the trace generates an error, and an additional copy of the error appears for each open editor.

            Not sure if this gives you any clues?

            • 3. Re: Trace Session in SQL Developer throws error
              Gary Graham-Oracle

              Apparently even though the error level is marked as SEVERE, in this case there really is no harm. If you look at your sqldeveloper.conf file, toward the bottom, you will see either
              IncludeConfFile  sqldeveloper-nondebug.conf
              IncludeConfFile  sqldeveloper-debug.conf
              The debug version contains
              AddVMOption  -Dsqldev.debug=true
              AddVMOption  -ea
              which enables debug logging and Java assert processing. The assert actually blocks processing of the code you see the error in. Since developers typically run the debug version, we never see that message logged. The non-debug version contains
              AddVMOption -Dide.AssertTracingDisabled=true
              So you should either ignore the error, or try to edit your conf files to suppress it. Possibly a bug should be logged, but the condition is benign.