4 Replies Latest reply: Nov 11, 2012 7:50 PM by user10496349 RSS

    Registered portlet but unable to place

    user10496349
      Hi All,

      I am using Oracle Portal 10.1.2.3.0 and have deployed a portlet application using JDeveloper, which says it succeeded.

      When I log in to the portal, click Edit on any page > Navigator > Providers tab > Registered Providers > Edit Registration on the portlet I previously deployed > Connection tab, I see the providers URL: http://someserver/publications-dev/providers, and I can access that URL and see the following output:

      Congratulations! You have successfully reached your Provider's Test Page.
      Recognizing Portlets...
      PublicationsNewsPortlet
      PublicationsNewsDetailPortlet
      PublicationsNewsDetailListPortlet
      PublicationsCareersPortlet
      PublicationsCareersDetailPortlet
      PublicationsCareersDetailListPortlet
      Recognizing component versions...
      ptlshare.jar version: 10.1.2.0.2
      pdkjava.jar version: 10.1.2.0.2

      Yet, when I try to add the portlet to a page, searching for the portlet name "Careers Widget Portlet" or "PublicationsCareersPortlet" reveals nothing. This is defined in the provider.xml:
      <name>PublicationsCareersPortlet</name>
      <title>Careers Widget Portlet</title>

      Can anyone give me a hint to what I might be missing? How can the Providers Test Paqe state that it recognizes the portlets but I cannot add them to a page?

      Kind Regards,

      Rob
      :)