This discussion is archived
5 Replies Latest reply: Nov 5, 2012 9:44 AM by alunwawa RSS

Fresh Install HCM 9.1 but Links not working. Help please

alunwawa Newbie
Currently Being Moderated
Dear All,

I'm trying to make a switch from SAP to PeopleSoft. I tought it easier to install PSFT since the number of source to install is much less than SAP. However, I kept getting same error where the links not working no matter which environment I tried to install.

I downloaded all software from eDelivery.
HCM 9.1, PTOOLS 8.52, Oracle 11g 64 bit, Oracle Client 32 bit.

First Try:
Install on windows 7 64bit. Everything works fine until first login to the PSFT and all links not working.
Suggestion from Hakan is to apply the patch and gave me a link to the old FTP site. I downloaded the 85209 patch but got password.
Finally I managed to get a customer ID from a friend and downloaded Patch 85211 and applied. But got java error so I scrapped it.
Anyway, Gasparotto said the environment is not certified and will not fix my problem with the patch.

Second Try:
Installed Virtual Box.
Installed Windows 2008 R2 and applied the SP1.
Installed everything all over again.
Ensured the PTWEBSERVER password similar the username.
Everything works fine but when login to PSFT, again..... links not working and see on the bottom left corner there are some javascript error where they cannot find certain peoplesoft objects..

Just upgraded to IE 9 because I read somewhere IE 8 is not certified.
Tried to login again, no error message and everything looks fine but... links not working.

Logs also looks normal to me.

Does anyone ever encountered similar issues before?
Does this is a normal behaviour before tools patch 85211 being applied ?

Thanks,
aLuNa

My APPSRV Log:
----------------------
PSSAMSRV.12 (0) [11/03/12 09:04:46](0) PeopleTools Release 8.52 (WinX86) starting. Tuxedo server is APPSRV(99)/100
PSSAMSRV.12 (0) [11/03/12 09:04:46](0) Cache Directory being used: C:\APPSRV_CONFIG\appserv\HCDMO\CACHE\PSSAMSRV_100\
PSSAMSRV.12 (0) [11/03/12 09:04:46](0) Server started
PSRENSRV.2808 [11/03/12 09:04:49](0) PeopleTools Release 8.52 (WinX86) starting. Tuxedo server is RENGRP(92)/101
PSRENSRV.2808 [11/03/12 09:04:49](3) Switching to new log file C:\APPSRV_CONFIG\appserv\HCDMO\LOGS\PSRENSRV_1103.LOG
PSADMIN.2124 (0) [11/03/12 09:04:52](0) End boot attempt on domain HCDMO
PSAPPSRV.1488 (3) [11/03/12 09:13:16 GetCertificate](3) Returning context. ID=PTWEBSERVER, Lang=ENG, UStreamId=091316_1488.3, Token=PSFT_HR/2012-11-03-02.13.17.193528/PTWEBSERVER/ENG/XxZ3vyJWXF/S1MoQtG2Wox6wGJA=
PSAPPSRV.1488 (5) [11/03/12 09:13:21 GetCertificate](3) Returning context. ID=PTWEBSERVER, Lang=ENG, UStreamId=091321_1488.5, Token=PSFT_HR/2012-11-03-02.13.22.193632/PTWEBSERVER/ENG/pS6ec6pIAJJSYc1oOWcNYiR0UFQ=
PSAPPSRV.1488 (7) [11/03/12 09:13:29 GetCertificate](3) Returning context. ID=PS, Lang=ENG, UStreamId=091329_1488.7, Token=PSFT_HR/2012-11-03-02.13.30.193285/PS/ENG/3GnOezS6D9PUlzwrjPwqexv4ir0=
PSAPPSRV.1488 (34) [11/03/12 09:18:47 GetCertificate](3) Returning context. ID=PS, Lang=ENG, UStreamId=091847_1488.34, Token=PSFT_HR/2012-11-03-02.18.48.194158/PS/ENG//oJB5tvSHYNzsmZ2Gs4g2vBLUVs=
  • 1. Re: Fresh Install HCM 9.1 but Links not working. Help please
    jim.marion Pro
    Currently Being Moderated
    The absolute best PeopleSoft install guides can be found on the right-hand side of Nicolas's blog at http://gasparotto.blogspot.com/. For VirtualBox, you can take a shortcut and deploy the PeopleSoft OVM images in VirtualBox by following the instructions here: http://jjmpsj.blogspot.com/2012/08/peoplesoft-ovm-virtualbox-conversion.html.
  • 2. Re: Fresh Install HCM 9.1 but Links not working. Help please
    alunwawa Newbie
    Currently Being Moderated
    Thanks Jim.
    I'm downloading the PSFT HCM 9.1 Template now.

    However, using the template is my last resort as I'm not familiar at all with Linux.

    again, my environment is:
    Windows 2008 R2 SP1 64-bit, RAM 4GB, using virtualBox.
    HCM 9.1 FP2, PTOOLS 8.52, Oracle 11g 64-bit, Oracle Client 32-bit

    Additional headache is, I cannot login to my application designer in 3-Tier Mode.
    the following is from my tuxlog:
    134346.HARTONO!JSL.2236.2024.0: JOLT_CAT:1592: "ERROR: Unrecognized message magic 6750259 "
    134602.HARTONO!JSL.2236.2024.0: JOLT_CAT:1592: "ERROR: Unrecognized message magic 6750259 "

    my configuration.properties file:
    psserver=HARTONO:9000
    joltPooling=true
    DomainConnectionPwd={V1.1}6O5vpwGxd5o=
    WebProfile=DEV

    any idea of the JOLT_CAT:1592 error?

    Thanks,
    aLuNa
  • 3. Re: Fresh Install HCM 9.1 but Links not working. Help please
    Nicolas.Gasparotto Oracle ACE
    Currently Being Moderated
    alunwawa wrote:
    ...
    Does anyone ever encountered similar issues before?
    Yes, I did already see the same, that was when installed the same with 8.52.00 (without Peopletools patch) or without applying the patch project...
    Does this is a normal behaviour before tools patch 85211 being applied ?
    Without patch, you have the error you mentioned. How many time I told that 8.52.03 min. is required, I did not go further, but there was some bugs before which make it not working.
    I understand that's rather frustrating for people who wants to jump to Peoplesoft. I don't know SAP, but here you go, Peoplesoft is not a simple toy.
    Unfortunately, if you have no access to My Oracle Support to get the Peoplesoft patches, you have no way but work on Peoplesoft OVM (free of use), and to use them on VirtualBox, the Jim's articles are worth to follow.

    Nicolas.

    PS: @Jim, thanks for the kind words.
    My last install guide is quite old now (PT8.50/Linux), even though it did not change very much within the last tools 8.52. But seeing the number of time such questions have asked over here (PT8.52 on Windows), I'm thinking to write one more, that time on Windows.
  • 4. Re: Fresh Install HCM 9.1 but Links not working. Help please
    Nicolas.Gasparotto Oracle ACE
    Currently Being Moderated
    alunwawa wrote:
    ...
    my configuration.properties file:
    psserver=HARTONO:9000
    joltPooling=true
    DomainConnectionPwd={V1.1}6O5vpwGxd5o=
    WebProfile=DEV
    AppDesigner 3tier mode does not care webprofile and webserver. It does not use at all.
    any idea of the JOLT_CAT:1592 error?
    I think you misunderstandoog the 3tier mode.
    The 3tier connection with AppDesigner is a direct connection to the Application server through the WSL port, not to the webserver or JSL port neither.
    So, first WSL must be activate and port configured on the appserverver.
    Second, your client should point to WSL port (7000 by default).

    You can find out more
    http://gasparotto.blogspot.nl/2010/03/peoplesoft-database-connectivity-part_28.html

    Nicolas.
  • 5. Re: Fresh Install HCM 9.1 but Links not working. Help please
    alunwawa Newbie
    Currently Being Moderated
    Managed to applied the Tools Patch 08.52.11 and the links is working now.
    I would recommend to listen to Nicolas from the first place when we tried to install psft.

    The 3-Tier is working now. I thought I had configured the WSL correctly. After reading the article from Nicolas, I double check the settings and to my surprise, the WSL is not configured yet.

    I did tried to configured my network adapter on virtualbox (NAT & host only) so I can connect to my PSFT from my host to my guest webserver.
    It was working fine but then after restart, it is not working anymore. solution is I cannot setup any network adapter for my virtualbox since I was not setting up any adapter when I first starting the install. In the meantime will work from my virtualbox guest to learn the psft and will try to figure out about how to make the psft still working once I setup the network adapter later on.

    So everything is working fine now. Finally the HCM 9.1 is working.

    Thanks for all the help.

    Regards,
    aLuNa

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points