6 Replies Latest reply on Nov 13, 2012 4:22 PM by Looney128 Branched to a new discussion.

    can not launch vnc console on newly installed manager (OVM 3.2.1)

      I have installed OVM manager 3.2 and have a VM set up and running. When I click on launch console....I get this error on my Windows 7 box...

      Failed to execute local configured vnc viewer due to
      java.io.IOException: Cannot run program "https://ovm:7002":CreateProcess error=2, The system cannot find the file specified

      I did install the tightvnc rpm package that was listed on Oracle's site along with the JTA package. To make sue everything was installed ok, I also installed TightVNC using yum. (I have since removed it as it was the tigervnc and not tight...)

      I have version 6 of java running on my workstation. I did notice the little oracle Ovm Ras Proxy up in the corner. I clicked on the option and noticed the configuration looking for the local install.
      So I browsed to the tightvnc installation. It now trys to launch VNC....but crashes.
      I then tried realvnc viewer. It did not crash, but it just shows a white screen.
      Tried ultravnc.....this did not connect either....but it look like it was trying to connect to 49825 So I tried to manually connect to the server and port....but no go.

      Any thoughts?

      Edited by: Looney128 on Nov 3, 2012 1:28 PM
        • 1. Re: can not launch vnc console on newly installed manager
          I tried many methods to solve it's problem: install on client PC(win7,XP)- RealVNC,tightvnc different versions; installed different versions JAVA 1.6 and 1.7 ; different versions browsers -firefox (3.6, 16), IE(6,7,9), Chrome .

          Installed on my manager server recommended for 3.2.1 verisiya tightvnc:

          "Known Limitations and Workarounds:

          The JRE that has been shown to work most consistently is Java SE6 Update 35. On some systems other
          versions of the JRE may function as well.

          Packages are available at Oracle's public yum server:
          • TightVNC (Oracle Linux 5): http://public-yum.oracle.com/repo/EnterpriseLinux/EL5/addons/x86_64/
          • TightVNC (Oracle Linux 6): http://public-yum.oracle.com/repo/OracleLinux/OL6/addons/x86_64/tightvnc-java-1.3.9-4.noarch.rpm
          • JTA (Oracle Linux 5): http://public-yum.oracle.com/repo/EnterpriseLinux/EL5/addons/x86_64/
          • JTA (Oracle Linux 6): http://public-yum.oracle.com/repo/OracleLinux/OL6/addons/x86_64/
          jta-2.6-1.noarch.rpm "

          it is NOT Help me!

          Then i am just reinstall Oracle VM and Oracle VM Server to version 3.1.1
          In this version Vm console work correctly. i am spend 3 days on this!

          Sorry for my English :)

          Edited by: 969097 on 02.11.2012 0:54
          • 2. Re: can not launch vnc console on newly installed manager
            I have seen others running 3.2.1 successfully......???????

            Maybe its the order on how things are installed.

            I installed OVM then vnc....... Did other do if differently? Why are others not having this problem?
            • 3. Re: can not launch vnc console on newly installed manager
              Yes, I do a lot of Oracle VM installation with the same problems?

              I start with Version 3.2.1 and I saw no console. Then I try a reinstallation in Version 3.1.1 with the last built and here
              I have the sam problem. I installed tight-vnc on the Vm Manager side as last step.

              From my Client a Mac Book with Safari or Firefox or Chrome and Java 1.7 I can't start the console.

              So I have the same problems and actually I think about reinstalling the whole environment but I lost more than 7 days. :-(

              Does somebody have a configuration which works well?

              - VM Server Version
              - VM Manager Version
              - Client
              - Mac , Windows 7, Linux
              - Safari, Firefox, Chrome, IE
              - Java Version
              - ???

              It would be very helpful for all who try to setup Oracle VM.

              • 4. Re: can not launch vnc console on newly installed manager
                For me, I had to remove Java7 from my win7 workstation (leaving java6) and then launching was fine. I suspect some security feature of java7 disabled the launch feature used my OVM.
                • 5. Re: can not launch vnc console on newly installed manager
                  Hi 969097,

                  I got the same problem but on Oracle VM 3.1.1.

                  My Oracle VM Manager installed on Oracle Linux 5, after completed installed and configured VM Manager and Server I start converted physical machine to virtual machine, then I created a new virtual machine with this VM template (converted machine).

                  After created a new virtual machine, I start virtual machine and status is completed 100% running, click lunch vnc console then type password, click OK button but not appears vnc console to view new machine. I don't know why?

                  I use java 1.6, Firefox 8.0, and I installed Tight-VNC package on Manager already

                  Please kindly give advice for this.
                  • 6. Re: can not launch vnc console on newly installed manager
                    I did a few things...but do not know which one solved the problem.

                    First, they updated the web site with a newer version of the beta (35901), so I started from scratch and installed this.

                    Second, I found that this beta prefers java 1.6_37. So I updated my java to this version.

                    Third, I found that 32bit installations of Windows 7 and XP with the updated java did not have a problem launching the console. My 64bit does....although I have not found another system to confirm this.

                    Fourth, the vnc console does not rely on a local version of the vnc client. 3.2.1 uses the java vnc, so I do not need to point it at my local install to use. Just clicking on the icon launches a java vnc session.......but like I said before, only on a 32bit system.

                    So if I started with just updating Java and using a 32bit system, I may not have needed to update to the latest build. I am having some issues with this new build and iSCSI, but thats a different story.....