This discussion is archived
6 Replies Latest reply: Feb 26, 2013 10:10 AM by foch RSS

WebLogic 11g: Weblogic-Application-Version not taken into account

foch Newbie
Currently Being Moderated
Hello,

I'm trying to set up Production Redeployment on my EAR, under WebLogic 10.3.6.
However, I can't figure out how to make Weblogic-Application-Version work in MANIFEST.MF

Here is my EAR structure:
MyApplication
--- APP-INF
--- --- lib
--- --- classes
--- META-INF
--- --- application.xml
--- --- weblogic-application.xml
--- --- MANIFEST.MF <- file I update
--- WebApp1
--- --- META-INF
--- --- --- MANIFEST.MF
--- --- WEB-INF
--- --- --- classes
--- --- --- lib
--- --- --- web.xml
--- --- --- weblogic.xml
--- WebApp2
--- --- same as WebApp1

MANIFEST.MF content is the following:
Manifest-Version: 1.0
Weblogic-Application-Version: VERSION_1

-----

The problem is that it's not taken into account when I deploy the application in the WebLogic console.
When I use staged mode, the line Weblogic-Application-Version: VERSION_1 is removed from the staged MANIFEST.MF file.
The only way to manage to version my application is to add the flag -appversion to weblogic.Deployer, but I don't want to use that on a Production environment (and it's not recommended in the documentation!).

Any idea why Weblogic-Application-Version not taken into account? I tried to add debug mode to node weblogic/debug but with no success.

Thanks by advance,
Julien

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points