14 Replies Latest reply: Nov 14, 2012 5:53 AM by 548396 RSS

    Setting Up a WebLogic Server Instance as a Windows Service in services.msc

    548396
      Hi All,

      Currently we are using OIM/OAM 11g in Windows environment .I got one requirement Setting Up a WebLogic Server Instance as a Windows Service in services.msc .

      Could any one pls.. explain me how to achive this....

      Regards,
      Ravi.
        • 1. Re: Setting Up a WebLogic Server Instance as a Windows Service in services.msc
          sandeep_singh
          please check this link:

          http://docs.oracle.com/cd/E17904_01/web.1111/e13708/winservice.htm#i1188175

          There is a metalink document also available :
          How to Install MS Windows Services For FMW 11g WebLogic Domain Admin and Managed Servers? (Doc ID 1060058.1)

          Thanks,
          Sandeep
          • 3. Re: Setting Up a WebLogic Server Instance as a Windows Service in services.msc
            548396
            Hi ,

            I got the following error after execute the script.

            Script is ::
            SETLOCAL
            set DOMAIN_NAME=base_domain
            set USERDOMAIN_HOME=C:\Oracle\Middleware\user_projects\domains\base_domain
            set SERVER_NAME=AdminServer
            SET JAVA_VENDOR=BEA
            SET JAVA_HOME=C:\Program Files\Java\jdk1.7.0_01
            set WL_HOME=C:\Oracle\Middleware\wlserver_10.3
            set WLS_USER=weblogic
            set WLS_PW=Ravi1981
            set PRODUCTION_MODE=false
            set MEM_ARGS=-Xms512m uXmx512m
            call C:\Oracle\Middleware\wlserver_10.3\server\bin\installSvc.cmd
            ENDLOCAL

            After that I am getting below error::


            C:\>set CLASSPATH=C:\Oracle\MIDDLE~1\patch_wls1035\profiles\default\sys_manifest
            classpath\weblogicpatch.jar;C:\Oracle\MIDDLE~1\patch_oepe1050\profiles\default
            \sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_ocp360\profi
            les\default\sys_manifest_classpath\weblogic_patch.jar;C:\Program Files\Java\jdk1
            .7.0_01\lib\tools.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic_sp.jar;C
            :\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.jar;C:\Oracle\MIDDLE~1\modules\
            features\weblogic.server.modules_10.3.5.0.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\serv
            er\lib\webservices.jar;C:\Oracle\MIDDLE~1\modules\ORGAPA~1.1/lib/ant-all.jar;C:\
            Oracle\MIDDLE~1\modules\NETSFA~1.0_1/lib/ant-contrib.jar;
            ***************************************************
            * To start WebLogic Server, use the password *
            * assigned to the system user. The system *
            * username and password must also be used to *
            * access the WebLogic Server console from a web *
            * browser. *
            ***************************************************

            C:\>rem *** Set Command Line for service to execute within created JVM

            C:\>set CMDLINE="-jrocket -Xms512m ûXmx512m -classpath \"C:\Oracle\MIDDLE~1\pat
            ch_wls1035\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\
            MIDDLE~1\patch_oepe1050\profiles\default\sys_manifest_classpath\weblogic_patch.j
            ar;C:\Oracle\MIDDLE~1\patch_ocp360\profiles\default\sys_manifest_classpath\weblo
            gic_patch.jar;C:\Program Files\Java\jdk1.7.0_01\lib\tools.jar;C:\Oracle\MIDDLE~1
            \WLSERV~1.3\server\lib\weblogic_sp.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\
            weblogic.jar;C:\Oracle\MIDDLE~1\modules\features\weblogic.server.modules_10.3.5.
            0.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\webservices.jar;C:\Oracle\MIDDLE~
            1\modules\ORGAPA~1.1/lib/ant-all.jar;C:\Oracle\MIDDLE~1\modules\NETSFA~1.0_1/lib
            /ant-contrib.jar;\" -Dweblogic.Name=AdminServer -Dweblogic.management.username=w
            eblogic -Dweblogic.ProductionModeEnabled=false -Djava.security.policy=\"C:\Oracl
            e\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.policy\" weblogic.Server"

            C:\>rem *** Set up extrapath for win32 and win64 platform separately

            C:\>if "true" == "true" set EXTRAPATH=C:\Oracle\MIDDLE~1\WLSERV~1.3\server\nativ
            e\win\32;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\bin;C:\Program Files\Java\jdk1.7.0
            _01\jre\bin;C:\Program Files\Java\jdk1.7.0_01\bin;C:\Oracle\MIDDLE~1\WLSERV~1.3\
            server\native\win\32\oci920_8

            C:\>if "false" == "true" set EXTRAPATH=C:\Oracle\MIDDLE~1\WLSERV~1.3\server\nati
            ve\win\64\;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\bin;C:\Program Files\Java\jdk1.7
            .0_01\jre\bin;C:\Program Files\Java\jdk1.7.0_01\bin;C:\Oracle\MIDDLE~1\WLSERV~1.
            3\server\native\win\64\oci920_8

            C:\>if "false" == "true" set EXTRAPATH=C:\Oracle\MIDDLE~1\WLSERV~1.3\server\nati
            ve\win\x64\;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\bin;C:\Program Files\Java\jdk1.
            7.0_01\jre\bin;C:\Program Files\Java\jdk1.7.0_01\bin;C:\Oracle\MIDDLE~1\WLSERV~1
            .3\server\native\win\x64\oci920_8

            C:\>rem *** Install the service

            C:\>"C:\Oracle\MIDDLE~1\WLSERV~1.3\server\bin\beasvc" -install -svcname:"beasvc
            base_domain_AdminServer" -javahome:"C:\Program Files\Java\jdk1.7.0_01" -execdir:
            "C:\Oracle\Middleware\user_projects\domains\base_domain" -maxconnectretries:"" -
            host:"" -port:"" -extrapath:"C:\Oracle\MIDDLE~1\WLSERV~1.3\server\native\win\32;
            C:\Oracle\MIDDLE~1\WLSERV~1.3\server\bin;C:\Program Files\Java\jdk1.7.0_01\jre\b
            in;C:\Program Files\Java\jdk1.7.0_01\bin;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\na
            tive\win\32\oci920_8" -password:"Ravi1981" -cmdline:"-jrocket -Xms512m ûXmx512m
            -classpath \"C:\Oracle\MIDDLE~1\patch_wls1035\profiles\default\sys_manifest_cla
            sspath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_oepe1050\profiles\default\sys
            manifestclasspath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_ocp360\profiles\
            default\sys_manifest_classpath\weblogic_patch.jar;C:\Program Files\Java\jdk1.7.0
            _01\lib\tools.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic_sp.jar;C:\Or
            acle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.jar;C:\Oracle\MIDDLE~1\modules\feat
            ures\weblogic.server.modules_10.3.5.0.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\l
            ib\webservices.jar;C:\Oracle\MIDDLE~1\modules\ORGAPA~1.1/lib/ant-all.jar;C:\Orac
            le\MIDDLE~1\modules\NETSFA~1.0_1/lib/ant-contrib.jar;\" -Dweblogic.Name=AdminSer
            ver -Dweblogic.management.username=weblogic -Dweblogic.ProductionModeEnabled=fal
            se -Djava.security.policy=\"C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.po
            licy\" weblogic.Server"
            CreateService failed - The specified service already exists. (0x431)

            C:\>ENDLOCAL

            C:\>ENDLOCAL

            Then I verified weblogic service is created in the name of *"beasvc base_Domain_AdminServer"*

            After that Need to execute the below steps.

            set PATH=WL_HOME\server\bin;%PATH%
            beasvc -debug “beasvc base_Domain_AdminServer”
            here I am getting below error

            C:\Documents and Settings\Administrator>set PATH=WL_HOME\server\bin;%PATH%

            C:\Documents and Settings\Administrator>cd C:\Oracle\Middleware\wlserver_10.3

            C:\Oracle\Middleware\wlserver_10.3>cd server\bin

            C:\Oracle\Middleware\wlserver_10.3\server\bin>beasvc -debug "beasvc base_domain_
            AdminServer"

            Debugging service ....... ôbeasvc

            Unable to open Registry Key ....... System\CurrentControlSet\Services\ôbeasvc\Pa
            rameters

            C:\Oracle\Middleware\wlserver_10.3\server\bin>beasvc -debug beasvc base_domain_A
            dminServer

            Debugging service ....... beasvc

            Unable to open Registry Key ....... System\CurrentControlSet\Services\beasvc\Par
            ameters



            Please advice me on this.

            Thanks in advance.

            Regards,
            Ravi.
            • 4. Re: Setting Up a WebLogic Server Instance as a Windows Service in services.msc
              Mohammed Rayan-Oracle
              You are having two issues here;

              1. The service is already installed and you have tried to install it again

              CreateService failed - The specified service already exists. (0x431)

              2. You are trying to debug it by specifying the wrong service name

              It should be as per the syntax: "beasvc %DOMAIN_NAME%_%SERVER_NAME%"

              So, its DOMAIN_NAME=base_domain and SERVER_NAME=AdminServer in your case but you have tried to debug with the wrong service name

              "Then I verified weblogic service is created in the name of "beasvc base_Domain_AdminServer""

              You can try using the correct name and verify : beasvc -debug “beasvc base_domain_AdminServer”

              Moreover,you can check from the services control panel to verify if the service by above name is already present.you can use the services.msc shortcut from the start---->Run option for the same.
              • 5. Re: Setting Up a WebLogic Server Instance as a Windows Service in services.msc
                548396
                Hi 809364,

                Thank you very much for your replay .

                After executing the the command also "beasvc %DOMAIN_NAME%_%SERVER_NAME%" I am unable to to start the service

                please find the below message
                C:\Oracle\Middleware\wlserver_10.3\server\bin>net start beasvc base_Domain_Admin
                Server
                The service name is invalid.

                More help is available by typing NET HELPMSG 2185.


                C:\Oracle\Middleware\wlserver_10.3\server\bin>net start beasvc %DOMAIN_NAME%_%SE
                RVER_NAME%
                The service name is invalid.

                More help is available by typing NET HELPMSG 2185.


                C:\Oracle\Middleware\wlserver_10.3\server\bin>

                Best Regards,
                Ravi.
                • 6. Re: Setting Up a WebLogic Server Instance as a Windows Service in services.msc
                  Mohammed Rayan-Oracle
                  Why are you starting with wrong service name.

                  You can use the below one for your case;


                  C:\Oracle\Middleware\wlserver_10.3\server\bin>net start beasvc base_domain_AdminServer

                  Note: if you see the service name,its base_domain_AdminServer but you are using wrong one by beasvc base_Domain_AdminServer

                  D is in uppercase,whereas it should be base_domain :)
                  • 7. Re: Setting Up a WebLogic Server Instance as a Windows Service in services.msc
                    548396
                    Hi,

                    Sorry for troubling you. Please verify the below one.

                    C:\Oracle\Middleware\wlserver_10.3\server\bin>net start "beasvc base_domain_Admi
                    nServer"
                    The beasvc base_domain_AdminServer service is starting.
                    The beasvc base_domain_AdminServer service could not be started.

                    The service did not report an error.

                    More help is available by typing NET HELPMSG 3534.


                    C:\Oracle\Middleware\wlserver_10.3\server\bin>NET HELPMSG 3534

                    The service did not report an error.


                    C:\Oracle\Middleware\wlserver_10.3\server\bin>

                    Even though I am unable to start the services from start menu services.msc

                    here i am getting error"The beasvc base_domain_AdminServer service on local computer startrd and stopped.Some service stop automatically if they have no work to do,for example, the performance logs and alerts service."

                    Could you please help me on this.

                    Regards,
                    Ravi.
                    • 8. Re: Setting Up a WebLogic Server Instance as a Windows Service in services.msc
                      Mohammed Rayan-Oracle
                      Did you checked the AdminServer log and if there's nothing.You can consider using the below command and check if everything seems to be fine

                      <WL_HOME>\wlserver_10.3\server\bin> beasvc -debug "beasvc base_domain_AdminServer"
                      • 9. Re: Setting Up a WebLogic Server Instance as a Windows Service in services.msc
                        548396
                        Hi After executeing degug I am getting JAVA error
                        please advice me on this.

                        C:\Oracle\Middleware\wlserver_10.3>set PATH=C:\Oracle\Middleware\wlserver_10.3\s
                        erver\bin;

                        C:\Oracle\Middleware\wlserver_10.3>echo PATH
                        PATH

                        C:\Oracle\Middleware\wlserver_10.3>beasvc -debug "beasvc base_domain_AdminServer
                        "

                        Debugging service ....... beasvc base_domain_AdminServer

                        Command Line: ....... -jrocket -Xms512m √Xmx512m -classpath "C:\Oracle\MIDDLE~1
                        \patch_wls1035\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Ora
                        cle\MIDDLE~1\patch_oepe1050\profiles\default\sys_manifest_classpath\weblogic_pat
                        ch.jar;C:\Oracle\MIDDLE~1\patch_ocp360\profiles\default\sys_manifest_classpath\w
                        eblogic_patch.jar;C:\Program Files\Java\jdk1.7.0_01\lib\tools.jar;C:\Oracle\MIDD
                        LE~1\WLSERV~1.3\server\lib\weblogic_sp.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\
                        lib\weblogic.jar;C:\Oracle\MIDDLE~1\modules\features\weblogic.server.modules_10.
                        3.5.0.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\webservices.jar;C:\Oracle\MID
                        DLE~1\modules\ORGAPA~1.1/lib/ant-all.jar;C:\Oracle\MIDDLE~1\modules\NETSFA~1.0_1
                        /lib/ant-contrib.jar;" -Dweblogic.Name=AdminServer -Dweblogic.management.usernam
                        e=weblogic -Dweblogic.ProductionModeEnabled=false -Djava.security.policy="C:\Ora
                        cle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.policy" weblogic.Server

                        Current Directory: ....... C:\Oracle\Middleware\user_projects\domains\base_domai
                        n

                        Path: ....... C:\Oracle\MIDDLE~1\WLSERV~1.3\server\native\win\32;C:\Oracle\MIDDL
                        E~1\WLSERV~1.3\server\bin;C:\Program Files\Java\jdk1.7.0_01\jre\bin;C:\Program F
                        iles\Java\jdk1.7.0_01\bin;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\native\win\32\oci
                        920_8;C:\Oracle\Middleware\wlserver_10.3\server\bin;

                        Java Home: ....... C:\Program Files\Java\jdk1.7.0_01

                        Delay: ....... 0

                        sArgs.args[j] before merging tokens = C:\Oracle\MIDDLE~1\patch_wls1035\profiles\
                        default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_oepe1
                        050\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~
                        1\patch_ocp360\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Pro
                        gram
                        strtToken before merging tokens = Files\Java\jdk1.7.0_01\lib\tools.jar;C:\Oracle
                        \MIDDLE~1\WLSERV~1.3\server\lib\weblogic_sp.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\se
                        rver\lib\weblogic.jar;C:\Oracle\MIDDLE~1\modules\features\weblogic.server.module
                        s_10.3.5.0.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\webservices.jar;C:\Oracl
                        e\MIDDLE~1\modules\ORGAPA~1.1/lib/ant-all.jar;C:\Oracle\MIDDLE~1\modules\NETSFA~
                        1.0_1/lib/ant-contrib.jar;"
                        sArgs.args[j] after merging tokens = C:\Oracle\MIDDLE~1\patch_wls1035\profiles\d
                        efault\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_oepe10
                        50\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1
                        \patch_ocp360\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Prog
                        ram Files\Java\jdk1.7.0_01\lib\tools.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\li
                        b\weblogic_sp.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.jar;C:\Oracl
                        e\MIDDLE~1\modules\features\weblogic.server.modules_10.3.5.0.jar;C:\Oracle\MIDDL
                        E~1\WLSERV~1.3\server\lib\webservices.jar;C:\Oracle\MIDDLE~1\modules\ORGAPA~1.1/
                        lib/ant-all.jar;C:\Oracle\MIDDLE~1\modules\NETSFA~1.0_1/lib/ant-contrib.jar;"
                        Thread created successfully!
                        Unrecognized option: -jrocket

                        Error in java application .......

                        The following line contains specific error details .......
                        Unable to initialize the Java virtual machine!
                        C:\Oracle\Middleware\wlserver_10.3>
                        • 10. Re: Setting Up a WebLogic Server Instance as a Windows Service in services.msc
                          sandeep_singh
                          Remove -jrocket from :

                          set CMDLINE="-jrocket

                          thanks,
                          sandeep
                          • 11. Re: Setting Up a WebLogic Server Instance as a Windows Service in services.msc
                            548396
                            hi,

                            I am getting bellow error .

                            <Nov 10, 2012 12:04:08 PM GMT+05:30> <Info> <Management> <BEA-141107> <Version:
                            WebLogic Server 10.3.5.0 Fri Apr 1 20:20:06 PDT 2011 1398638 >
                            <Nov 10, 2012 12:04:14 PM GMT+05:30> <Error> <Management> <BEA-141244> <Schema v
                            alidation errors while parsing C:\Oracle\Middleware\user_projects\domains\base_d
                            omain\config\config.xml - C:\Oracle\Middleware\user_projects\domains\base_domain
                            \<unknown>:16:9: error: failed to load java type corresponding to t=oam-servlet-
                            authentication-filter-ia-providerType@http://xmlns.oracle.com/weblogic/security/
                            extension>
                            <Nov 10, 2012 12:04:16 PM GMT+05:30> <Error> <Management> <BEA-141244> <Schema v
                            alidation errors while parsing C:\Oracle\Middleware\user_projects\domains\base_d
                            omain\config\config.xml - C:\Oracle\Middleware\user_projects\domains\base_domain
                            \<unknown>:19:9: error: failed to load java type corresponding to t=oim-authenti
                            cation-providerType@http://xmlns.oracle.com/weblogic/security/extension>
                            <Nov 10, 2012 12:04:17 PM GMT+05:30> <Emergency> <Management> <BEA-141151> <The
                            admin server could not be reached at http://localhost:7001.>
                            <Nov 10, 2012 12:04:17 PM GMT+05:30> <Info> <Configuration Management> <BEA-1500
                            18> <This server is being started in managed server independence mode in the abs
                            ence of the admin server.>
                            <Nov 10, 2012 12:04:17 PM GMT+05:30> <Notice> <WebLogicServer> <BEA-000365> <Ser
                            ver state changed to STARTING>
                            <Nov 10, 2012 12:04:17 PM GMT+05:30> <Info> <WorkManager> <BEA-002900> <Initiali
                            zing self-tuning thread pool>
                            <Nov 10, 2012 12:04:18 PM GMT+05:30> <Notice> <LoggingService> <BEA-320400> <The
                            log file C:\Oracle\Middleware\user_projects\domains\base_domain\servers\AdminSe
                            rver\logs\AdminServer.log will be rotated. Reopen the log file if tailing has st
                            opped. This can happen on some platforms like Windows.>
                            <Nov 10, 2012 12:04:18 PM GMT+05:30> <Notice> <LoggingService> <BEA-320401> <The
                            log file has been rotated to C:\Oracle\Middleware\user_projects\domains\base_do
                            main\servers\AdminServer\logs\AdminServer.log00024. Log messages will continue t
                            o be logged in C:\Oracle\Middleware\user_projects\domains\base_domain\servers\Ad
                            minServer\logs\AdminServer.log.>
                            <Nov 10, 2012 12:04:18 PM GMT+05:30> <Notice> <Log Management> <BEA-170019> <The
                            server log file C:\Oracle\Middleware\user_projects\domains\base_domain\servers\
                            AdminServer\logs\AdminServer.log is opened. All server side log events will be w
                            ritten to this file.>
                            <Nov 10, 2012 12:04:30 PM GMT+05:30> <Error> <Security> <BEA-090870> <The realm
                            "myrealm" failed to be loaded: weblogic.security.service.SecurityServiceExceptio
                            n: com.bea.common.engine.ServiceInitializationException: com.bea.common.engine.S
                            ecurityServiceRuntimeException: [Security:097533]SecurityProvider service class
                            name for OIMAuthenticationProvider is not specified..
                            weblogic.security.service.SecurityServiceException: com.bea.common.engine.Servic
                            eInitializationException: com.bea.common.engine.SecurityServiceRuntimeException:
                            [Security:097533]SecurityProvider service class name for OIMAuthenticationProvi
                            der is not specified.
                            at weblogic.security.service.CSSWLSDelegateImpl.initializeServiceEngine(
                            CSSWLSDelegateImpl.java:341)
                            at weblogic.security.service.CSSWLSDelegateImpl.initialize(CSSWLSDelegat
                            eImpl.java:220)
                            at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.In
                            itializeServiceEngine(CommonSecurityServiceManagerDelegateImpl.java:1785)
                            at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.in
                            itializeRealm(CommonSecurityServiceManagerDelegateImpl.java:442)
                            at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.lo
                            adRealm(CommonSecurityServiceManagerDelegateImpl.java:840)
                            Truncated. see log file for complete stacktrace
                            Caused By: com.bea.common.engine.ServiceInitializationException: com.bea.common.
                            engine.SecurityServiceRuntimeException: [Security:097533]SecurityProvider servic
                            e class name for OIMAuthenticationProvider is not specified.
                            at com.bea.common.engine.internal.ServiceEngineImpl.findOrStartService(S
                            erviceEngineImpl.java:365)
                            at com.bea.common.engine.internal.ServiceEngineImpl.findOrStartService(S
                            erviceEngineImpl.java:315)
                            at com.bea.common.engine.internal.ServiceEngineImpl.lookupService(Servic
                            eEngineImpl.java:257)
                            at com.bea.common.engine.internal.ServicesImpl.getService(ServicesImpl.j
                            ava:72)
                            at weblogic.security.service.internal.WLSIdentityServiceImpl.initialize(
                            WLSIdentityServiceImpl.java:46)
                            Truncated. see log file for complete stacktrace
                            Caused By: com.bea.common.engine.SecurityServiceRuntimeException: [Security:0975
                            33]SecurityProvider service class name for OIMAuthenticationProvider is not spec
                            ified.
                            at com.bea.common.security.internal.legacy.service.SecurityProviderImpl.
                            init(SecurityProviderImpl.java:42)
                            at com.bea.common.engine.internal.ServiceEngineImpl.findOrStartService(S
                            erviceEngineImpl.java:363)
                            at com.bea.common.engine.internal.ServiceEngineImpl.findOrStartService(S
                            erviceEngineImpl.java:315)
                            at com.bea.common.engine.internal.ServiceEngineImpl.lookupService(Servic
                            eEngineImpl.java:257)
                            at com.bea.common.engine.internal.ServicesImpl.getService(ServicesImpl.j
                            ava:72)
                            Truncated. see log file for complete stacktrace
                            >
                            <Nov 10, 2012 12:04:30 PM GMT+05:30> <Notice> <Security> <BEA-090082> <Security
                            initializing using security realm myrealm.>
                            <Nov 10, 2012 12:04:30 PM GMT+05:30> <Critical> <WebLogicServer> <BEA-000362> <S
                            erver failed. Reason:

                            There are 1 nested errors:

                            weblogic.security.service.SecurityServiceRuntimeException: [Security:090399]Secu
                            rity Services Unavailable
                            at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.do
                            BootAuthorization(CommonSecurityServiceManagerDelegateImpl.java:916)
                            at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.in
                            itialize(CommonSecurityServiceManagerDelegateImpl.java:1050)
                            at weblogic.security.service.SecurityServiceManager.initialize(SecurityS
                            erviceManager.java:873)
                            at weblogic.security.SecurityService.start(SecurityService.java:141)
                            at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
                            at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
                            at weblogic.work.ExecuteThread.run(ExecuteThread.java:178)

                            >
                            <Nov 10, 2012 12:04:31 PM GMT+05:30> <Notice> <WebLogicServer> <BEA-000365> <Ser
                            ver state changed to FAILED>
                            <Nov 10, 2012 12:04:31 PM GMT+05:30> <Error> <WebLogicServer> <BEA-000383> <A cr
                            itical service failed. The server will shut itself down>
                            <Nov 10, 2012 12:04:31 PM GMT+05:30> <Notice> <WebLogicServer> <BEA-000365> <Ser
                            ver state changed to FORCE_SHUTTING_DOWN>


                            Regards,
                            Ravi.
                            • 12. Re: Setting Up a WebLogic Server Instance as a Windows Service in services.msc
                              sandeep_singh
                              Hi Ravi,

                              The error related to WLS Windows service is now resolved .

                              Now the error you are receiving is :

                              <Nov 10, 2012 12:04:30 PM GMT+05:30> <Error> <Security> <BEA-090870> <The realm
                              "*myrealm*" failed to be loaded: weblogic.security.service.SecurityServiceExceptio
                              n: com.bea.common.engine.ServiceInitializationException: com.bea.common.engine.S
                              ecurityServiceRuntimeException: [Security:097533]SecurityProvider service class
                              name for OIMAuthenticationProvider is not specified..

                              This error trace shows that Some OIMAuthenticationProvideris configured for the domain , however the classes required for this authentication provider are not loaded properly .
                              you need to compare the classpath values for the server when it is started as windows service and when it is started normally .

                              Thanks,
                              Sandeep
                              • 13. Re: Setting Up a WebLogic Server Instance as a Windows Service in services.msc
                                Kalyan Pasupuleti-Oracle
                                Hi Ravi,

                                Try this option.

                                Check if the "Master First" option is enabled (default: false).


                                1. Log in into Admin Console
                                2. Click on <Domain_name>
                                3. Select "Security" tab
                                4. Select "Embedded LDAP" sub tab
                                5. Uncheck "Master First" select box
                                6. Save
                                7. Activate changes (if necessary)



                                Regards,
                                Kal
                                • 14. Re: Setting Up a WebLogic Server Instance as a Windows Service in services.msc
                                  548396
                                  Currently it is (Master First) in unchecked status only.