2 Replies Latest reply: Nov 6, 2012 7:20 AM by Michael Ferrante-Oracle RSS

    FRM-92160:Fatal error:Webclient version too old

    972741
      Somebody pls assist.

      I am running 11gR2 on Redhat, the forms can run on ie9 but can't on ie8. I am getting "FRM-92160:Fatal error:Webclient version too old". Anything I didn't do? I need this wotking as well on ie8.

      Any help would be appreciated.

      regards

      Mo
        • 1. Re: FRM-92160:Fatal error:Webclient version too old
          Christian Erlinger
          Did you try to turn it off and on again? Err...I mean: clear the jar cache on the machine where it's not working and try again.

          cheers
          • 2. Re: FRM-92160:Fatal error:Webclient version too old
            Michael Ferrante-Oracle
            Fortunately, the "Web client too old" or "Web client too new" errors are very accurate and clear. When a Forms application attempts to start, one of the first things which occurs is a verification that the client applet (frmall.jar) is of the same version as the server side runtime which is about to host it. "Web client too old", means that the client jar is of an older version than the server side runtime (i.e. frmweb.exe). This can occur if more than one Forms version has been accessed from the same server. Remember that the jar files are cached on the client (in the JRE). So, if you were to run something like v10 from serverA then attempt to run v11 from the same server, you likely would end up with a client too old error. The same would be true if you first try to run 11.1.1 then attempt to access 11.1.2 from the same machine. The issue can also occur if for some reason the jar files in the installation were not patched during a patch installation. This would be rare, but could occur if the patch installation failed during the process. It could also occur if you copies old files into the installation. This is never a good idea.

            So, as mentioned, start by clearing the JRE cache and retesting.

            1. Close ALL open browsers.
            2. Open the JRE Control Panel (found on the Windows Control Panel).
            3. On the General tab, click on "Settings..."
            4. Then click on "Delete files..."
            5. Then click on "Ok".
            6. Exit the JRE Control Panel and retest.

            Important to note is that JRE7 is NOT supported with 11.1.2.0. Be sure that you are using JRE6. If you have JRE7 installed, I would recommend closing ALL open browsers and uninstalling it. You should have only JRE6 installed before testing.