2 Replies Latest reply: Nov 6, 2012 8:54 AM by 953835 RSS

    Defined another LogServer but it is not coming up

    953835
      <logserver id="LogServer_xxx" host-id="ITLHost" port="6292">
      <properties>
      <property name="numLogBackups" value="${DEFAULT_NUM_BACKUPS}" />
      <property name="targetReportGenDir" value="./reports/Xxx/input" />
      <property name="targetReportGenHostId" value="ITLHost" />
      </properties>
      <log-dir>./logs/logservers/Xxx/LogServer</log-dir>
      <output-dir>./logs/logserver_output/Xxx</output-dir>
      <startup-timeout>120</startup-timeout>
      <gzip>false</gzip>
      </logserver>

      Defined another log server, but I there is no listener on port 6292.
      Did "run command.sh --update-definition" to load the new AppConfig.xml
      Then I used "eaccmd.sh describe-app --app <app_id>" to get the configs in memory, and I see this definition (in a differernt format).
      Don't get any errors or warnings in any logs.
      Ideas?
        • 1. Re: Defined another LogServer but it is not coming up
          Branchbird - Pat
          Joe,

          Did you start it up after creating it?

          Issuing the following ought to do it:

          runcommand.sh LogServer_xxx start

          Going forward, you can modify your BaselineUpdate script to cycle this log server as well as your original one when the index is refreshed.

          Regards,

          Patrick Rafferty
          http://branchbird.com
          • 2. Re: Defined another LogServer but it is not coming up
            953835
            That was the problem, thanks.

            This also helped:
            ./runcommand.sh --print-status