This discussion is archived
8 Replies Latest reply: Nov 6, 2012 11:43 AM by user12061096 RSS

11.2.0.3 installation on oel 6.3 installed 32 bit binaries

user12061096 Newbie
Currently Being Moderated
cat /etc/redhat-release
shows
Red Hat Enterprise Linux Server release 6.3 (Santiago)

uname -a
.... 2.6.39-200.24.1.e16uek.x86_64 ..... x86_64 GNU/LINUX

uname -m
x86_64

We're just starting to test oracle installs on rhel 6.3.
We're installing oracle 11.2.0.3 x86_64 linux. The installation went smooth but when I went to install PSU 13923374 it complained about invalid version

Patch .... is not applicable on current platform

a look into oraclehomeproperties.xml show

ARU_ID_DESCRIPTION>Linux x86<
and
file oracle,sqlldr etc all show up as 32bit.

I created a db successfully and v$database show 32 bit.

So oracle compiled everything as 32bit which I didn't even know was possible for x86_64. I successfully installed the same zip files for Linux 5.6 and it shows 64 bit.

I'm wondering how to fix this and where oracle decided it was 32 bit. I'm surprised it even compiled this way. I guess I'm missing a library somewhere but I'm not sure on what to look for.

By fix it I mean I will deinstall and then reinstall but I want it to compile as 64 bit.

Any help is greatly appreciated.

Thanks

Mike

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points