3 Replies Latest reply: Nov 9, 2012 8:08 AM by CKPT RSS

    log is not applied, subsequent log applied are "yes"

    user8875620
      Hi all,

      I am building a new standby.
      It is brand new, and I have turned on the managed recovery for the first time after restoring my database.

      --> ALTER DATABASE RECOVER MANAGED STANDBY DATABASE DISCONNECT FROM SESSION;


      Why does the first line show "NO" for applied log? (and all the logs after it shows "YES"?)

      Is there something wrong, or can I ignore this as it is normal?


      SQL> SELECT sequence#, first_time, next_time, applied
      FROM v$archived_log
      ORDER BY sequence#; 2 3

      SEQUENCE# FIRST_TIME NEXT_TIME APP
      ---------- -------------------- -------------------- ---
      2653893 30-OCT-2012 23:03:21 30-OCT-2012 23:03:25 NO
      2653894 30-OCT-2012 23:03:25 30-OCT-2012 23:23:04 YES
      2653895 30-OCT-2012 23:23:04 30-OCT-2012 23:23:28 YES
      2653896 30-OCT-2012 23:23:28 30-OCT-2012 23:26:32 YES
      2653897 30-OCT-2012 23:26:32 30-OCT-2012 23:26:49 YES
      2653898 30-OCT-2012 23:26:49 30-OCT-2012 23:31:05 YES
      2653899 30-OCT-2012 23:31:05 31-OCT-2012 00:00:41 YES
      2653900 31-OCT-2012 00:00:41 31-OCT-2012 00:31:04 YES
      2653901 31-OCT-2012 00:31:04 31-OCT-2012 01:01:03 YES
      2653902 31-OCT-2012 01:01:03 31-OCT-2012 01:31:17 YES

      Edited by: user8875620 on Nov 8, 2012 11:20 PM
        • 1. Re: log is not applied, subsequent log applied are "yes"
          CKPT
          user8875620 wrote:
          Hi all,

          I am building a new standby.
          It is brand new, and I have turned on the managed recovery for the first time after restoring my database.

          --> ALTER DATABASE RECOVER MANAGED STANDBY DATABASE DISCONNECT FROM SESSION;


          Why does the first line show "NO" for applied log? (and all the logs after it shows "YES"?)

          Is there something wrong, or can I ignore this as it is normal?


          SQL> SELECT sequence#, first_time, next_time, applied
          FROM v$archived_log
          ORDER BY sequence#; 2 3

          SEQUENCE# FIRST_TIME NEXT_TIME APP
          ---------- -------------------- -------------------- ---
          2653893 30-OCT-2012 23:03:21 30-OCT-2012 23:03:25 NO
          2653894 30-OCT-2012 23:03:25 30-OCT-2012 23:23:04 YES
          2653895 30-OCT-2012 23:23:04 30-OCT-2012 23:23:28 YES
          2653896 30-OCT-2012 23:23:28 30-OCT-2012 23:26:32 YES
          2653897 30-OCT-2012 23:26:32 30-OCT-2012 23:26:49 YES
          2653898 30-OCT-2012 23:26:49 30-OCT-2012 23:31:05 YES
          2653899 30-OCT-2012 23:31:05 31-OCT-2012 00:00:41 YES
          2653900 31-OCT-2012 00:00:41 31-OCT-2012 00:31:04 YES
          2653901 31-OCT-2012 00:31:04 31-OCT-2012 01:01:03 YES
          2653902 31-OCT-2012 01:01:03 31-OCT-2012 01:31:17 YES

          Edited by: user8875620 on Nov 8, 2012 11:20 PM
          What is the version you are using?
          Are you using Data Guard broker?
          Assuming you are not using Real-time apply.

          Basically there are so many bugs with the views specific to Data Guard they are v$archived_gap, v$archived_log depending on the environments.
          One of note for this bug.
          'APPLIED'-Column not updated if Heartbeat-ARCH hangs [ID 1369630.1]     
          v$archived_log: applied column is not marked if recovery applied the redo from SRL [ID 1481927.1]

          Thanks
          • 2. Re: log is not applied, subsequent log applied are "yes"
            user8875620
            This is in 9.2.0.6.
            Broker is not used.
            regarding Real time apply - I have a delay of xxx hours.


            I forgot to mention, this query is run on standby database site.

            Edited by: user8875620 on Nov 9, 2012 4:34 AM
            • 3. Re: log is not applied, subsequent log applied are "yes"
              CKPT
              user8875620 wrote:
              This is in 9.2.0.6.
              Broker is not used.
              regarding Real time apply - I have a delay of xxx hours.


              I forgot to mention, this query is run on standby database site.

              Edited by: user8875620 on Nov 9, 2012 4:34 AM
              No more support to this version. You cannot log SR.
              Is there something wrong, or can I ignore this as it is normal?
              Of course you can ignore when the ahead archives already applied on standby. you can try to bounce database once and start MRP then see. Or else still you can ignore.