5 Replies Latest reply: Nov 9, 2012 8:17 AM by User245677 RSS

    OIM 11g R2: Organization UDFs problem

    User245677
      Hi all,
      I tried to create an UDF NOT for User entity but for Organization entity.
      In my environment OIM is installed in 11g R2 version (11.1.2.0.0).

      I'm not completely new about this activity with this OIM version because I created some UDFs for User entity also and all of them work fine.

      To customize the Organization entity, I followed Oracle documentation fitting it for Organization entity instead User one, but I get an error.
      Here high-level steps that I've done:
      1. created and activated a sandbox
      2. looked for Organization form
      3. modified it adding MyCustomField
      4. opened Create Organization Form
      5. customized it adding MyCustomFild
      6. created a new organization MyTestOrg

      Note: for steps 1, 2, 3 I followed this document http://docs.oracle.com/cd/E27559_01/admin.1112/e27149/customattr.htm#CHDDIGCI, while for steps 4 and 5 this one http://docs.oracle.com/cd/E27559_01/admin.1112/e27149/customattr.htm#BABGDEIC

      Once I created the new Organization I checked the result, but closing and opening again MyTestOrg details, my custom field is empty.
      I also checked at database side and I noticed that the value specified for MyCustmField of MyTestOrg was saved to Xellerate Users default organization.
      I executed this test for four times with the same result.

      To verifiy this behaviour, I've done the following test:
      1. at database side, I manually updated MyCustomField for MyTestOrg
      2. at database side, I manually updated MyCustomField for Xellerate Users default org

      Once executed the first test, I verified that using OIM web interface the value specified does not appear in any organizations.
      While once executed the second test, I verified that the value specified appear in all of the organizations. It's seams that Xellerate Users organization modification is spawned for all organizations.

      It sounds like a bug.....

      Do you have any suggestions?

      Thanks
      Daniele
        • 1. Re: OIM 11g R2: Organization UDFs problem
          user12005063
          Is your sandbox active when you try to view/update the new field for the new organization. Did you try publishing the sandbox?
          • 2. Re: OIM 11g R2: Organization UDFs problem
            Nishith Nayan
            yes, this is bug. we had encounter the same earlier. Hope It is known to oracle as well, raise SR and get the oracle answer if they are ready with the fixes
            • 3. Re: OIM 11g R2: Organization UDFs problem
              User245677
              Hi,
              thanks for your reply. The sandbox is active when I try to modify the Organization custom field. I didn't publish it because I would test the customization before publishing the sandbox.

              Bye
              Daniele
              • 4. Re: OIM 11g R2: Organization UDFs problem
                User245677
                Hi Nayan,
                you help me one more time :) Thanks!
                I already raised a SR to Oracle. I hope they will provide me a solution as soon as possible.

                I'll let you know as soon as they reply me!

                Stay tuned ;)
                Daniele
                • 5. Re: OIM 11g R2: Organization UDFs problem
                  User245677
                  Hi,
                  for anybody who's interested, I have some news about this problem.
                  Here the answer that support provides to me:
                  check if the following doc addition helps you with the issue?

                  http://docs.oracle.com/cd/E27559_01/admin.1112/e27149/customattr.htm#CHDDIGCI,

                  Section "7.5 Adding a Custom Attribute" in OIM Administration Guide needs to be updated as follows:

                  Step 12, add the following:
                  For Organizations (includes create and modify organization), select Data Component - Organization

                  Step 13 - we need to mention all the VOs that they're supposed to select based on selection they made in Step 12. We need to add the following: For View User Details, select UserVO1
                  For Create User, select userVO
                  For Modify User, select userVO
                  For Manage Roles (create / modify role), select RoleDetailsVO
                  For Organizations (create / modify organization), select EditOrgVO

                  Step 18b - the EL provided only works for user page. On other pages they're
                  basically supposed to copy the EL of valueChangeListener property from any
                  other existing field on the form.
                  With this suggestions, the initial problem was resolved, but a strange behaviour still occurs.
                  Infact, after the new organization creation (with UDF field valorized), if I try to modify the value for custom field MyCustomFiled (for example from "MyCustomValue_2" to "MyCustomValue_1"), the button Apply remain inactive (so I can't save the modification - see screenshot "inactive-apply-button.png"). It become active only if I modify a standard field also (for example Organization Name or Type).

                  About this last problem, the support needs to check it.

                  I'm waiting an answer.

                  I'll give you news as soon as possible.

                  Bye
                  Daniele