6 Replies Latest reply on Nov 9, 2012 7:21 PM by Jasmine Pauline-Oracle

    PlanningSecurity Question

      I have a small application in which users are all assigned the "Planner" role. There is not data level secruity, and no security applied to individual data forms - all users are allowed to see all forms.

      Recently, I created a new form in Planning and a new report in HFR. However, none of the users, except those in the administrator group can see this form. Initially I did not assign any specific access for the form, since I figured by default all those in the "Planner" role can see all forms anyway, but that turned out not to be the case.

      I then went ahead and added a specific user or two to be able to see that form. Still, they can't see the form that I created.

      Am I missing a step here?

      Pls advise. thanks.
        • 1. Re: PlanningSecurity Question
          There is no way planners could have access without security being defined on the dimensions and forms as by default they will not see anything unless explicitly grantes access.

          Therefore you probably have granted all users some kind of access on dimensions and forms probably via a group, and once you assign your new form and report they will be able to see it. Check what groups they are in via Shared Services and then check the security report for that group on planning. Chances are you will see that the group has permissions assigned to it.

          • 2. Re: PlanningSecurity Question
            Thanks for the reply. You were right - I was looking in the wrong place. This is what I found, though it still doesn't seem to solve my problem:

            There is a group named "PLANNERS" in Shared Services. This group has been assigned the roles of Planner for the Planning application in question.

            The group "PLANNERS" has been assigned WRITE access to the FORMS folder. All data forms in the application, including the one I created reside in the FORMS folder.

            The group "PLANNERS" has access to all dimensions.

            Still, users in the PLANNERS group cannot see the form I created for some reason. I also tried assigning access to that form itself, still no luck.

            Any suggestions?
            • 3. Re: PlanningSecurity Question
              Jasmine Pauline-Oracle
              Can you try providing user level access instead of the group and check if that helps?

              • 4. Re: PlanningSecurity Question
                thanks for the response - I tried that as well, still apparently no luck. Only users who have been assigned the Admin role can see it for some reason.
                • 5. Re: PlanningSecurity Question
                  is "migrate identities" worth giving a try?
                  • 6. Re: PlanningSecurity Question
                    Jasmine Pauline-Oracle
                    Yes, you can give that a try.

                    Also, have you refreshed security from Planning to Essbase?
                    Are the filters visible in Essbase?