This discussion is archived
3 Replies Latest reply: Nov 12, 2012 1:07 AM by Helios-GunesEROL RSS

could not find libjava.so when runInstaller 11g for PA-RISC on B.11.31 ia64

234267 Newbie
Currently Being Moderated
I am installing Oracle 11gR2 for PA-RISC on hp-ux B11.31 ia64.
When starting runInstaller, I got error after checking for DISPLAY:
Error: could not find libjava.so
Error: could not find Java 2 Runtime Environment.

I found libjava.so in /opt/java1.5/jre/lib/IA64W/libjava.so and symbolic link to /usr/lib/pa20_64/libjava.so. I got this directory (/usr/lib/pa20_64) from chatr on database/.oui.
Also tried setting SHLIB_PATH (LD_LIBRARY_PATH was unset by runInstaller), still got the same error. I also tried setting JAVA_HOME to java1.5 or java1.5/jre, nothing changed.
Searching the OTN does not find anything solution. Can someone shed some light on it? Thanks.

By the way, we use PA-RISC software instead of IA64 for some other reasons. We assume using the PA-RISC software on IA64 platform will be OK.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points